<!DOCTYPE html><html
class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><link
rel="stylesheet" type="text/css" href="https://k9v2t9s8.stackpathcdn.com/wp-content/cache/minify/10aba.default.include.11c0ae.css" media="all" /> <script async type="text/javascript" src="https://k9v2t9s8.stackpathcdn.com/wp-content/cache/minify/10aba.single.include.5b461f.js"></script> <meta
charset="UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="profile" href="http://gmpg.org/xfn/11"><link
rel="pingback" href="https://linuxtechlab.com/xmlrpc.php"><title>How to install ClamAV (Antivirus) &amp; ClamTK on Linux - LinuxTechLab</title> <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script> <meta
name="description" content="In this Beginner&#039;s friendly tutorial, we will learn to install ClamAV, which is an open source antivirus application and it&#039;s GUI ClamTK."/><link
rel="canonical" href="https://linuxtechlab.com/install-clamav-clamtk-linux/" /><link
rel="publisher" href="https://plus.google.com/+linuxtechlab"/><meta
property="og:locale" content="en_US" /><meta
property="og:type" content="article" /><meta
property="og:title" content="How to install ClamAV (Antivirus) &amp; ClamTK on Linux - LinuxTechLab" /><meta
property="og:description" content="In this Beginner&#039;s friendly tutorial, we will learn to install ClamAV, which is an open source antivirus application and it&#039;s GUI ClamTK." /><meta
property="og:url" content="https://linuxtechlab.com/install-clamav-clamtk-linux/" /><meta
property="og:site_name" content="LinuxTechLab" /><meta
property="article:publisher" content="https://www.facebook.com/linuxtechlab/" /><meta
property="article:author" content="https://www.facebook.com/shujat.hus" /><meta
property="article:tag" content="antivirus" /><meta
property="article:tag" content="clam" /><meta
property="article:section" content="How To&#039;s" /><meta
property="article:published_time" content="2018-09-12T10:51:06+05:30" /><meta
property="article:modified_time" content="2018-09-12T10:49:30+05:30" /><meta
property="og:updated_time" content="2018-09-12T10:49:30+05:30" /><meta
property="og:image" content="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/how-to-clam-av.jpg" /><meta
property="og:image:secure_url" content="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/how-to-clam-av.jpg" /><meta
property="og:image:width" content="720" /><meta
property="og:image:height" content="340" /><meta
property="og:image:alt" content="install clamav" /><meta
name="twitter:card" content="summary" /><meta
name="twitter:description" content="In this Beginner&#039;s friendly tutorial, we will learn to install ClamAV, which is an open source antivirus application and it&#039;s GUI ClamTK." /><meta
name="twitter:title" content="How to install ClamAV (Antivirus) &amp; ClamTK on Linux - LinuxTechLab" /><meta
name="twitter:site" content="@LinuxTechLab" /><meta
name="twitter:image" content="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/how-to-clam-av.jpg" /><meta
name="twitter:creator" content="@linuxtechlab" /> <script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Person","url":"https:\/\/linuxtechlab.com\/","sameAs":["https:\/\/www.facebook.com\/linuxtechlab\/","https:\/\/www.linkedin.com\/in\/linux-techlab-9963b9138\/","https:\/\/plus.google.com\/+linuxtechlab","https:\/\/in.pinterest.com\/techlablinux\/","https:\/\/twitter.com\/LinuxTechLab"],"@id":"#person","name":"Shusain"}</script> <link
rel='dns-prefetch' href='//s0.wp.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Feed" href="https://linuxtechlab.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Comments Feed" href="https://linuxtechlab.com/comments/feed/" /><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; How to install ClamAV (Antivirus) &#038; ClamTK on Linux Comments Feed" href="https://linuxtechlab.com/install-clamav-clamtk-linux/feed/" />
 <script type="text/javascript" data-cfasync="false">var mi_version         = '7.1.0';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-66906913-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-66906913-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('set', 'anonymizeIp', true);
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxtechlab.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link
rel='stylesheet' id='cookie-consent-style-css'  href='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/uk-cookie-consent/assets/css/style.css' type='text/css' media='all' /><link
rel='stylesheet' id='dashicons-css'  href='https://k9v2t9s8.stackpathcdn.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' /><style id='hueman-main-style-inline-css' type='text/css'>body { font-family:Georgia, serif;font-size:1.00rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }.boxed #wrapper, .container-inner { max-width: 1120px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1120px;
                }
              }::selection { background-color: #67597a; }
::-moz-selection { background-color: #67597a; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #67597a; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #67597a; }.post-format .format-container { border-color: #67597a; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #67597a!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #6e8894; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #6e8894; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #6e8894; }
.post-comments span:before { border-right-color: #6e8894; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #67597a}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #67597a; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #67597a; background-color: rgba(103,89,122,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #67597a; background-color: rgba(103,89,122,0.95) }#header { background-color: #7c8483; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #7c8483; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: ; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: ; }
}
        #footer-bottom { background-color: #565656; }.site-title a img { max-height: 100px; }img { -webkit-border-radius: 10px; border-radius: 10px; }body { background-color: #34495e; }</style><style id='jetpack_facebook_likebox-inline-css' type='text/css'>.widget_facebook_likebox {
	overflow: hidden;
}</style><link
rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css' type='text/css' media='all' /><link
rel='stylesheet' id='social-logos-css'  href='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css' type='text/css' media='all' /> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","is_debug_mode":"false","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"","home_url":"https:\/\/linuxtechlab.com","track_download_as":"event","internal_label":"int","hash_tracking":"false"};</script> <script type='text/javascript' src='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js'></script> <script type='text/javascript' src='https://k9v2t9s8.stackpathcdn.com/wp-content/themes/hueman/assets/front/js/libs/mobile-detect.min.js'></script> <link
rel='https://api.w.org/' href='https://linuxtechlab.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxtechlab.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://k9v2t9s8.stackpathcdn.com/wp-includes/wlwmanifest.xml" /><link
rel='shortlink' href='https://wp.me/p8pupD-uM' /><link
rel="alternate" type="application/json+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Finstall-clamav-clamtk-linux%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Finstall-clamav-clamtk-linux%2F&#038;format=xml" /> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-2507344487072720",
    enable_page_level_ads: true
  });</script> <style id="ctcc-css" type="text/css" media="screen">#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linuxtechlab.com/?wordfence_lh=1&hid=2130BB652C5BC3FBE501C1CFA3835154');</script> <link
rel='dns-prefetch' href='//v0.wordpress.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]> <script src="https://k9v2t9s8.stackpathcdn.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script> <script src="https://k9v2t9s8.stackpathcdn.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script> <![endif]--><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><meta
name="onesignal" content="wordpress-plugin"/><link
rel="manifest"
href="https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=264261321638"/> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linuxtechlab.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '4aa7dae9-6300-464c-a817-ed5ca97dd617';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "LinuxTechLab";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing !!!";
oneSignal_options['path'] = "https://linuxtechlab.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5ccade99-0f35-4775-9ae0-5e2c3bfd110b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Click to subscribe notifications';
oneSignal_options['notifyButton']['text']['tip.state.unsubscribed'] = 'Subscribe to notification';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You have subscribed';
oneSignal_options['notifyButton']['text']['tip.state.blocked'] = 'You have blocked notifications';
oneSignal_options['notifyButton']['text']['message.action.subscribed'] = 'Thanks for subscribing !!!';
oneSignal_options['notifyButton']['text']['message.action.resubscribed'] = 'You are subscribed !!!';
oneSignal_options['notifyButton']['text']['message.action.unsubscribed'] = 'Did we do something wrong ???';
oneSignal_options['notifyButton']['text']['dialog.main.title'] = 'Manafe site notifications';
oneSignal_options['notifyButton']['text']['dialog.main.button.subscribe'] = 'SUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.main.button.unsubscribe'] = 'UNSUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.blocked.title'] = 'Unblock Notifications';
oneSignal_options['notifyButton']['text']['dialog.blocked.message'] = 'Follow instructions  to allow notifications';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><link
rel="icon" href="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-32x32.png" sizes="32x32" /><link
rel="icon" href="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-192x192.png" sizes="192x192" /><link
rel="apple-touch-icon-precomposed" href="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-180x180.png" /><meta
name="msapplication-TileImage" content="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-270x270.png" /><style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
.last-updated {
    font-size: small;
    text-transform: uppercase;
    background-color: #fffdd4;
} 

.single-post-meta{
display:none;
}

body, html {
color: #000000;
}

.entry {
    color: #000000 !important;
}</style></head><body
class="post-template-default single single-post postid-1908 single-format-standard wp-custom-logo ctcc-exclude-OC col-2cl boxed topbar-enabled mobile-sidebar-hide-s2 header-desktop-sticky header-mobile-sticky gecko"><div
id="wrapper">
<header
id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav
class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1"><div
class="mobile-title-logo-in-header"><p
class="site-title"><a
class="custom-logo-link" href="https://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page">LinuxTechLab</a></p></div><div
class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false"><div
class="ham__navbar-span-wrapper">
<span
class="line line-1"></span>
<span
class="line line-2"></span>
<span
class="line line-3"></span></div></div><div
class="nav-text"></div><div
class="nav-wrap container"><ul
class="nav container-inner group mobile-search"><li><form
method="get" class="searchform themeform" action="https://linuxtechlab.com/"><div>
<input
type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></li></ul><ul
id="menu-top-navigation" class="nav container-inner group"><li
id="menu-item-65" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
id="menu-item-1994" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
id="menu-item-2289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
id="menu-item-269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav>
<nav
class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2"><div
class="nav-text"></div><div
class="topbar-toggle-down">
<i
class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i
class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i></div><div
class="nav-wrap container"><ul
id="menu-top-navigation-1" class="nav container-inner group"><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div><div
id="topbar-header-search" class="container"><div
class="container-inner"><div
class="toggle-search"><i
class="fas fa-search"></i></div><div
class="search-expand"><div
class="search-expand-inner"><form
method="get" class="searchform themeform" action="https://linuxtechlab.com/"><div>
<input
type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></div></div></div></div>
</nav><div
class="container group"><div
class="container-inner"><div
class="group pad central-header-zone"><div
class="logo-tagline-group"><p
class="site-title"><a
class="custom-logo-link" href="https://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page">LinuxTechLab</a></p></div><div
id="header-widgets"><div
id="text-18" class="widget widget_text"><div
class="textwidget"><p><br
/>
<br
/>
<ins
class="adsbygoogle"
style="display:inline-block;width:620px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="7709195798"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></div>
<nav
class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3"><div
class="nav-text"></div><div
class="nav-wrap container"><ul
id="menu-top-navigation-2" class="nav container-inner group"><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav></div></div></header><div
class="container" id="page"><div
class="container-inner"><div
class="main"><div
class="main-inner group">
<section
class="content"><div
class="page-title pad group"><ul
class="meta-single group"><li
class="category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> <span>/</span> <a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></li></ul></div><div
class="pad group"><div
class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; clear: both;'><ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div>
<article
class="post-1908 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos tag-antivirus tag-clam"><div
class="post-inner group"><h1 class="post-title entry-title">How to install ClamAV (Antivirus) &#038; ClamTK on Linux</h1><p
class="post-byline">by   <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot;
Published <time
class="published" datetime="September 12, 2018">September 12, 2018</time>
&middot; Updated <time
class="updated" datetime="September 12, 2018">September 12, 2018</time></p><div
class="clear"></div><div
class="entry themeform"><div
class="entry-inner"><p>Linux is known for its high standards of security &amp; there are very low amount of viruses that has been known to infect a Linux system. But in the recent times as technology is moving forward at rapid pace, we are seeing that trojans, malware etc are also making it to Linux space &amp; many users, especially enterprises with production servers on Linux, are looking for a Antivirus programs for secure their installations.</p><p>To address such a concern, we will discuss in this article about how to install Clam Antiivirus &amp; its GUI ClamTK. Clam is an open source antivirus engine that is used to detect viruses, trojans &amp; other malwares. It was initially designed as email scanning gateway on Unix but it has since then evolved as a solution for securing other OS &amp; applications.</p><p><strong>Recommended Read: <a
href="https://linuxtechlab.com/easy-way-to-integrate-apache-with-modsecurity-on-ubuntu/"><span
style="color: #993300;">Easy way to integrate Apache with modsecurity on Ubuntu</span></a></strong></p><div
class='code-block code-block-2' style='margin: 8px 0; clear: both;'><ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>Also Read: <a
href="https://linuxtechlab.com/create-free-apache-ssl-certificate-lets-encrypt-on-centos-rhel/"><span
style="color: #993300;">Create a free Apache SSL certificate with Let’s Encrypt on CentOS &amp; RHEL</span></a></strong></p><p>ClamAV is basically a CLI based program but in this tutorial, we will learn to setup Clam with a GUI frontend known as Clamtk &amp; will also setup a daily scan of the Centos/RHEL &amp; Ubuntu systems.</p><p>&nbsp;</p><h2>Pre-requisites</h2><h3>For RHEL/CentOS systems</h3><p>We need to have EPEL repositories enabled as Clam pacakges are availble via EPEL repository. Based on your OS &amp; architecture, execute one of the following commands to install EPEL repository on your CentOS/RHEL systems,</p><p><strong>RHEL/CentOS 7</strong></p><p><span
style="color: #333399;"><strong>$ sudo rpm -Uvh https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/e/epel-release-7-11.noarch.rpm</strong></span></p><div
class='code-block code-block-3' style='margin: 8px auto; text-align: center; clear: both;'><ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>RHEL/CentOS 6 (64 Bit)</strong></p><p><span
style="color: #333399;"><strong>$ sudo rpm -Uvh http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm</strong></span></p><p><strong>RHEL/CentOS 6 (32 Bit)</strong></p><p><span
style="color: #333399;"><strong>$ sudo rpm -Uvh http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm</strong></span></p><h3>For Ubuntu System</h3><p>No requirements as the Clam packages are available with the default repositories.</p><p><strong>( Recommended Read :<a
href="https://linuxtechlab.com/beginners-guide-to-selinux/"><span
style="color: #993300;"> Beginner&#8217;s guide to SELINUX </span></a> )</strong></p><p>&nbsp;</p><h2>Install ClamAV on RHEL/CentOS</h2><p>Once the epel repositories have been enabled, we can install ClamAV using yum command. To install Clam anti-virus, execute the following command via your terminal,</p><div
class='code-block code-block-4' style='margin: 8px 0; clear: both;'><ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><span
style="color: #333399;"><strong>$ sudo yum install clamav clamd</strong></span></p><p>Next we will star the Clam service &amp; set to enable it at boot time,</p><p><span
style="color: #333399;"><strong>$ sudo service clamd start                OR              sudo systemctl start clamd</strong></span></p><p><span
style="color: #333399;"><strong>$ sudo chkconfig clamd on               OR              sudo systemclt enable clamd</strong></span></p><p>Now we will update the Clam AV’s signatures to the latest available,</p><p><span
style="color: #333399;"><strong>$ sudo /usr/bin/freshclam</strong></span></p><p>This will update the signature database to latest, also Clam AV will update daily as a cronjob is created by default under ‘/etc/cron.daily/freshclam’.</p><p>&nbsp;</p><h2>ClamAV installation on Ubuntu</h2><p>Installation of Clam AV on Ubuntu is pretty simple, open terminal &amp; excute the following command,</p><p><span
style="color: #333399;"><strong>$ sudo apt-get install clamav</strong></span></p><p>Now to update the AV signature database, run the following commands</p><p><span
style="color: #333399;"><strong>$ sudo freshclam</strong></span></p><p>That’s it, Clam AV is now now ready to work but before we do that we will install GUI for Clam AV.</p><div
class='code-block code-block-5' style='margin: 8px auto; text-align: center; clear: both;'><ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p>&nbsp;</p><h2>Installing GUI for ClamAV</h2><p>We will be using Clam TK as GUI frontend for Clam AV, its lightweight &amp; very easy to use. To install it on CentOS/RHEL, we can use yum</p><p><span
style="color: #333399;"><strong>$ sudo yum install clamtk</strong></span></p><p>&amp; similarly for Ubuntu, we can run</p><p><span
style="color: #333399;"><strong>$ sudo apt-get install clamtk</strong></span></p><p>&amp; we will have ClamTK installed on our systems but if for some reasons its not installed, we can also grab the rpm &amp; deb files from the ClamTK websites.</p><p>To get the packages files, visit <a
href="https://dave-theunsub.github.io/clamtk/"><span
style="color: #993300;"><strong>ClamTK Official Website</strong></span></a> &amp; under the download section, you will the package file for CentOS 6 &amp; 7 and for Ubuntu as well, along with other Linux distributions.</p><p>Download the required file &amp; install it using rpm,</p><p><span
style="color: #333399;"><strong>$ sudo rpm -ivh clamtk-5.25-1.el7.noarch.rpm</strong></span></p><p>or if installing it on Ubuntu, run</p><p><span
style="color: #333399;"><strong>$ sudo dpkg -i clamtk_5.25-1_all.deb</strong></span></p><p>&nbsp;</p><h2>Setting up a daily scan</h2><p>To setup a daily scan, we can create a cron job that will be executed daily on systems. To do this, we will create a file named ‘daily_scan’ under ‘/etc/cron.daily/’ ,</p><p><span
style="color: #333399;"><strong>$ sudo vim /etc/cron.daily/daily_scan</strong></span></p><p>&amp; will add the following line to the file</p><p><span
style="color: #333399;"><strong>/usr/bin/clamscan -i -r /home &gt;&gt; /var/log/ClamAV/daily_scan.log</strong></span></p><p>here ‘/home’ is the directory that will be scannned &amp; ‘/var/log/ClamAV/daily_scan.log’ is the file where logs for the scan will be created. You can also excute the above mentioned command to start a scan from your teminal or if you want to start a scan using GUI, use ClamTK.</p><p>That completes our tutorial on setting ClamAV &amp; its GUI frontend, ClamTK. If you have any queries on your mind or are facing some issue while installation, please do let us know using the comment box down below.</p><div
style="padding: 1.5em; background: #E1DDDD; border: 0.125em solid #c5dbe5; border-width: 0.125em 0;"><p
style="margin-bottom: 0.75em;">If you think we have helped you or just want to support us, please consider these :-</p><p
style="margin-bottom: 0.75em;">Connect to us: <a
href="https://www.facebook.com/linuxtechlab/"><span
style="color: #ff0000;">Facebook</span></a> | <a
href="https://twitter.com/LinuxTechLab"><span
style="color: #ff0000;">Twitter</span></a> | <a
href="https://plus.google.com/+linuxtechlab"><span
style="color: #ff0000;">Google Plus</span></a></p><p
style="margin-bottom: 0.75em;">Become a Supporter &#8211; <a
href="https://linuxtechlab.com/contact-us-2/">Donate us some of you hard earned money:<form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"><div
class="paypal-donations">
<input
type="hidden" name="cmd" value="_donations" />
<input
type="hidden" name="bn" value="TipsandTricks_SP" />
<input
type="hidden" name="business" value="techlablinux@gmail.com" />
<input
type="hidden" name="return" value="https://linuxtechlab.com" />
<input
type="hidden" name="rm" value="0" />
<input
type="hidden" name="currency_code" value="USD" />
<input
type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
<img
alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /></div></form></a></p><p
style="margin-bottom: 0.75em;">Linux TechLab is thankful for your continued support.</p></div><div
class="sharedaddy sd-sharing-enabled"><div
class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this post:</h3><div
class="sd-content"><ul><li
class="share-email"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span
class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li
class="share-facebook"><a
rel="nofollow noopener noreferrer" data-shared="sharing-facebook-1908" class="share-facebook sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span
class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li
class="share-linkedin"><a
rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-1908" class="share-linkedin sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span
class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li
class="share-twitter"><a
rel="nofollow noopener noreferrer" data-shared="sharing-twitter-1908" class="share-twitter sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span
class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li
class="share-google-plus-1"><a
rel="nofollow noopener noreferrer" data-shared="sharing-google-1908" class="share-google-plus-1 sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span
class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li
class="share-jetpack-whatsapp"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=How%20to%20install%20ClamAV%20%28Antivirus%29%20%26%20ClamTK%20on%20Linux%20https%3A%2F%2Flinuxtechlab.com%2Finstall-clamav-clamtk-linux%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span
class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li
class="share-tumblr"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://linuxtechlab.com/install-clamav-clamtk-linux/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span
class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li
class="share-end"></li></ul></div></div></div>          <nav
class="pagination group">
</nav></div><div
class="clear"></div></div></div>
</article><div
class="clear"></div><p
class="post-tags"><span>Tags:</span> <a
href="https://linuxtechlab.com/tag/antivirus/" rel="tag">antivirus</a><a
href="https://linuxtechlab.com/tag/clam/" rel="tag">clam</a></p><div
class="author-bio"><div
class="bio-avatar"><img
alt='' src='https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&#038;d=retro&#038;r=g' srcset="https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=256&#038;d=retro&#038;r=g 2x" class='avatar avatar-128 photo' height='128' width='128' /></div><p
class="bio-name">Shusain</p><p
class="bio-desc">Passionate about Linux &amp; open source.
Loves to learn, read &amp; write about Linux as well as new technologies.</p><div
class="clear"></div></div><h4 class="heading">
<i
class="far fa-hand-point-right"></i>You may also like...</h4><ul
class="related-posts group"><li
class="related post-hover">
<article
class="post-1953 post type-post status-publish format-standard has-post-thumbnail hentry category-how-tos category-tips-tricks tag-adb tag-fastboot"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/install-adb-fastboot-ubuntu/" title="How to install ADB &#038; Fastboot on Ubuntu">
<img
width="520" height="245" src="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/install-adb-520x245.jpg" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="install adb" srcset="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/install-adb-520x245.jpg 520w, https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/09/install-adb.jpg 720w" sizes="(max-width: 520px) 100vw, 520px" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/install-adb-fastboot-ubuntu/" rel="bookmark" title="How to install ADB &#038; Fastboot on Ubuntu">How to install ADB &#038; Fastboot on Ubuntu</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2017-10-10 14:55:21">October 10, 2017</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">October 10, 2017</span>
&middot; Last modified <span
class="updated">March 12, 2018</span></p></div></div></article></li><li
class="related post-hover">
<article
class="post-586 post type-post status-publish format-standard has-post-thumbnail hentry category-how-tos tag-centos tag-linux-commands tag-partition tag-redhat tag-rhel tag-swap tag-system-administrator"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/create-swap-using-fdisk-fallocate/" title="Creating SWAP partition using FDISK &#038; FALLOCATE commands">
<img
width="520" height="245" src="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/02/swap-520x245.jpg" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="creating swap" srcset="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/02/swap-520x245.jpg 520w, https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/02/swap-300x142.jpg 300w, https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/02/swap.jpg 720w" sizes="(max-width: 520px) 100vw, 520px" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/create-swap-using-fdisk-fallocate/" rel="bookmark" title="Creating SWAP partition using FDISK &#038; FALLOCATE commands">Creating SWAP partition using FDISK &#038; FALLOCATE commands</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2017-08-02 07:25:59">August 2, 2017</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">August 2, 2017</span>
&middot; Last modified <span
class="updated">June 5, 2018</span></p></div></div></article></li><li
class="related post-hover">
<article
class="post-2235 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-tips-tricks tag-apache tag-https tag-ssl tag-webserver"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/redirect-http-to-https-apache-server/" title="Redirect http to https: Apache Server">
<img
width="520" height="245" src="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/10/http-to-hhtps-520x245.png" class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="redirect http to https" srcset="https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/10/http-to-hhtps-520x245.png 520w, https://k9v2t9s8.stackpathcdn.com/wp-content/uploads/2017/10/http-to-hhtps-720x340.png 720w" sizes="(max-width: 520px) 100vw, 520px" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/redirect-http-to-https-apache-server/" rel="bookmark" title="Redirect http to https: Apache Server">Redirect http to https: Apache Server</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2017-10-29 09:11:13">October 29, 2017</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">October 29, 2017</span>
&middot; Last modified <span
class="updated">March 12, 2018</span></p></div></div></article></li></ul><section
id="comments" class="themeform"><div
id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a
rel="nofollow" id="cancel-comment-reply-link" href="/install-clamav-clamtk-linux/#respond" style="display:none;">Cancel reply</a></small></h3><form
action="https://linuxtechlab.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p
class="comment-notes"><span
id="email-notes">Your email address will not be published.</span> Required fields are marked <span
class="required">*</span></p><p
class="comment-form-comment"><label
for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p
class="comment-form-author"><label
for="author">Name <span
class="required">*</span></label> <input
id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p
class="comment-form-email"><label
for="email">Email <span
class="required">*</span></label> <input
id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p
class="comment-form-url"><label
for="url">Website</label> <input
id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p
class="comment-subscription-form"><input
type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label
class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p
class="comment-subscription-form"><input
type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label
class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p
class="form-submit"><input
name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input
type='hidden' name='comment_post_ID' value='1908' id='comment_post_ID' />
<input
type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p
style="display: none;"><input
type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="300d642ce6" /></p><p
style="display: none;"><input
type="hidden" id="ak_js" name="ak_js" value="35"/></p></form></div>
</section></div>
</section><div
class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1"><a
class="sidebar-toggle" title="Expand Sidebar"><i
class="fas icon-sidebar-toggle"></i></a><div
class="sidebar-content"><div
class="sidebar-top group"><p>Follow:</p><ul
class="social-links"><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#0ea4d1;font-size:20px"><i
class="fab fa-facebook"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-twitter"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" aria-label="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-google-plus"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" aria-label="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-linkedin"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fas fa-rss"></i></a></li></ul></div><ul
class="post-nav group"><li
class="next"><a
href="https://linuxtechlab.com/working-with-linux-file-links/" rel="next"><i
class="fas fa-chevron-right"></i><strong>Next story</strong> <span>Working with Linux File Links</span></a></li><li
class="previous"><a
href="https://linuxtechlab.com/scheduling-important-jobs-crontab-examples/" rel="prev"><i
class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>Scheduling important jobs with CRONTAB : Crontab Examples</span></a></li></ul><div
id="text-14" class="widget widget_text"><h3 class="widget-title">Search</h3><div
class="textwidget"><p><script>(function() {
    var cx = 'partner-pub-9186837757068891:7136602963';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();</script></p></div></div><div
id="facebook-likebox-2" class="widget widget_facebook_likebox"><h3 class="widget-title"><a
href="https://www.facebook.com/linuxtechlab/">Facebook Fan Page</a></h3><div
id="fb-root"></div><div
class="fb-page" data-href="https://www.facebook.com/linuxtechlab/" data-width="450"  data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div
class="fb-xfbml-parse-ignore"><blockquote
cite="https://www.facebook.com/linuxtechlab/"><a
href="https://www.facebook.com/linuxtechlab/">Facebook Fan Page</a></blockquote></div></div></div><div
id="text-7" class="widget widget_text"><div
class="textwidget"><p><br
/>
<br
/>
<ins
class="adsbygoogle"
style="display:inline-block;width:300px;height:1050px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="2501356018"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div
id="recent-posts-2" class="widget widget_recent_entries"><h3 class="widget-title">Recent Posts</h3><ul><li>
<a
href="https://linuxtechlab.com/simple-guide-to-install-postgresql-on-ubuntu/">Simple guide to install PostGreSQL on Ubuntu</a></li><li>
<a
href="https://linuxtechlab.com/working-with-linux-file-links/">Working with Linux File Links</a></li><li>
<a
href="https://linuxtechlab.com/install-clamav-clamtk-linux/">How to install ClamAV (Antivirus) &#038; ClamTK on Linux</a></li></ul></div></div></div></div></div></div></div>
<footer
id="footer"><section
class="container" id="footer-full-width-widget"><div
class="container-inner"><div
id="text-19" class="widget widget_text"><div
class="textwidget"><p><br
/>
<br
/>
<ins
class="adsbygoogle" style="display: inline-block; width: 620px; height: 90px;" data-ad-client="ca-pub-9186837757068891" data-ad-slot="7709195798"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div>
</section>
<nav
class="nav-container group" id="nav-footer" data-menu-id="footer-4" data-menu-scrollable="false"><div
class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false"><div
class="ham__navbar-span-wrapper">
<span
class="line line-1"></span>
<span
class="line line-2"></span>
<span
class="line line-3"></span></div></div><div
class="nav-text"></div><div
class="nav-wrap"><ul
id="menu-footer-menu" class="nav container group"><li
id="menu-item-4389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4389"><a
href="https://linuxtechlab.com/privacy-policy/">Privacy Policy</a></li><li
id="menu-item-4390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4390"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
id="menu-item-4391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4391"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav>
<section
class="container" id="footer-bottom"><div
class="container-inner"><a
id="back-to-top" href="#"><i
class="fas fa-angle-up"></i></a><div
class="pad group"><div
class="grid one-half"><div
id="copyright"><p>LinuxTechLab &copy; 2018. All Rights Reserved.</p></div></div><div
class="grid one-half last"><ul
class="social-links"><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#0ea4d1;font-size:20px"><i
class="fab fa-facebook"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-twitter"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" aria-label="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-google-plus"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" aria-label="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-linkedin"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fas fa-rss"></i></a></li></ul></div></div></div>
</section></footer></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/linuxtechlab.com\/install-clamav-clamtk-linux\/":1908};</script> <div
id="sharing_email" style="display: none;"><form
action="/install-clamav-clamtk-linux/" method="post">
<label
for="target_email">Send to Email Address</label>
<input
type="email" name="target_email" id="target_email" value="" />
<label
for="source_name">Your Name</label>
<input
type="text" name="source_name" id="source_name" value="" /><label
for="source_email">Your Email Address</label>
<input
type="email" name="source_email" id="source_email" value="" /><input
type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img
style="float: right; display: none" class="loading" src="https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input
type="submit" value="Send Email" class="sharing_send" />
<a
rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a><div
class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses!</div><div
class="errors errors-2" style="display: none;">
Email check failed, please try again</div><div
class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email.</div></form></div> <script type='text/javascript'>var ctcc_vars = {"expiry":"30","method":"1","version":"1"};</script> <script type='text/javascript' src='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js'></script> <script type='text/javascript'>var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"https:\/\/linuxtechlab.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"b79b604951"},"userStarted":{"with":"before|3.3.4","on":{"date":"2017-05-19 02:16:15.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":"","fitTextMap":{"single_post_title":{"selectors":".single h1.entry-title","minEm":1.375,"maxEm":2.62},"page_title":{"selectors":".page-title h1","minEm":1,"maxEm":1.3},"home_page_title":{"selectors":".home .page-title","minEm":1,"maxEm":1.2,"compression":2.5},"post_titles":{"selectors":".blog .post-title, .archive .post-title","minEm":1.375,"maxEm":1.475},"featured_post_titles":{"selectors":".featured .post-title","minEm":1.375,"maxEm":2.125},"comments":{"selectors":".commentlist li","minEm":0.8125,"maxEm":0.93,"compression":2.5},"entry":{"selectors":".entry","minEm":0.9375,"maxEm":1.125,"compression":2.5},"content_h1":{"selectors":".entry h1, .woocommerce div.product h1.product_title","minEm":1.7578125,"maxEm":2.671875},"content_h2":{"selectors":".entry h2","minEm":1.5234375,"maxEm":2.390625},"content_h3":{"selectors":".entry h3","minEm":1.40625,"maxEm":1.96875},"content_h4":{"selectors":".entry h4","minEm":1.2890625,"maxEm":1.6875},"content_h5":{"selectors":".entry h5","minEm":1.0546875,"maxEm":1.40625},"content_h6":{"selectors":".entry h6","minEm":0.9375,"maxEm":1.265625,"compression":2.5}},"userFontSize":"16","fitTextCompression":"1.5"};</script> <script type='text/javascript'>var jpfbembed = {"appid":"249643311490","locale":"en_US"};</script> <script type='text/javascript' src='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script> <script type='text/javascript'>var rm_pre_data = {"ajax_url":"https:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","rm_nonce_field":"623c20de1d"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1"};</script> <script type='text/javascript' src='https://k9v2t9s8.stackpathcdn.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js'></script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <!--[if lt IE 9]> <script src="https://k9v2t9s8.stackpathcdn.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script> <![endif]--> <script type='text/javascript' src='https://stats.wp.com/e-201838.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.5',blog:'124285797',post:'1908',tz:'5.5',srv:'linuxtechlab.com'} ]);
	_stq.push([ 'clickTrackerInit', '124285797', '1908' ]);</script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																			ctccFirstPage();
											});</script> <div
id="catapult-cookie-bar" class=""><div
class="ctcc-inner "><span
class="ctcc-left-side">This site uses cookies to store information on your computer.  By using the site, you consent to the placement of these cookies. <a
class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://linuxtechlab.com/privacy-policy/">Find out more.</a></span><span
class="ctcc-right-side"><button
id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">THANKS</button></span></div></div></body></html>