<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head><meta charset="UTF-8">
<script src="/cdn-cgi/apps/head/0IgBzvyLrhKdADprLcm3MAK_O7E.js"></script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>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</script><script data-ezscrex='false' data-cfasync='false' data-pagespeed-no-defer>__ez.pel=(function(){var pixels=[],pxURL="/porpoiseant/army.gif";function AddAndFirePixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0);Fire();}
function AddAndFireOrigPixel(adSlot,pixelData){AddPixel(adSlot,pixelData,0,0,0,0,0,true);Fire();}
function GetCurrentPixels(){return pixels;}
function AddPixel(adSlot,pixelData,revenue,est_revenue,bid_floor_filled,bid_floor_prev,stat_source_id,isOrig){if(!__ez.dot.isDefined(adSlot)||__ez.dot.isAnyDefined(adSlot.getSlotElementId,adSlot.ElementId)==false){return;}
var ad_position_id=parseInt(__ez.dot.getTargeting(adSlot,'ap'));var impId=__ez.dot.getSlotIID(adSlot),adUnit=__ez.dot.getAdUnit(adSlot,isOrig);var compId=parseInt(__ez.dot.getTargeting(adSlot,"compid"));var lineItemId=0;var creativeId=0;var ezimData=getEzimData(adSlot);if(typeof ezimData=='object'){if(ezimData.creative_id!==undefined){creativeId=ezimData.creative_id;}
if(ezimData.line_item_id!==undefined){lineItemId=ezimData.line_item_id;}}
if(__ez.dot.isDefined(impId,adUnit)&&__ez.dot.isValid(pixelData)){pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),revenue:revenue,est_revenue:est_revenue,ad_position:ad_position_id,ad_size:"",bid_floor_filled:bid_floor_filled,bid_floor_prev:bid_floor_prev,stat_source_id:stat_source_id,country_code:__ez.dot.getCC(),pageview_id:__ez.dot.getPageviewId(),comp_id:compId,line_item_id:lineItemId,creative_id:creativeId,data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig,});}}
function AddPixelById(impFullId,pixelData,isOrig){var vals=impFullId.split('/');if(__ez.dot.isDefined(impFullId)&&vals.length===3&&__ez.dot.isValid(pixelData)){var adUnit=vals[0],impId=vals[2];pixels.push({type:"impression",impression_id:impId,domain_id:__ez.dot.getDID(),unit:adUnit,t_epoch:__ez.dot.getEpoch(0),pageview_id:__ez.dot.getPageviewId(),data:__ez.dot.dataToStr(pixelData),is_orig:isOrig||__ez.template.isOrig});}}
function Fire(){if(typeof document.visibilityState!=='undefined'&&document.visibilityState==="prerender")return;if(__ez.dot.isDefined(pixels)&&pixels.length>0){var allPixels=[pixels.filter(function(pixel){return pixel.is_orig}),pixels.filter(function(pixel){return!pixel.is_orig})];allPixels.forEach(function(pixels){while(pixels.length>0){var isOrig=pixels[0].is_orig||false;var j=5;if(j>pixels.length){j=pixels.length;}
var pushPixels=pixels.splice(0,j);var pixelURL=__ez.dot.getURL(pxURL)+"?orig="+(isOrig===true?1:0)+"&sts="+btoa(JSON.stringify(pushPixels));if(typeof window.isAmp!=='undefined'&&isAmp&&typeof window._ezaq!=='undefined'&&_ezaq.hasOwnProperty("domain_id")){pixelURL+="&visit_uuid="+_ezaq['visit_uuid'];}
__ez.dot.Fire(pixelURL);}})}
pixels=[];}
function getEzimData(adSlot){if(typeof _ezim_d=="undefined"){return false}
var adUnitName=__ez.dot.getAdUnitPath(adSlot).split('/').pop();if(typeof _ezim_d==='object'&&_ezim_d.hasOwnProperty(adUnitName)){return _ezim_d[adUnitName];}
for(var ezimKey in _ezim_d){if(ezimKey.split('/').pop()===adUnitName){return _ezim_d[ezimKey];}}
return false;}
return{Add:AddPixel,AddAndFire:AddAndFirePixel,AddAndFireOrig:AddAndFireOrigPixel,AddById:AddPixelById,Fire:Fire,GetPixels:GetCurrentPixels,};})();__ez.queue.addFile('/detroitchicago/raleigh.js', '/detroitchicago/raleigh.js?gcb=194-2&cb=5', false, [], true, false, true, false);__ez.queue.addFile('/detroitchicago/tampa.js', '/detroitchicago/tampa.js?gcb=194-2&cb=3', false, [], true, false, true, false);</script>
<script data-ezscrex="false" data-cfasync="false">(function(){if("function"===typeof window.CustomEvent)return!1;window.CustomEvent=function(c,a){a=a||{bubbles:!1,cancelable:!1,detail:null};var b=document.createEvent("CustomEvent");b.initCustomEvent(c,a.bubbles,a.cancelable,a.detail);return b}})();</script><script data-ezscrex="false" data-cfasync="false">__ez.queue.addFile('/detroitchicago/tulsa.js', '/detroitchicago/tulsa.js?gcb=194-2&cb=5', false, [], true, false, true, false);</script>
    
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=5">
        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<!-- start: Estudio Patagon Meta Tags -->
<meta property="description" content="The FSCK command is a very important Linux/Unix utility, it is used to check &amp; repair the errors in the file system. It is similar..."/>
<meta property="og:locale" content="en_US" />
<meta property="og:title" content="Check Linux filesystem for errors: FSCK command with examples - LinuxTechLab"/>
<meta property="og:description" content="The FSCK command is a very important Linux/Unix utility, it is used to check &amp; repair the errors in the file system. It is similar..."/>
<meta property="og:image" content="https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg"/>
<meta property="og:type" content="article"/>
<meta property="og:url" content="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/"/>
<meta property="og:site_name" content="LinuxTechLab"/>
<meta property="article:published_time" content="2020-06-10T11:05:15+05:30" />
<meta property="article:modified_time" content="2021-01-29T21:26:45+05:30" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The FSCK command is a very important Linux/Unix utility, it is used to check &amp; repair the errors in the file system. It is similar..." />
<meta name="twitter:title" content="Check Linux filesystem for errors: FSCK command with examples - LinuxTechLab" />
<meta name="twitter:image" content="https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg" />
<!-- end: Estudio Patagon Meta Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Check Linux filesystem for errors: FSCK command with examples - LinuxTechLab</title>
	<meta name="description" content="Learn how to use fsck command with examples. FSCK is used to check &amp; repair the errors in the file system. It is similar to &#039;chkdsk&#039; utility" />
	<link rel="canonical" href="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Check Linux filesystem for errors: FSCK command with examples - LinuxTechLab" />
	<meta property="og:description" content="Learn how to use fsck command with examples. FSCK is used to check &amp; repair the errors in the file system. It is similar to &#039;chkdsk&#039; utility" />
	<meta property="og:url" content="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/" />
	<meta property="og:site_name" content="LinuxTechLab" />
	<meta property="article:publisher" content="https://www.facebook.com/linuxtechlab" />
	<meta property="article:author" content="https://www.facebook.com/linuxtechlab" />
	<meta property="article:published_time" content="2020-06-10T05:35:15+00:00" />
	<meta property="article:modified_time" content="2021-01-29T15:56:45+00:00" />
	<meta property="og:image" content="https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg" />
	<meta property="og:image:width" content="720" />
	<meta property="og:image:height" content="340" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@https://twitter.com/linuxtechlab" />
	<meta name="twitter:site" content="@linuxtechlab" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="Shusain">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://linuxtechlab.com/#website","url":"https://linuxtechlab.com/","name":"LinuxTechLab","description":"Linux Devops Tutorial, Scripting tutorials, how to&#039;s , Tips &amp; Tricks","publisher":{"@id":"https://linuxtechlab.com/#/schema/person/c225f87d575203dba6fbc0d4022aa205"},"potentialAction":[{"@type":"SearchAction","target":"https://linuxtechlab.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#primaryimage","inLanguage":"en-US","url":"https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg","width":"720","height":"340","caption":"fsck command with examples"},{"@type":"WebPage","@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#webpage","url":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/","name":"Check Linux filesystem for errors: FSCK command with examples - LinuxTechLab","isPartOf":{"@id":"https://linuxtechlab.com/#website"},"primaryImageOfPage":{"@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#primaryimage"},"datePublished":"2020-06-10T05:35:15+00:00","dateModified":"2021-01-29T15:56:45+00:00","description":"Learn how to use fsck command with examples. FSCK is used to check & repair the errors in the file system. It is similar to 'chkdsk' utility","breadcrumb":{"@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/"]}]},{"@type":"BreadcrumbList","@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://linuxtechlab.com/","url":"https://linuxtechlab.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/","url":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/","name":"Check Linux filesystem for errors: FSCK command with examples"}}]},{"@type":"Article","@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#article","isPartOf":{"@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#webpage"},"author":{"@id":"https://linuxtechlab.com/#/schema/person/c225f87d575203dba6fbc0d4022aa205"},"headline":"Check Linux filesystem for errors: FSCK command with examples","datePublished":"2020-06-10T05:35:15+00:00","dateModified":"2021-01-29T15:56:45+00:00","mainEntityOfPage":{"@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#webpage"},"commentCount":5,"publisher":{"@id":"https://linuxtechlab.com/#/schema/person/c225f87d575203dba6fbc0d4022aa205"},"image":{"@id":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#primaryimage"},"keywords":"filesystem,linux commands","articleSection":"How To's,Tips &amp; Tricks","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/#respond"]}]},{"@type":["Person","Organization"],"@id":"https://linuxtechlab.com/#/schema/person/c225f87d575203dba6fbc0d4022aa205","name":"Shusain","image":{"@type":"ImageObject","@id":"https://linuxtechlab.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=96&d=retro&r=g","caption":"Shusain"},"logo":{"@id":"https://linuxtechlab.com/#personlogo"},"description":"Passionate about Linux &amp; open source. Loves to learn, read &amp; write about Linux as well as new technologies.","sameAs":["https://linuxtechlab.com","https://www.facebook.com/linuxtechlab","https://instagram.com/linuxtechlab","https://linkedin.com/in/linuxtechlab","https://in.pinterest.com/linuxtechlab/","https://twitter.com/https://twitter.com/linuxtechlab","https://linuxtechlab.tumblr.com"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Feed" href="https://linuxtechlab.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Comments Feed" href="https://linuxtechlab.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Check Linux filesystem for errors: FSCK command with examples Comments Feed" href="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.17.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-66906913-3"  type="text/javascript" data-cfasync="false"></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.17.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-66906913-3';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-66906913-3', {
						forceSSL:true,anonymize_ip:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof (
											arguments[1].hitType
										) ) {
											hitObject = arguments[1];
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var gaKey, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
									};
									for ( gaKey in gaMap ) {
										if ( 'undefined' !== typeof args[gaKey] ) {
											hit[gaMap[gaKey]] = args[gaKey];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxtechlab.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5d9d509b0c856539e18d8e916df0c9ac"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='cookie-consent-style-css'  href='https://linuxtechlab.com/wp-content/plugins/uk-cookie-consent/assets/css/style.css?ver=5d9d509b0c856539e18d8e916df0c9ac' type='text/css' media='all' />
<link rel='stylesheet' id='wp-dark-mode-frontend-css'  href='https://linuxtechlab.com/wp-content/plugins/wp-dark-mode//assets/css/frontend.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='epcl-theme-css'  href='https://linuxtechlab.com/wp-content/themes/breek/assets/dist/style.min.css?ver=3.6.6' type='text/css' media='all' />
<link rel='stylesheet' id='plugins-css'  href='https://linuxtechlab.com/wp-content/themes/breek/assets/dist/plugins.min.css?ver=3.6.6' type='text/css' media='all' />
<style id='plugins-inline-css' type='text/css'>
body:before{
            background: -webkit-linear-gradient(0deg, #2c46a5 30%, #5c70a5 100%);
            background: linear-gradient(90deg, #2c46a5 30%, #5c70a5 100%);
        }#header.is-sticky div.menu-wrapper{ 
            background-color: #00bec1; }#author{ 
            background-color: rgba(0,0,0,0.15); }body{ font-size: ; }
</style>
<link rel='stylesheet' id='epcl-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Poppins%3A400%2C400i%2C500%2C600%2C600i%2C700%2C700i%7CMontserrat%3A400%2C500%2C600%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://linuxtechlab.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.13' type='text/css' media='all' />
<link rel='stylesheet' id='breek-child-css-css'  href='https://linuxtechlab.com/wp-content/themes/breek-child/style.css?ver=5d9d509b0c856539e18d8e916df0c9ac' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://linuxtechlab.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.5' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20210219' id='jetpack_related-posts-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/linuxtechlab.com","hash_tracking":"false","ua":"UA-66906913-3"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.17.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://linuxtechlab.com/wp-json/" /><link rel="alternate" type="application/json" href="https://linuxtechlab.com/wp-json/wp/v2/posts/2933" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxtechlab.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxtechlab.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://linuxtechlab.com/?p=2933' />
<link rel="alternate" type="application/json+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Flinux-filesystem-errors-fsck-command-with-examples%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Flinux-filesystem-errors-fsck-command-with-examples%2F&#038;format=xml" />
<meta name="rankz-verification" content="tKzXTBjPI6EGQPEU"><style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style>                <style>
                    :root {
                        --wp-dark-mode-bg: #1B2836;
                        --wp-dark-mode-text: #fff;
                        --wp-dark-mode-link: #459BE6;
                        --wp-dark-mode-border: #394654;
                        --wp-dark-mode-btn: #2f3c4a;
                    }
                </style>

			<style>html.wp-dark-mode-active :not(.wp-dark-mode-ignore) {
  color: var(--wp-dark-mode-text) !important;
  border-color: var(--wp-dark-mode-border) !important; }
  html.wp-dark-mode-active a:not(.wp-dark-mode-ignore), html.wp-dark-mode-active a *:not(.wp-dark-mode-ignore), html.wp-dark-mode-active a:active:not(.wp-dark-mode-ignore), html.wp-dark-mode-active a:active *:not(.wp-dark-mode-ignore), html.wp-dark-mode-active a:visited:not(.wp-dark-mode-ignore), html.wp-dark-mode-active a:visited *:not(.wp-dark-mode-ignore) {
    color: var(--wp-dark-mode-link) !important; }
  html.wp-dark-mode-active iframe:not(.wp-dark-mode-ignore), html.wp-dark-mode-active iframe *:not(.wp-dark-mode-ignore), html.wp-dark-mode-active input:not(.wp-dark-mode-ignore), html.wp-dark-mode-active select:not(.wp-dark-mode-ignore), html.wp-dark-mode-active textarea:not(.wp-dark-mode-ignore), html.wp-dark-mode-active button:not(.wp-dark-mode-ignore) {
    background: var(--wp-dark-mode-btn) !important; }
</style>                <script>
                    (function () {
                        window.wpDarkMode = {"config":{"brightness":"100","contrast":"90","sepia":"10"},"enable_preset":true,"customize_colors":false,"colors":{"bg":"#1B2836","text":"#fff","link":"#459BE6"},"enable_frontend":true,"enable_backend":false,"enable_os_mode":true,"excludes":"","includes":"","is_excluded":false,"remember_darkmode":false,"default_mode":false,"images":"","is_pro_active":false,"is_ultimate_active":false,"pro_version":0,"is_elementor_editor":false,"is_block_editor":false,"frontend_mode":false};

                        const is_saved = localStorage.getItem('wp_dark_mode_active');

                        if ((is_saved && is_saved != 0) || (!is_saved && wpDarkMode.default_mode)) {
                            document.querySelector('html').classList.add('wp-dark-mode-active');

                            const isCustomColor = parseInt("1");

                            if (!isCustomColor) {

                                const userAgent = typeof navigator === 'undefined' ? 'some useragent' : navigator.userAgent.toLowerCase();
                                const isFirefox = userAgent.includes('firefox');

                                var isChromium = userAgent.includes('chrome') || userAgent.includes('chromium');
                                var isSafari = userAgent.includes('safari') && !isChromium;

                                if (isFirefox || isSafari) {
                                    return;
                                }

                                if ('' === ``) {
                                    DarkMode.enable();
                                }
                            }
                        }

                    })();
                </script>
				<style id="wp_dark_mode_pre_css">.wp-dark-mode-active body, .wp-dark-mode-active header, .wp-dark-mode-active aside{background: var(--wp-dark-mode-bg)}</style>                    <script>

                        window.customColor = function () {

                            const is_active = document.querySelector('html').classList.contains('wp-dark-mode-active') ? 1 : 0;

                            const elements = document.querySelectorAll(`
                               body, header, footer, div, section, nav, article, aside, figure,
                               p, a, span, strong, font, i, label, small,
                               h1, h2, h3, h4, h5, h6,
                               ul, ol, li,
                               form,
                               table, tr, td
                               `);


                            elements.forEach(element => {

                                if (element.classList.contains('wp-dark-mode-ignore')) {
                                    return;
                                }

                                if ('' !== ``) {
                                    if (!element.classList.contains('wp-dark-mode-include')) {
                                        return;
                                    }
                                }


                                const styles = window.getComputedStyle(element, "");

                                //Background Color
                                const rgb = styles.getPropertyValue('background-color');
                                const hex = '#' + rgb.substr(4, rgb.indexOf(')') - 4).split(',').map((color) => parseInt(color).toString(16)).join('');

                                if ('#NaN000' !== hex) {
                                    if (!is_active && 'var(--wp-dark-mode-bg)' === element.style.backgroundColor) {
                                        element.style.removeProperty('background-color');
                                    } else {
                                        element.style.setProperty('background-color', 'var(--wp-dark-mode-bg)', 'important');
                                    }
                                }


                                //Gradient BG
                                const gradientBG = styles.getPropertyValue('background-image');
                                const gradientAttr = element.getAttribute('bg-gradient');

                                if (gradientBG.includes('gradient') || gradientAttr) {
                                    if (gradientAttr) {
                                        element.removeAttribute('bg-gradient');
                                        element.style.removeProperty('background-image');
                                        element.style.background = gradientAttr;
                                    } else {
                                        element.setAttribute('bg-gradient', gradientBG);
                                        element.style.backgroundImage = 'var(--wp-dark-mode-bg)';
                                    }
                                }

                            });


                        }
                    </script>
					      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linuxtechlab.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '4aa7dae9-6300-464c-a817-ed5ca97dd617';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "LinuxTechLab";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing !!!";
oneSignal_options['path'] = "https://linuxtechlab.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5ccade99-0f35-4775-9ae0-5e2c3bfd110b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['promptOptions']['actionMessage'] = "Want to Learn Linux/DevOPs ???";
oneSignal_options['promptOptions']['acceptButtonText'] = "Agree to learn !";
oneSignal_options['promptOptions']['cancelButtonText'] = "No Thanks";
oneSignal_options['promptOptions']['siteName'] = "https://linuxtechlab.com";
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<link rel="icon" href="https://linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1-270x270.png" />
<script type="text/javascript">var ezouid = "1";</script><base href="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/"><script type='text/javascript'>
var ezoTemplate = 'old_site_gc';
if(typeof ezouid == 'undefined')
{
    var ezouid = 'none';
}
var ezoFormfactor = '1';
var ezo_elements_to_check = Array();
</script><!-- START EZHEAD -->
<script data-ezscrex="false" type='text/javascript'>
var soc_app_id = '0';
var did = 123629;
var ezdomain = 'linuxtechlab.com';
var ezoicSearchable = 1;
</script>
<!--{jquery}-->
<!-- END EZHEAD -->
<script data-ezscrex="false" type="text/javascript" data-cfasync="false">var _ezaq = {"ad_cache_level":0,"ad_lazyload_version":0,"ad_load_version":0,"city":"Ashburn","country":"US","days_since_last_visit":-1,"domain_id":123629,"domain_test_group":20210303,"engaged_time_visit":0,"ezcache_level":2,"ezcache_skip_code":0,"form_factor_id":1,"framework_id":1,"is_return_visitor":false,"is_sitespeed":0,"last_page_load":"","last_pageview_id":"","lt_cache_level":0,"metro_code":511,"page_ad_positions":"","page_view_count":0,"page_view_id":"d1077ceb-1e9c-433c-5462-97529056e3e0","position_selection_id":0,"postal_code":"20149","pv_event_count":0,"response_size_orig":113849,"response_time_orig":4,"serverid":"35.153.106.152:10121","state":"VA","t_epoch":1616968257,"template_id":126,"time_on_site_visit":0,"url":"https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/","user_id":0,"word_count":1366,"worst_bad_word_level":0};var _ezExtraQueries = "&ez_orig=1";</script>
<script src="//www.ezojs.com/ezoic/ezd.js" defer async></script>
<script data-ezscrex='false' data-pagespeed-no-defer data-cfasync='false'>
function create_ezolpl(pvID, rv) {
    var d = new Date();
    d.setTime(d.getTime() + (365*24*60*60*1000));
    var expires = "expires="+d.toUTCString();
    __ez.ck.setByCat("ezux_lpl_123629=" + new Date().getTime() + "|" + pvID + "|" + rv + "; " + expires, 3);
}
function attach_ezolpl(pvID, rv) {
    if (document.readyState === "complete") {
        create_ezolpl(pvID, rv);
    }
    if(window.attachEvent) {
        window.attachEvent("onload", create_ezolpl, pvID, rv);
    } else {
        if(window.onload) {
            var curronload = window.onload;
            var newonload = function(evt) {
                curronload(evt);
                create_ezolpl(pvID, rv);
            };
            window.onload = newonload;
        } else {
            window.onload = create_ezolpl.bind(null, pvID, rv);
        }
    }
}

__ez.queue.addFunc("attach_ezolpl", "attach_ezolpl", ["d1077ceb-1e9c-433c-5462-97529056e3e0", "false"], false, ['/detroitchicago/boise.js'], true, false, false, false);
</script></head>
<body data-rsssl=1 class="post-template-default single single-post postid-2933 single-format-standard wp-embed-responsive ctcc-exclude-OC">
    <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" style="display: none;">

	<symbol id="tag" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M10.9 2.1l9.899 1.415 1.414 9.9-9.192 9.192a1 1 0 0 1-1.414 0l-9.9-9.9a1 1 0 0 1 0-1.414L10.9 2.1zm.707 2.122L3.828 12l8.486 8.485 7.778-7.778-1.06-7.425-7.425-1.06zm2.12 6.364a2 2 0 1 1 2.83-2.829 2 2 0 0 1-2.83 2.829z"/>
        </g>
	</symbol>

    <symbol id="copy" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M7 6V3a1 1 0 0 1 1-1h12a1 1 0 0 1 1 1v14a1 1 0 0 1-1 1h-3v3c0 .552-.45 1-1.007 1H4.007A1.001 1.001 0 0 1 3 21l.003-14c0-.552.45-1 1.007-1H7zM5.003 8L5 20h10V8H5.003zM9 6h8v10h2V4H9v2z"/>
        </g>
    </symbol>

    <symbol id="calendar" viewBox="0 0 24 24">
        <g>
            <path fill="none" d="M0 0h24v24H0z"/>
            <path d="M17 3h4a1 1 0 0 1 1 1v16a1 1 0 0 1-1 1H3a1 1 0 0 1-1-1V4a1 1 0 0 1 1-1h4V1h2v2h6V1h2v2zm-2 2H9v2H7V5H4v4h16V5h-3v2h-2V5zm5 6H4v8h16v-8z"/>
        </g>
    </symbol>

    <symbol id="comments-icon" viewBox="0 0 24 24">
        <g id="a" clip-path="url(#b)"><path d="M24,0H0V24H24Z" fill="none"/><path d="M14,3H10a8,8,0,0,0,0,16v3.5c5-2,12-5,12-11.5a8,8,0,0,0-8-8ZM12,17H10A6,6,0,0,1,10,5h4a6,6,0,0,1,6,6c0,3.61-2.462,5.966-8,8.48Z"/></g>
    </symbol>

    <symbol id="views-icon" viewBox="0 0 24 24">
    <g>
        <path fill="none" d="M0 0h24v24H0z"/>
        <path d="M9 18H4v-8h5v8zm-2-2v-4H6v4h1zm6 0V8h-1v8h1zm2 2h-5V6h5v12zm4-2V4h-1v12h1zm2 2h-5V2h5v16zm1 4H3v-2h19v2z"/>
    </g>
    </symbol>

    <symbol id="envelope" viewBox="1 -95 511.99998 511">
        <path d="m16 32.5v256c0 8.835938 7.164062 16 16 16h448c8.835938 0 16-7.164062 16-16v-256l-240 112zm0 0" fill="#333"/><path d="m480 16.5h-448c-8.835938 0-16 7.164062-16 16l240 112 240-112c0-8.835938-7.164062-16-16-16zm0 0" fill="#333"/><path d="m512 32.117188c0-.207032 0-.386719 0-.59375-.527344-17.289063-14.699219-31.03125-32-31.023438h-448c-17.261719.042969-31.378906 13.769531-31.9023438 31.023438v.59375c0 .207031-.0976562.253906-.0976562.382812v256c0 17.671875 14.328125 32 32 32h448c17.671875 0 32-14.328125 32-32v-256c0-.128906 0-.257812 0-.382812zm-53.839844.382812-202.160156 94.398438-202.160156-94.398438zm-426.160156 256v-230.878906l217.230469 101.375c4.292969 2.003906 9.246093 2.003906 13.539062 0l217.230469-101.375v230.878906zm0 0" fill="#fff"/>
    </symbol>

    <symbol id="tiktok-icon" viewBox="0 0 512 512">
        <path fill="none" d="M0 0h24v24H0z"/>
        <path d="m480.32 128.39c-29.22 0-56.18-9.68-77.83-26.01-24.83-18.72-42.67-46.18-48.97-77.83-1.56-7.82-2.4-15.89-2.48-24.16h-83.47v228.08l-.1 124.93c0 33.4-21.75 61.72-51.9 71.68-8.75 2.89-18.2 4.26-28.04 3.72-12.56-.69-24.33-4.48-34.56-10.6-21.77-13.02-36.53-36.64-36.93-63.66-.63-42.23 33.51-76.66 75.71-76.66 8.33 0 16.33 1.36 23.82 3.83v-62.34-22.41c-7.9-1.17-15.94-1.78-24.07-1.78-46.19 0-89.39 19.2-120.27 53.79-23.34 26.14-37.34 59.49-39.5 94.46-2.83 45.94 13.98 89.61 46.58 121.83 4.79 4.73 9.82 9.12 15.08 13.17 27.95 21.51 62.12 33.17 98.11 33.17 8.13 0 16.17-.6 24.07-1.77 33.62-4.98 64.64-20.37 89.12-44.57 30.08-29.73 46.7-69.2 46.88-111.21l-.43-186.56c14.35 11.07 30.04 20.23 46.88 27.34 26.19 11.05 53.96 16.65 82.54 16.64v-60.61-22.49c.02.02-.22.02-.24.02z"/>
    </symbol>

    <symbol id="patreon-icon" enable-background="new 0 0 24 24" viewBox="0 0 24 24"><path d="m0 .5h4.219v23h-4.219z"/><path d="m15.384.5c-4.767 0-8.644 3.873-8.644 8.633 0 4.75 3.877 8.61 8.644 8.61 4.754 0 8.616-3.865 8.616-8.61 0-4.759-3.863-8.633-8.616-8.633z"/></symbol>

</svg>    <!-- start: #wrapper -->
    <div id="wrapper">
		            <div class="notice text underline-effect">
            <div class="grid-container">
                <div class="info">
                    <i class="fa fa-bell"></i>
                    <p>Check out <a href="https://linuxtechlab.com/devops-books/"><span style="color: #ff6600"><strong>Linux &amp; Devops Books you should read here</strong></span></a> &amp; also some <a href="https://linuxtechlab.com/exclusive-deals/"><strong><span style="color: #ff6600">Exclusive Deals here</span></strong></a></p>
                                    </div>
            </div>
        </div>
    
<!-- start: #header -->
<header id="header" class="advertising">

                      
        <div class="menu-mobile">
            <i class="remixicon remixicon-menu-line"></i>
        </div>
    
	<!-- start: .menu-wrapper -->
	<div class="menu-wrapper">
		<div class="grid-container">
            
			                <div class="logo">
                    <a href="https://linuxtechlab.com/"><img src="https://linuxtechlab.com/wp-content/uploads/2021/01/Linuxtechlab-1.png" alt="LinuxTechLab" width="" /></a>
                </div>
                			
                                <!-- start: .epcl-banner -->
    <div class="epcl-banner textcenter hide-on-tablet hide-on-mobile">
                    <!-- Ezoic - Header - top_of_page -->
<div id="ezoic-pub-ad-placeholder-139"> </div>
<!-- End Ezoic - Header - top_of_page -->            </div>
    <!-- end: .epcl-banner -->
    <div class="clear ad"></div>
            
                            <div class="share-buttons hide-on-tablet hide-on-mobile">
                                            <a href="https://www.facebook.com/linuxtechlab" target="_blank" rel="nofollow noopener" aria-label="Facebook"><i class="fa fa-facebook"></i></a>
                                                                <a href="https://twitter.com/linuxtechlab" target="_blank" rel="nofollow noopener" aria-label="Twitter"><i class="fa fa-twitter"></i></a>
                                                                <a href="https://in.linkedin.com/in/linuxtechlab" target="_blank" rel="nofollow noopener" aria-label="Linkedin"><i class="fa fa-linkedin"></i></a>
                                                                <a href="https://www.instagram.com/linuxtechlab/" target="_blank" rel="nofollow noopener" aria-label="Instagram"><i class="fa fa-instagram"></i></a>
                                                                <a href="https://in.pinterest.com/linuxtechlab" target="_blank" rel="nofollow noopener" aria-label="Pinterest"><i class="fa fa-pinterest"></i></a>
                                                                                    <a href="http://linuxtechlab.tumblr.com" target="_blank" rel="nofollow noopener" aria-label="Tumblr"><i class="fa fa-tumblr"></i></a>
                                                                                                                                        </div>
                        
			<!-- start: .main-nav -->
			<nav class="main-nav gradient-effect">
				<ul id="menu-top-navigation" class="menu"><li id="menu-item-65" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a href="https://linuxtechlab.com">Home</a></li>
<li id="menu-item-1994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1994"><a href="https://linuxtechlab.com/devops/">DevOps</a></li>
<li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li>
<li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="https://linuxtechlab.com/scripting/">Scripting</a></li>
<li id="menu-item-5703" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5703"><a href="https://linuxtechlab.com/tips-tricks/">Tips &amp; Tricks</a></li>
<li id="menu-item-5747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5747"><a href="https://linuxtechlab.com/reviews/"><i class="fa fa-android"></i> Reviews</a></li>
<li id="menu-item-6003" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6003"><a href="https://linuxtechlab.com/exclusive-deals/">Exclusive Deals</a></li>
<li id="menu-item-6257" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-6257"><a href="https://linuxtechlab.com/books-to-read/">Books</a>
<ul class="sub-menu">
	<li id="menu-item-6261" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6261"><a href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li>
	<li id="menu-item-6126" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6126"><a href="https://linuxtechlab.com/devops-books/">Linux &#038; DevOps Books you</a></li>
	<li id="menu-item-6266" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6266"><a href="https://linuxtechlab.com/linux-bash-scripting-books-you-should-read/">Linux &#038; Bash Scripting Books you should read</a></li>
	<li id="menu-item-6258" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6258"><a href="https://linuxtechlab.com/ansible-books-you-should-read/">Ansible Books you should read</a></li>
	<li id="menu-item-6259" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6259"><a href="https://linuxtechlab.com/aws-amazon-web-services-books-you-should-read/">AWS (Amazon Web Services) Books you should read</a></li>
	<li id="menu-item-6260" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6260"><a href="https://linuxtechlab.com/docker-books-you-should-read/">Docker Books you should read</a></li>
	<li id="menu-item-6262" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6262"><a href="https://linuxtechlab.com/git-gitlab-books-you-should-read/">Git &#038; Gitlab Books you should read</a></li>
	<li id="menu-item-6263" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6263"><a href="https://linuxtechlab.com/google-cloud-gcp-books-you-should-read/">Google Cloud (GCP) Books you should read</a></li>
	<li id="menu-item-6264" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6264"><a href="https://linuxtechlab.com/jenkins-books-you-should-read/">Jenkins Books you should read</a></li>
	<li id="menu-item-6265" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6265"><a href="https://linuxtechlab.com/kubernetes-books-you-should-read/">Kubernetes Books you should read</a></li>
	<li id="menu-item-6267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6267"><a href="https://linuxtechlab.com/microsoft-azure-books-you-should-read/">Microsoft Azure Books you should read</a></li>
	<li id="menu-item-6268" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6268"><a href="https://linuxtechlab.com/python-books-you-should-read/">Python Books you should read</a></li>
	<li id="menu-item-6269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6269"><a href="https://linuxtechlab.com/terraform-books-you-should-read/">Terraform Books you should read</a></li>
</ul>
</li>
<li class="search-menu-item hide-on-mobile hide-on-tablet"><a href="#search-lightbox" class="lightbox mfp-inline"><i class="remixicon remixicon-search-line"></i></a></li><li class="subscribe-menu-item hide-on-mobile hide-on-tablet"><a href="http://eepurl.com/cCSdrf" target="_blank" class="subscribe epcl-button red hide-on-tablet hide-on-mobile" rel="nofollow noopener">Subscribe our Newsletter <i class="fa fa-paper-plane"></i></a></li></ul>			</nav>
            <!-- end: .main-nav -->

                            <a href="#search-lightbox" class="lightbox epcl-search-button mfp-inline hide-on-desktop"><i class="remixicon remixicon-search-line"></i></a>
            
            <div class="clear"></div>
            <div class="border hide-on-tablet hide-on-mobile"></div>
		</div>
		<div class="clear"></div>
	</div>
	<!-- end: .menu-wrapper -->

	<div class="clear"></div>
</header>
<!-- end: #header -->

    <!-- start: .epcl-banner -->
    <div class="epcl-banner textcenter mobile-grid-100 epcl-banner-below_header grid-container" style="margin-top: 50px; margin-bottom: 50px;">
		            <a href="" target="_blank" rel="nofollow">
                <img src="" class="custom-image" alt="Banner">
            </a>
		    </div>
    <!-- end: .epcl-banner -->
    <div class="clear"></div>
	
        <div class="hide-on-mobile hide-on-tablet hide-on-desktop">
        <div id="search-lightbox" class="mfp-hide grid-container grid-small grid-parent">
            <h4 class="title small white textcenter fw-normal hide-on-mobile hide-on-tablet">Press <span>ESC</span> to close</h4>
            <div class="search-wrapper section">                
                <form action="https://linuxtechlab.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
            </div>
        </div>
    </div>

    	<!-- start: #single -->
	<main id="single" class="main grid-container standard" data-aos="fade" data-post-id="2933">

		<!-- start: .center -->
	    <div class="center content">

			<!-- Fullcover Style -->
            
            <!-- start: .epcl-page-wrapper -->
            <div class="epcl-page-wrapper">

                <!-- start: .content -->
                <div class="left-content grid-70 np-mobile">

                    <article class="main-article post-2933 post type-post status-publish format-standard has-post-thumbnail hentry category-how-tos category-tips-tricks tag-filesystem tag-linux-commands">

                                            
                                                    <header>

    	<div class="post-format-image post-format-wrapper ">
                                    <div class="featured-image">
                                            <img width="720" height="340" src="https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg" class="attachment-epcl_single_standard size-epcl_single_standard wp-post-image" alt="fsck command with examples" loading="lazy" data-lazy="false" srcset="https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg 720w, https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples-520x245.jpg 520w" sizes="(max-width: 720px) 100vw, 720px" />                                        <div class="tags absolute"><a href="https://linuxtechlab.com/how-tos/" class="tag-link-2">How To's</a><a href="https://linuxtechlab.com/tips-tricks/" class="tag-link-5">Tips &amp; Tricks</a></div>                </div>
            			</div>

    <!-- start: .meta -->
    <div class="meta">
                    <a href="https://linuxtechlab.com/author/shsuain/" title="Shusain" class="author meta-info hide-on-mobile">                                        
                                    <span class="author-image cover" style="background-image: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Shujat-website.png');"></span>
                                <span class="author-name">Shusain</span>
            </a>
            

            
                               
                <time class="meta-info" datetime="2020-06-10"><i class="remixicon remixicon-calendar-line"></i> June 10, 2020</time>
            
                            <span class="views-counter meta-info" title="Views">
                    <i class="remixicon remixicon-fire-line"></i> 228                </span>
                        
            <a href="#comments" class="comments tooltip" title="Go to comments">
                <i class="remixicon remixicon-chat-1-line fa-flip-horizontal"></i>
                                    <span class="comment-count">5</span>
                    <!-- <span class="comment-text hide-on-mobile">Comments</span> -->
                            </a>   
        
        <div class="clear"></div>
    
        <h1 class="title no-thumb large bold">Check Linux filesystem for errors: FSCK command with examples</h1>
    </div>
    <!-- end: .meta -->

	<div class="clear"></div>

</header>                        
                        <section class="post-content">

                            
                                                            <div class="epcl-share-container hide-on-mobile">
                                    <div class="epcl-share">
            
        <a class="facebook " rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https://linuxtechlab.com/?p=2933"
onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
            
    <a class="twitter " rel="nofollow noopener" href="https://twitter.com/share?text=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples&url=https://linuxtechlab.com/?p=2933" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
            
        <a class="linkedin " rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Flinuxtechlab.com%2F%3Fp%3D2933&title=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples&summary=The+FSCK+command+is+a+very+important+Linux%2FUnix+utility%2C+it+is+used+to+check+%26amp%3B+repair+the+errors+in+the+file+system.+It+is+similar..." onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
            
        <a class="pinterest " rel="nofollow noopener" href="//pinterest.com/pin/create/link/?url=https://linuxtechlab.com/?p=2933&media=https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg&description=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;"><i class="fa fa-pinterest"></i></a>
            
        <a class="telegram " rel="nofollow noopener" href="https://telegram.me/share/url?url=https://linuxtechlab.com/?p=2933&text=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples" onclick="window.open(this.href, 'telegram-share', 'width=490,height=530');return false;"><i class="fa fa-telegram"></i></a>
                
        <a class="email " rel="nofollow noopener" href="/cdn-cgi/l/email-protection#0b34787e69616e687f3648636e6860204762657e73206d62676e7872787f6e66206d6479206e79796479782e384a204d58484020686466666a656f207c627f63206e736a667b676e782d69646f7236637f7f7b783124246762657e737f6e6863676a692568646624347b3639323838" target="_blank"><i class="fa fa-envelope"></i></a>
            
            <a class="whatsapp " rel="nofollow noopener" href="https://api.whatsapp.com/send?text=https://linuxtechlab.com/?p=2933" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>    
        </div>                                </div>
                            
                            <div class="text">
                                <p class="western">The FSCK command is a very important Linux/Unix utility, it is used to check &amp; repair the errors in the file system. It is similar to 'chkdsk' utility in Windows operating systems. It is available for Linux, macOS, FreeBSD operating systems.</p>
<p class="western">FSCK stands for File System Consistency Check &amp; most of the time, it runs at boot time but can also be started manually by the superuser, if the need arises.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'>
<!-- Ezoic - under_second_paragraph 108 - under_second_paragraph -->
<div id="ezoic-pub-ad-placeholder-108"> </div>
<!-- End Ezoic - under_second_paragraph 108 - under_second_paragraph --></div>

<p class="western">It can be used with 3 modes of operation,</p>
<p class="western"><strong>1-</strong> Check for errors &amp; let the user decide what should be done with each error,</p>
<p class="western"><strong>2-</strong> Check for errors &amp; make repairs automatically, or,</p>
<p class="western"><strong>3-</strong> Check for errors &amp; display the error but does not perform any repairs.</p>
<p><strong>(Recommended Read: <a href="https://linuxtechlab.com/learn-use-tcpdump-command-examples/"><span style="color: #993300;">Learn to use TCPDUMP command with examples</span></a>)</strong></p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'>
<!-- Ezoic - in content another - mid_content -->
<div id="ezoic-pub-ad-placeholder-103"></div>
<!-- End Ezoic - in content another - mid_content --></div>

<hr />
<h3 class="western">The syntax for using FSCK</h3>
<p class="western">We can use the FSCK command manually with the following syntax,</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck options drives</strong></span></p>
<p class="western">The options that can be used with the fsck command are,</p>
<p class="western"><strong>-p  </strong>    Automatic repair (no questions)</p>
<p class="western"><strong>-n</strong>      Make no changes to the filesystem</p>
<p class="western"><strong>-y  </strong>    Assume "yes" to all questions</p>
<p class="western"><strong>-c</strong>      Check for bad blocks and add them to the bad block list</p>
<p class="western"><strong>-f  </strong>    Force checking even if the filesystem is marked clean</p>
<p class="western"><strong>-v  </strong>   Be verbose</p><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- Ezoic - mid_content 111 - mid_content -->
<div id="ezoic-pub-ad-placeholder-111"> </div>
<!-- End Ezoic - mid_content 111 - mid_content --></div>

<p class="western"><strong>-b   </strong>  superblock Use alternative superblock</p>
<div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<!-- Ezoic - mid_content 111 - mid_content -->
<div id="ezoic-pub-ad-placeholder-111"> </div>
<!-- End Ezoic - mid_content 111 - mid_content --></div>
<p class="western"><strong>-B</strong>     blocksize Force blocksize when looking for the superblock</p>
<p class="western"><strong>-j   </strong>   external_journal Set location of the external journal</p>
<p class="western"><strong>-l </strong>     bad_blocks_file Add to bad blocks list</p>
<p class="western"><strong>-L </strong>    bad_blocks_file Set bad blocks list</p>
<p class="western">We can use any of the following options, depending on the operation we need to perform. Let's discuss some of the options of the fsck command with examples.</p>
<hr />
<h3 class="western">Fsck command with examples</h3>
<p class="western"><b>Note:- </b>Before we discuss any examples, please read this. We should not be using FSCK on mounted drives, as there will be high chances that fsck on the mounted drive will damage the drive permanently. So before performing fsck, we must unmount the drive with the following command,</p>
<p class="western"><span style="color: #333399;"><strong>$ umount drive-name</strong></span></p>
<p class="western">For example,</p>
<p class="western"><span style="color: #333399;"><strong>$ umount /dev/sdb1</strong></span></p>
<p class="western">You can check the partition number with the following command,</p><div class='code-block code-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<!-- Ezoic - mid_content 111 - mid_content -->
<div id="ezoic-pub-ad-placeholder-111"> </div>
<!-- End Ezoic - mid_content 111 - mid_content --></div>

<p class="western"><span style="color: #333399;"><strong>$ fdisk -l</strong></span></p>
<p class="western">Also while running the fsck, we might get some error codes. Below mentioned is the list of error codes that we might get along with their meanings,</p>
<p class="western"><b>0</b> - No errors<br />
<b>1</b> - Filesystem errors corrected<br />
<b>2</b> - The system should be rebooted<br />
<b>4</b> - Filesystem errors left uncorrected<br />
<b>8</b> - Operational error<br />
<b>16</b> - Usage or syntax error<br />
<b>32</b> - Fsck canceled by user request<br />
<b>128</b> - Shared-library error</p>
<p class="western">Now let's discuss usage of the fsck command with examples,</p>
<p>&nbsp;</p>
<h3 class="western">Perform an error check on a single partition</h3>
<p class="western">To perform a file check on a single partition, run the following command from the terminal,</p>
<p class="western"><span style="color: #333399;"><strong>$ umount /dev/sdb1</strong></span></p>
<p class="western"><span style="color: #333399;"><strong>$ fsck /dev/sdb1</strong></span></p>
<p>&nbsp;</p>
<h3 class="western">Check filesystem for errors &amp; repair them automatically</h3>
<p class="western">Run the fsck command with 'a' option to perform consistency check &amp; to repair them automatically, execute the following command. We can also use the 'y' option in place of option 'a'.</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -a /dev/sdb1</strong></span></p>
<p>&nbsp;</p>
<h3 class="western">Check filesystem for errors but don't repair them</h3>
<p class="western">In case we only need to see the error that is occurring on our file system &amp; doesn't need to repair them, then we should run fsck with option 'n',</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -n /dev/sdb1</strong></span></p>
<p>&nbsp;</p>
<h3 class="western">Perform an error check on all partitions</h3>
<p class="western">To perform a filesystem check for all partitions in single go, use fsck with 'A' option,</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -A</strong></span></p>
<p class="western">To disable the root file system check, we will use the option 'R'</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -AR</strong></span></p>
<p>&nbsp;</p>
<h3 class="western">Check the only partition with mentioned filesystem</h3>
<p class="western">In order to run fsck on all the partitions with mentioned filesystem type, for example, 'ext4', use fsck with option 't' followed by filesystem type,</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -t ext4 /dev/sdb1</strong></span></p>
<p class="western">or</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -t -A ext4</strong></span></p>
<p>&nbsp;</p>
<h3 class="western">Perform consistency check only on unmounted drives</h3>
<p class="western">To make sure that the fsck is performed only on unmounted drives, we will use the option 'M' while running fsck,</p>
<p class="western"><span style="color: #333399;"><strong>$ fsck -AM</strong></span></p>
<h3>
Get the complete list of options with the help</h3>
<p><span style="color: #333399;"><strong>$ fsck --help</strong></span></p>
<p><img loading="lazy" class="alignnone size-full wp-image-5804" src="https://linuxtechlab.com/wp-content/uploads/2020/06/Screenshot-from-2021-01-29-21-25-08.png" alt="fsck command" width="527" height="544" srcset="https://linuxtechlab.com/wp-content/uploads/2020/06/Screenshot-from-2021-01-29-21-25-08.png 527w, https://linuxtechlab.com/wp-content/uploads/2020/06/Screenshot-from-2021-01-29-21-25-08-48x50.png 48w, https://linuxtechlab.com/wp-content/uploads/2020/06/Screenshot-from-2021-01-29-21-25-08-97x100.png 97w, https://linuxtechlab.com/wp-content/uploads/2020/06/Screenshot-from-2021-01-29-21-25-08-436x450.png 436w" sizes="(max-width: 527px) 100vw, 527px" /></p>
<p class="western">This was our tutorial on the fsck command with examples. Please feel free to send in your questions or queries to us, using the comment box below.</p>
<div style="padding: 1.5em; background: #E1DDDD; border: 0.125em solid #c5dbe5; border-width: 0.125em 0;">
<p style="margin-bottom: 0.75em;">If you think we have helped you or just want to support us, please consider these :-</p>
<p style="margin-bottom: 0.75em;">Connect to us: <a href="https://www.facebook.com/linuxtechlab/"><span style="color: #ff0000;">Facebook</span></a> | <a href="https://twitter.com/LinuxTechLab"><span style="color: #ff0000;">Twitter</span></a></p>
<p style="margin-bottom: 0.75em;">Linux TechLab is thankful for your continued support.</p>
</div>

<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div><!-- AI CONTENT END 3 -->
                                                            </div>
                            <div class="clear"></div>

                            
                            
                                                            <!-- start: .share-buttons -->
                                <div class="share-buttons section">
                                    <h5 class="title small">Share Article:</h5>
                                                                        <div class="epcl-share-bottom">
            
        <a class="facebook epcl-button circle" rel="nofollow noopener" href="https://www.facebook.com/sharer/sharer.php?u=https://linuxtechlab.com/?p=2933"
onclick="window.open(this.href, 'facebook-share','width=580,height=296');return false;"><i class="fa fa-facebook"></i></a>
            
    <a class="twitter epcl-button circle" rel="nofollow noopener" href="https://twitter.com/share?text=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples&url=https://linuxtechlab.com/?p=2933" onclick="window.open(this.href, 'twitter-share', 'width=550,height=235');return false;"><i class="fa fa-twitter"></i></a>
            
        <a class="linkedin epcl-button circle" rel="nofollow noopener" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Flinuxtechlab.com%2F%3Fp%3D2933&title=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples&summary=The+FSCK+command+is+a+very+important+Linux%2FUnix+utility%2C+it+is+used+to+check+%26amp%3B+repair+the+errors+in+the+file+system.+It+is+similar..." onclick="window.open(this.href, 'linkedin-share', 'width=490,height=530');return false;"><i class="fa fa-linkedin"></i></a>
            
        <a class="pinterest epcl-button circle" rel="nofollow noopener" href="//pinterest.com/pin/create/link/?url=https://linuxtechlab.com/?p=2933&media=https://linuxtechlab.com/wp-content/uploads/2017/12/Check-Linux-filesystem-for-errors-FSCK-command-with-examples.jpg&description=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples" onclick="window.open(this.href, 'pinterest-share', 'width=490,height=530');return false;"><i class="fa fa-pinterest"></i></a>
            
        <a class="telegram epcl-button circle" rel="nofollow noopener" href="https://telegram.me/share/url?url=https://linuxtechlab.com/?p=2933&text=Check+Linux+filesystem+for+errors%3A+FSCK+command+with+examples" onclick="window.open(this.href, 'telegram-share', 'width=490,height=530');return false;"><i class="fa fa-telegram"></i></a>
                
        <a class="email epcl-button circle" rel="nofollow noopener" href="/cdn-cgi/l/email-protection#7f400c0a1d151a1c0b423c171a1c14543316110a07541916131a0c060c0b1a125419100d541a0d0d100d0c5a4c3e54392c3c34541c1012121e111b5408160b17541a071e120f131a0c591d101b0642170b0b0f0c4550501316110a070b1a1c17131e1d511c101250400f424d464c4c" target="_blank"><i class="fa fa-envelope"></i></a>
            
            <a class="whatsapp epcl-button circle" rel="nofollow noopener" href="https://api.whatsapp.com/send?text=https://linuxtechlab.com/?p=2933" data-action="share/whatsapp/share"><i class="fa fa-whatsapp"></i></a>    
        </div>                                    <div class="clear"></div>
                                    <div class="permalink">
                                        <input type="text" name="shortlink" value="https://linuxtechlab.com/linux-filesystem-errors-fsck-command-with-examples/" id="copy-link" readonly>
                                        <span class="copy"><svg><use xlink:href="#copy"></use></svg></span>
                                    </div>
                                </div>
                                <!-- end: .share-buttons -->
                            
                        </section>

                                                    <div class="bottom-tags">
                                <i class="remixicon remixicon-price-tag-3-line"></i>
                                <a href="https://linuxtechlab.com/tag/filesystem/" rel="tag">filesystem</a>, <a href="https://linuxtechlab.com/tag/linux-commands/" rel="tag">linux commands</a>                            </div>
                        
                        
                    </article>
                    <div class="clear"></div>

                    	    
    <!-- start: .author -->
    <section id="author" class="author  with-avatar section">
                    <div class="avatar">
                    <a href="https://linuxtechlab.com/author/shsuain/" class="hover-effect thumb"><span class="fullimage cover" style="background-image: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Shujat-website.png');"></span></a>
            </div>
                <div class="info">
                            <h4 class="title author-name gradient-effect"><a href="https://linuxtechlab.com/author/shsuain/">Shusain</a></h4>
            	
            
            <p>Passionate about Linux &amp; open source.
Loves to learn, read &amp; write about Linux as well as new technologies.</p>
            <div class="social">
                                                    <a href="https://linuxtechlab.com" class="website" title="Website: https://linuxtechlab.com" target="_blank" rel="nofollow noopener"><i class="fa fa-globe"></i></a>
                                                    <a href="https://twitter.com/linuxtechlab" class="twitter" title="Follow me on Twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i></a>
                                                    <a href="https://www.facebook.com/linuxtechlab" class="facebook" title="Follow me on Facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i></a>
                                                                            <a href="https://instagram.com/linuxtechlab" class="custom-social fa fa-instagram translate-effect" target="_blank" rel="nofollow noopener" title=""></a>
                                            <a href="https://linkedin.com/in/linuxtechlab" class="custom-social fa fa-linkedin translate-effect" target="_blank" rel="nofollow noopener" title=""></a>
                                            <a href="https://linuxtechlab.tumblr.com" class="custom-social fa fa-tumblr translate-effect" target="_blank" rel="nofollow noopener" title=""></a>
                                            <a href="https://linuxtechlab.medium.com" class="custom-social fa fa-medium translate-effect" target="_blank" rel="nofollow noopener" title=""></a>
                                                </div>
        </div>
        <div class="clear"></div>
    </section>
    <!-- end: .author -->
    <div class="clear"></div>

                    
                        <section class="related section">
                                                                                        <article class="prev grid-50 tablet-grid-50 grid-parent">
                                                                                                                        <div class="thumb cover" style="background: url('https://linuxtechlab.com/wp-content/uploads/2017/02/Master-Slave-DNS.jpg');"></div>
                                                                                                                <a href="https://linuxtechlab.com/master-slave-dns-setup-with-bind/" class="full-link"></a>                              
                                    <div class="info">
                                                                                    <time datetime="2020-06-09">
                                                June 9, 2020                                            </time>
                                                                                <h4 class="title white no-margin">How to create Bind DNS master slave setup in CentOS</h4>
                                    </div>                                
                                    <span class="epcl-button red"><img src="https://linuxtechlab.com/wp-content/themes/breek/assets/images/left-arrow.svg" width="15" alt="Left Arrow"></span>
                                    <div class="overlay"></div>
                                </article>
                            
                                                                                        <article class="next grid-50 tablet-grid-50 grid-parent">
                                                                                                                        <div class="thumb cover" style="background: url('https://linuxtechlab.com/wp-content/uploads/2020/06/New-way-to-Dual-Boot-Ubuntu-with-Windows-10--e1600796726221.jpg');"></div>
                                                                                                                <a href="https://linuxtechlab.com/new-way-to-dual-boot-ubuntu-with-windows-10/" class="full-link"></a>                            
                                    <div class="info">
                                                                                    <time datetime="2020-06-23">
                                                June 23, 2020                                            </time>
                                                                                <h4 class="title white no-margin">New way to Dual Boot Ubuntu with Windows 10</h4>                                
                                    </div>
                                    <span class="epcl-button red"><img src="https://linuxtechlab.com/wp-content/themes/breek/assets/images/right-arrow.svg" width="15" alt="Right Arrow"></span>
                                    <div class="overlay"></div>
                                </article>
                                                        <div class="clear"></div>
                        </section>

                    
                    <div class="clear"></div>

                                            
    <!-- start: #comments -->
    <div id="comments" class="bg-white hosted section have-comments">

                    <h3 class="title bordered">
                5 Comments            </h3>
            <!-- start: .commentlist -->
            <ol class="commentlist">
                    <li class="comment even thread-even depth-1 count-1" id="comment-263">
    	            <div class="avatar grid-10 tablet-grid-15 mobile-grid-15"><img alt='' src='https://secure.gravatar.com/avatar/c9027a65fc17c2527be2d71c678172b8?s=96&#038;d=retro&#038;r=g' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></div>
                <div class="right grid-90 tablet-grid-85 mobile-grid-85">
            <cite class="comment-author">Darksun</cite>
            <span class="date">on December 27, 2017</span>
            <div class="clear"></div>
            <div class="text">
                                <p>Now let’s discuss usage of *fdisk* command with examples,<br />
I think you mean &#8220;fsck&#8221;?</p>
			
            </div>
            <a rel='nofollow' class='comment-reply-link epcl-button green' href='#comment-263' data-commentid="263" data-postid="2933" data-belowelement="comment-263" data-respondelement="respond" data-replyto="Reply to Darksun" aria-label='Reply to Darksun'>Reply</a>        </div>
        <div class="clear"></div>
<ul class="children">
    <li class="comment byuser comment-author-shsuain bypostauthor odd alt depth-2 count-2" id="comment-266">
    	            <div class="avatar grid-10 tablet-grid-15 mobile-grid-15"><img src="https://linuxtechlab.com/wp-content/uploads/2021/02/Shujat-website-120x120.png" width="144" class="avatar" alt="Avatar"></div>
                <div class="right grid-90 tablet-grid-85 mobile-grid-85">
            <cite class="comment-author"><a href='https://linuxtechlab.com' rel='external nofollow ugc' class='url'>Shusain</a></cite>
            <span class="date">on December 27, 2017</span>
            <div class="clear"></div>
            <div class="text">
                                <p>Thanks for pointing out.</p>
			
            </div>
            <a rel='nofollow' class='comment-reply-link epcl-button green' href='#comment-266' data-commentid="266" data-postid="2933" data-belowelement="comment-266" data-respondelement="respond" data-replyto="Reply to Shusain" aria-label='Reply to Shusain'>Reply</a>        </div>
        <div class="clear"></div>
</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1 count-3" id="comment-4278">
    	            <div class="avatar grid-10 tablet-grid-15 mobile-grid-15"><img alt='' src='https://secure.gravatar.com/avatar/bf0d37316ecf312fe76c2ba11904e812?s=96&#038;d=retro&#038;r=g' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></div>
                <div class="right grid-90 tablet-grid-85 mobile-grid-85">
            <cite class="comment-author">kritika chaos unleashed hack</cite>
            <span class="date">on September 30, 2018</span>
            <div class="clear"></div>
            <div class="text">
                                <p>stays on topic and states valid points.  Thank you.</p>
			
            </div>
            <a rel='nofollow' class='comment-reply-link epcl-button green' href='#comment-4278' data-commentid="4278" data-postid="2933" data-belowelement="comment-4278" data-respondelement="respond" data-replyto="Reply to kritika chaos unleashed hack" aria-label='Reply to kritika chaos unleashed hack'>Reply</a>        </div>
        <div class="clear"></div>
</li><!-- #comment-## -->
    <li class="comment odd alt thread-even depth-1 count-4" id="comment-4734">
    	            <div class="avatar grid-10 tablet-grid-15 mobile-grid-15"><img alt='' src='https://secure.gravatar.com/avatar/c454795bdbe55f8aea6ba243db35d5f8?s=96&#038;d=retro&#038;r=g' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></div>
                <div class="right grid-90 tablet-grid-85 mobile-grid-85">
            <cite class="comment-author">Shannan</cite>
            <span class="date">on October 15, 2018</span>
            <div class="clear"></div>
            <div class="text">
                                <p>Thanks for the great article</p>
			
            </div>
            <a rel='nofollow' class='comment-reply-link epcl-button green' href='#comment-4734' data-commentid="4734" data-postid="2933" data-belowelement="comment-4734" data-respondelement="respond" data-replyto="Reply to Shannan" aria-label='Reply to Shannan'>Reply</a>        </div>
        <div class="clear"></div>
</li><!-- #comment-## -->
    <li class="comment even thread-odd thread-alt depth-1 count-5" id="comment-4773">
    	            <div class="avatar grid-10 tablet-grid-15 mobile-grid-15"><img alt='' src='https://secure.gravatar.com/avatar/5ed13ee31851b90234bdb420bae3053a?s=96&#038;d=retro&#038;r=g' class='avatar avatar-96 photo' height='96' width='96' loading='lazy' /></div>
                <div class="right grid-90 tablet-grid-85 mobile-grid-85">
            <cite class="comment-author">Google</cite>
            <span class="date">on October 16, 2018</span>
            <div class="clear"></div>
            <div class="text">
                                <p>The facts talked about inside the write-up are a few of the very best accessible.</p>
			
            </div>
            <a rel='nofollow' class='comment-reply-link epcl-button green' href='#comment-4773' data-commentid="4773" data-postid="2933" data-belowelement="comment-4773" data-respondelement="respond" data-replyto="Reply to Google" aria-label='Reply to Google'>Reply</a>        </div>
        <div class="clear"></div>
</li><!-- #comment-## -->
            </ol>
            <!-- end: .commentlist  -->

            
            
                	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title title bordered">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/linux-filesystem-errors-fsck-command-with-examples/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linuxtechlab.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><textarea id="comment" name="comment" aria-required="true" rows="10" placeholder="Comment"></textarea><input class="form-author" name="author" type="text" placeholder="Name" value="" size="30" aria-required='true' required />
<input class="form-email" name="email" type="email" placeholder="Email" value="" size="30" aria-required='true' required />
<input class="form-website" name="url" type="text" placeholder="Website" value="" size="30" />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="epcl-button" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='2933' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="07837c92b8" /></p><input type="hidden" id="ak_js" name="ak_js" value="40"/><textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100" style="display: none !important;"></textarea></form>	</div><!-- #respond -->
	        <div class="clear"></div>
    </div>
    <!-- end: #comments -->
                    
                    
                    
                    <div class="clear"></div>
                </div>
                <!-- end: .content -->

                    <!-- start: #sidebar -->
    <aside id="sidebar" class="grid-30 np-mobile no-sidebar">
        <div class="default-sidebar"><section id="search-2" class="widget widget_search"><h4 class="widget-title title bordered">Search Bar</h4><form action="https://linuxtechlab.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
<div class="clear"></div></section><section id="epcl_social-2" class="widget widget_epcl_social"><h4 class="widget-title title bordered">Social</h4><div class="icons title"><a href="https://twitter.com/linuxtechlab" class="twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i><p>Twitter <span>Follow me!</span></p></a><a href="https://www.facebook.com/linuxtechlab" class="facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i><p>Facebook <span>Follow me!</span></p></a><a href="https://www.instagram.com/linuxtechlab/" class="instagram" target="_blank" rel="nofollow noopener"><i class="fa fa-instagram"></i><p>Instagram <span>Our photos!</span></p></a><a href="https://in.linkedin.com/in/linuxtechlab" class="linkedin" target="_blank" rel="nofollow noopener"><i class="fa fa-linkedin"></i> <p>Linkedin <span>Visit me!</span></p></a><a href="https://in.pinterest.com/linuxtechlab" class="pinterest" target="_blank" rel="nofollow noopener"><i class="fa fa-pinterest"></i><p>Pinterest <span>Pin it!</span></p></a><a href="http://linuxtechlab.tumblr.com" class="tumblr" target="_blank" rel="nofollow noopener"><i class="fa fa-tumblr"></i><p>Tumblr <span>Visit me!</span></p></a></div><div class="clear"></div></section><section id="text-27" class="widget widget_text">			<div class="textwidget"><p><!-- Ezoic - Sidead-widget - sidebar_middle --></p>
<div id="ezoic-pub-ad-placeholder-101"></div>
<p><!-- End Ezoic - Sidead-widget - sidebar_middle --></p>
</div>
		<div class="clear"></div></section><section id="epcl_featured_category-2" class="widget widget_epcl_featured_category"><h4 class="widget-title title bordered">Featured posts</h4><article class="item post-6227 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-server tag-wordpress tag-wordpress-hosting">

                    <a href="https://linuxtechlab.com/create-a-free-wordpress-website/" class="thumb hover-effect" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE">
                            <span class="fullimage cover" role="img" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/03/Step-by-step-guide-to-create-a-FREE-WORDPRESS-WEBSITE-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-03-08">March 8, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-a-free-wordpress-website/">Step by step guide to create a FREE WORDPRESS WEBSITE</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6189 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-reviews">

                    <a href="https://linuxtechlab.com/10-best-vpn-services-to-use/" class="thumb hover-effect" aria-label="10 Best VPN services you can use in 2021">
                            <span class="fullimage cover" role="img" aria-label="best vpn services" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/10-Best-VPN-services-you-can-use-in-2021-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-17">February 17, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/10-best-vpn-services-to-use/">10 Best VPN services you can use in 2021</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6146 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-website tag-wordpress">

                    <a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/" class="thumb hover-effect" aria-label="Create your own WordPress Website from Scratch : Step by Step">
                            <span class="fullimage cover" role="img" aria-label="create wordpress website from scratch" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Create-your-own-WordPress-Website-from-Scratch-_-Step-by-Step-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-10">February 10, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/">Create your own WordPress Website from Scratch : Step by Step</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5918 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-dns tag-hosting">

                    <a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/" class="thumb hover-effect" aria-label="Hostgator Hosting Review: Is Hostgator Good ?">
                            <span class="fullimage cover" role="img" aria-label="is hostgator good" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Is-hostgator-good-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-01">February 1, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/">Hostgator Hosting Review: Is Hostgator Good ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5717 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-secure tag-security tag-torrent tag-vpn">

                    <a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/" class="thumb hover-effect" aria-label="CyberGhost: Is it the best VPN for Torrenting, Streaming ?">
                            <span class="fullimage cover" role="img" aria-label="best vpn for torrenting" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/01/CyberGhost_-Is-it-the-best-VPN-for-you-your-home-___-1-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-01-25">January 25, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/">CyberGhost: Is it the best VPN for Torrenting, Streaming ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><div class="clear"></div></section></div>
                    <div class="mobile-sidebar hide-on-desktop"><section id="search-2" class="widget widget_search"><h4 class="widget-title title bordered">Search Bar</h4><form action="https://linuxtechlab.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
<div class="clear"></div></section><section id="epcl_social-2" class="widget widget_epcl_social"><h4 class="widget-title title bordered">Social</h4><div class="icons title"><a href="https://twitter.com/linuxtechlab" class="twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i><p>Twitter <span>Follow me!</span></p></a><a href="https://www.facebook.com/linuxtechlab" class="facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i><p>Facebook <span>Follow me!</span></p></a><a href="https://www.instagram.com/linuxtechlab/" class="instagram" target="_blank" rel="nofollow noopener"><i class="fa fa-instagram"></i><p>Instagram <span>Our photos!</span></p></a><a href="https://in.linkedin.com/in/linuxtechlab" class="linkedin" target="_blank" rel="nofollow noopener"><i class="fa fa-linkedin"></i> <p>Linkedin <span>Visit me!</span></p></a><a href="https://in.pinterest.com/linuxtechlab" class="pinterest" target="_blank" rel="nofollow noopener"><i class="fa fa-pinterest"></i><p>Pinterest <span>Pin it!</span></p></a><a href="http://linuxtechlab.tumblr.com" class="tumblr" target="_blank" rel="nofollow noopener"><i class="fa fa-tumblr"></i><p>Tumblr <span>Visit me!</span></p></a></div><div class="clear"></div></section><section id="text-27" class="widget widget_text">			<div class="textwidget"><p><!-- Ezoic - Sidead-widget - sidebar_middle --></p>
<div id="ezoic-pub-ad-placeholder-101"></div>
<p><!-- End Ezoic - Sidead-widget - sidebar_middle --></p>
</div>
		<div class="clear"></div></section><section id="epcl_featured_category-2" class="widget widget_epcl_featured_category"><h4 class="widget-title title bordered">Featured posts</h4><article class="item post-6227 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-server tag-wordpress tag-wordpress-hosting">

                    <a href="https://linuxtechlab.com/create-a-free-wordpress-website/" class="thumb hover-effect" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE">
                            <span class="fullimage cover" role="img" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/03/Step-by-step-guide-to-create-a-FREE-WORDPRESS-WEBSITE-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-03-08">March 8, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-a-free-wordpress-website/">Step by step guide to create a FREE WORDPRESS WEBSITE</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6189 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-reviews">

                    <a href="https://linuxtechlab.com/10-best-vpn-services-to-use/" class="thumb hover-effect" aria-label="10 Best VPN services you can use in 2021">
                            <span class="fullimage cover" role="img" aria-label="best vpn services" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/10-Best-VPN-services-you-can-use-in-2021-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-17">February 17, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/10-best-vpn-services-to-use/">10 Best VPN services you can use in 2021</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6146 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-website tag-wordpress">

                    <a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/" class="thumb hover-effect" aria-label="Create your own WordPress Website from Scratch : Step by Step">
                            <span class="fullimage cover" role="img" aria-label="create wordpress website from scratch" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Create-your-own-WordPress-Website-from-Scratch-_-Step-by-Step-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-10">February 10, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/">Create your own WordPress Website from Scratch : Step by Step</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5918 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-dns tag-hosting">

                    <a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/" class="thumb hover-effect" aria-label="Hostgator Hosting Review: Is Hostgator Good ?">
                            <span class="fullimage cover" role="img" aria-label="is hostgator good" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Is-hostgator-good-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-01">February 1, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/">Hostgator Hosting Review: Is Hostgator Good ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5717 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-secure tag-security tag-torrent tag-vpn">

                    <a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/" class="thumb hover-effect" aria-label="CyberGhost: Is it the best VPN for Torrenting, Streaming ?">
                            <span class="fullimage cover" role="img" aria-label="best vpn for torrenting" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/01/CyberGhost_-Is-it-the-best-VPN-for-you-your-home-___-1-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-01-25">January 25, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/">CyberGhost: Is it the best VPN for Torrenting, Streaming ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><div class="clear"></div></section></div>
            </aside>
    <!-- end: #sidebar -->

            </div>
            <!-- end: .epcl-page-wrapper -->            
        
        </div>
        <!-- end: .center -->

	</main>
	<!-- end: #single -->




        <!-- start: #footer -->
<footer id="footer" class="grid-container hide-default">

            <div class="widgets row gradient-effect">
            <div class="default-sidebar border-effect"><div class="grid-33 tablet-grid-50 mobile-grid-100"><section id="nav_menu-4" class="widget widget_nav_menu underline-effect"><div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-6004" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6004"><a href="https://linuxtechlab.com/exclusive-deals/">Exclusive Deals</a></li>
<li id="menu-item-6005" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6005"><a href="https://linuxtechlab.com/reviews/">Reviews</a></li>
<li id="menu-item-4389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-4389"><a href="https://linuxtechlab.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-4390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4390"><a href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li>
<li id="menu-item-5532" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5532"><a href="https://linuxtechlab.com/get-in-touch/">Get in Touch</a></li>
<li id="menu-item-6125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6125"><a href="https://linuxtechlab.com/devops-books/">Linux &#038; DevOps Books you should read</a></li>
</ul></div><div class="clear"></div></section></div>
		<div class="grid-33 tablet-grid-50 mobile-grid-100"><section id="recent-posts-3" class="widget widget_recent_entries underline-effect">
		<h4 class="widget-title title white bordered">Recent Posts</h4>
		<ul>
											<li>
					<a href="https://linuxtechlab.com/simple-way-to-configure-nginx-reverse-proxy/">Simple guide on How to setup Nginx Reverse Proxy</a>
									</li>
											<li>
					<a href="https://linuxtechlab.com/create-a-free-wordpress-website/">Step by step guide to create a FREE WORDPRESS WEBSITE</a>
									</li>
											<li>
					<a href="https://linuxtechlab.com/what-is-malware-and-protect-from-it/">What is Malware and how to protect from it</a>
									</li>
											<li>
					<a href="https://linuxtechlab.com/5-advantages-of-using-socks5-proxy/">5 Advantages of using a SOCKS5 Proxy</a>
									</li>
											<li>
					<a href="https://linuxtechlab.com/10-best-vpn-services-to-use/">10 Best VPN services you can use in 2021</a>
									</li>
					</ul>

		<div class="clear"></div></section></div></div>
            <div class="clear"></div>
                            <div class="mobile-sidebar hide-on-desktop"><section id="search-2" class="widget widget_search"><h4 class="widget-title title bordered">Search Bar</h4><form action="https://linuxtechlab.com/" method="get" class="search-form">
	<input type="text" name="s" id="s" value="" class="search-field" placeholder="Type to start your search..." aria-label="Type to start your search..." required>
	<button type="submit" class="submit" aria-label="Submit"><i class="remixicon remixicon-search-line"></i></button>
</form>
<div class="clear"></div></section><section id="epcl_social-2" class="widget widget_epcl_social"><h4 class="widget-title title bordered">Social</h4><div class="icons title"><a href="https://twitter.com/linuxtechlab" class="twitter" target="_blank" rel="nofollow noopener"><i class="fa fa-twitter"></i><p>Twitter <span>Follow me!</span></p></a><a href="https://www.facebook.com/linuxtechlab" class="facebook" target="_blank" rel="nofollow noopener"><i class="fa fa-facebook"></i><p>Facebook <span>Follow me!</span></p></a><a href="https://www.instagram.com/linuxtechlab/" class="instagram" target="_blank" rel="nofollow noopener"><i class="fa fa-instagram"></i><p>Instagram <span>Our photos!</span></p></a><a href="https://in.linkedin.com/in/linuxtechlab" class="linkedin" target="_blank" rel="nofollow noopener"><i class="fa fa-linkedin"></i> <p>Linkedin <span>Visit me!</span></p></a><a href="https://in.pinterest.com/linuxtechlab" class="pinterest" target="_blank" rel="nofollow noopener"><i class="fa fa-pinterest"></i><p>Pinterest <span>Pin it!</span></p></a><a href="http://linuxtechlab.tumblr.com" class="tumblr" target="_blank" rel="nofollow noopener"><i class="fa fa-tumblr"></i><p>Tumblr <span>Visit me!</span></p></a></div><div class="clear"></div></section><section id="text-27" class="widget widget_text">			<div class="textwidget"><p><!-- Ezoic - Sidead-widget - sidebar_middle --></p>
<div id="ezoic-pub-ad-placeholder-101"></div>
<p><!-- End Ezoic - Sidead-widget - sidebar_middle --></p>
</div>
		<div class="clear"></div></section><section id="epcl_featured_category-2" class="widget widget_epcl_featured_category"><h4 class="widget-title title bordered">Featured posts</h4><article class="item post-6227 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-server tag-wordpress tag-wordpress-hosting">

                    <a href="https://linuxtechlab.com/create-a-free-wordpress-website/" class="thumb hover-effect" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE">
                            <span class="fullimage cover" role="img" aria-label="Step by step guide to create a FREE WORDPRESS WEBSITE" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/03/Step-by-step-guide-to-create-a-FREE-WORDPRESS-WEBSITE-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-03-08">March 8, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-a-free-wordpress-website/">Step by step guide to create a FREE WORDPRESS WEBSITE</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6189 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-reviews">

                    <a href="https://linuxtechlab.com/10-best-vpn-services-to-use/" class="thumb hover-effect" aria-label="10 Best VPN services you can use in 2021">
                            <span class="fullimage cover" role="img" aria-label="best vpn services" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/10-Best-VPN-services-you-can-use-in-2021-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-17">February 17, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/10-best-vpn-services-to-use/">10 Best VPN services you can use in 2021</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-6146 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos category-reviews tag-hosting tag-website tag-wordpress">

                    <a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/" class="thumb hover-effect" aria-label="Create your own WordPress Website from Scratch : Step by Step">
                            <span class="fullimage cover" role="img" aria-label="create wordpress website from scratch" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Create-your-own-WordPress-Website-from-Scratch-_-Step-by-Step-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-10">February 10, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/create-your-own-wordpress-website-from-scratch-step-by-step/">Create your own WordPress Website from Scratch : Step by Step</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5918 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-dns tag-hosting">

                    <a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/" class="thumb hover-effect" aria-label="Hostgator Hosting Review: Is Hostgator Good ?">
                            <span class="fullimage cover" role="img" aria-label="is hostgator good" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/02/Is-hostgator-good-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-02-01">February 1, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/hostgator-review-is-hostgator-good/">Hostgator Hosting Review: Is Hostgator Good ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><article class="item post-5717 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-secure tag-security tag-torrent tag-vpn">

                    <a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/" class="thumb hover-effect" aria-label="CyberGhost: Is it the best VPN for Torrenting, Streaming ?">
                            <span class="fullimage cover" role="img" aria-label="best vpn for torrenting" style="background: url('https://linuxtechlab.com/wp-content/uploads/2021/01/CyberGhost_-Is-it-the-best-VPN-for-you-your-home-___-1-120x120.png');"></span>
                    </a>
    
    <div class="info gradient-effect">
                    <time datetime="2021-01-25">January 25, 2021</time>
                <h4 class="title usmall"><a href="https://linuxtechlab.com/cyberghost-is-it-the-best-vpn-for-torrenting-streaming/">CyberGhost: Is it the best VPN for Torrenting, Streaming ?</a></h4>								
    </div>

    <div class="clear"></div>
</article><div class="clear"></div></section></div>
                        <div class="clear"></div>
        </div>
    
                                <h2 class="logo"><a href="https://linuxtechlab.com/"><img src="https://linuxtechlab.com/wp-content/uploads/2021/01/Linuxtechlab-1.png" alt="LinuxTechLab" width="" /></a></h2>
            
	            <a id="back-to-top" class="epcl-button dark"><i class="remixicon remixicon-arrow-up-line"></i></a>
    
</footer>
<!-- end: #footer -->
        <div class="clear"></div>
    </div>
    <!-- end: #wrapper --> 

    <!-- W3TC-include-css -->
    <!-- W3TC-include-js-head -->

    
<div class="wp-dark-mode-switcher wp-dark-mode-ignore style-2   floating right_bottom">

    <label for="wp-dark-mode-switch wp-dark-mode-ignore">
        <div class="toggle wp-dark-mode-ignore"></div>
        <div class="modes wp-dark-mode-ignore">
            <p class="light">Light</p>
            <p class="dark">Dark</p>
        </div>
    </label>

</div>                <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
                    ;(function () {
                        const userAgent = typeof navigator === 'undefined' ? 'some useragent' : navigator.userAgent.toLowerCase();
                        const isFirefox = userAgent.includes('firefox');

                        var isChromium = userAgent.includes('chrome') || userAgent.includes('chromium');
                        var isSafari = userAgent.includes('safari') && !isChromium;

                        const isCustomColor = parseInt('1');

                        //handle bg image excludes
                        if(!isCustomColor && isSafari) {
                            (function () {
                                const elements = document.querySelectorAll('header, footer, div, section');

                                elements.forEach((element) => {
                                    const bi = window.getComputedStyle(element, false).backgroundImage;
                                    const parallax = element.getAttribute('data-jarallax-original-styles');


                                    if (bi !== 'none' || parallax) {
                                        element.classList.add('wp-dark-mode-ignore');
                                        element.querySelectorAll('*').forEach((child) => child.classList.add('wp-dark-mode-ignore'));
                                    }
                                });
                            })();
                        }

                        //Handle excludes
                        if ('' !== ``) {
                            const elements = document.querySelectorAll(``);

                            elements.forEach((element) => {
                                element.classList.add('wp-dark-mode-ignore');
                                const children = element.querySelectorAll('*');

                                children.forEach((child) => {
                                    child.classList.add('wp-dark-mode-ignore');
                                });
                            });
                        }

                        //handle includes
                        if ('' !== ``) {
                            const elements = document.querySelectorAll(``);

                            elements.forEach((element) => {
                                element.classList.add('wp-dark-mode-include');
                                const children = element.querySelectorAll('*');

                                children.forEach((child) => {
                                    child.classList.add('wp-dark-mode-include');
                                })
                            });
                        }

                        if (isCustomColor) {
                            const is_active = document.querySelector('html').classList.contains('wp-dark-mode-active') ? 1 : 0;

                            if (is_active) {
                                window.customColor();
                            }
                        }

                        if (document.getElementById('wp_dark_mode_pre_css')) {
                            document.getElementById('wp_dark_mode_pre_css').remove();
                        }
                    })();
                </script>
			<link rel='stylesheet' id='epcl-fontawesome-css'  href='https://linuxtechlab.com/wp-content/themes/breek/assets/dist/fontawesome.min.css?ver=3.6.6' type='text/css' media='all' />
<link rel='stylesheet' id='epcl-remixicons-css'  href='https://linuxtechlab.com/wp-content/themes/breek/assets/dist/remixicons.min.css?ver=3.6.6' type='text/css' media='all' />
<script type='text/javascript' id='ta_main_js-js-extra'>
/* <![CDATA[ */
var thirsty_global_vars = {"home_url":"\/\/linuxtechlab.com","ajax_url":"https:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","link_fixer_enabled":"yes","link_prefix":"recommends","link_prefixes":{"2":"review","4":"recommends"},"post_id":"2933","enable_record_stats":"yes","enable_js_redirect":"yes","disable_thirstylink_class":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/thirstyaffiliates/js/app/ta.js?ver=3.10.2' id='ta_main_js-js'></script>
<script type='text/javascript' id='cookie-consent-js-extra'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"1","version":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/uk-cookie-consent/assets/js/uk-cookie-consent-js.js?ver=2.3.0' id='cookie-consent-js'></script>
<script type='text/javascript' id='wp-dark-mode-frontend-js-extra'>
/* <![CDATA[ */
var wpDarkMode = {"config":{"brightness":"100","contrast":"90","sepia":"10"},"enable_preset":"1","customize_colors":"","colors":{"bg":"#1B2836","text":"#fff","link":"#459BE6"},"enable_frontend":"1","enable_backend":"","enable_os_mode":"1","excludes":"","includes":"","is_excluded":"","remember_darkmode":"","default_mode":"","images":"","is_pro_active":"","is_ultimate_active":"","pro_version":"0","is_elementor_editor":"","is_block_editor":"","frontend_mode":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/wp-dark-mode//assets/js/frontend.min.js?ver=2.0.3' id='wp-dark-mode-frontend-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.lazyload.min.js?ver=3.6.6' id='lazy-load-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/aos.js?ver=3.6.6' id='aos-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/slick.min.js?ver=3.6.6' id='slick-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.nice-select.min.js?ver=3.6.6' id='nice-select-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jflickrfeed.min.js?ver=3.6.6' id='jflickrfeed-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.magnific-popup.min.js?ver=3.6.6' id='magnific-popup-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.sticky-sidebar.min.js?ver=3.6.6' id='sticky-sidebar-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/theia-sidebar.min.js?ver=3.6.6' id='theia-sidebar-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.sticky.min.js?ver=3.6.6' id='sticky-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/jquery.tooltipster.min.js?ver=3.6.6' id='tooltipster-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/pace.min.js?ver=3.6.6' id='pace-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/preload-css.min.js?ver=3.6.6' id='preload-css-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/prism.min.js?ver=3.6.6' id='prism-js'></script>
<script type='text/javascript' id='epcl-functions-js-extra'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","nonce":"977e68f225"};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/functions.js?ver=3.6.6' id='epcl-functions-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/themes/breek/assets/js/shortcodes.js?ver=3.6.6' id='epcl-shortcodes-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/comment-reply.min.js?ver=5d9d509b0c856539e18d8e916df0c9ac' id='comment-reply-js'></script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/wp-embed.min.js?ver=5d9d509b0c856539e18d8e916df0c9ac' id='wp-embed-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5d9d509b0c856539e18d8e916df0c9ac' async='async' id='remote_sdk-js'></script>
<script async="async" type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>
<script type='text/javascript' id='icegram_main_js-js-extra'>
/* <![CDATA[ */
var icegram_pre_data = {"ajax_url":"https:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","post_obj":{"is_home":false,"page_id":2933,"action":"display_messages","shortcodes":[],"cache_compatibility":"yes","device":"laptop"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://linuxtechlab.com/wp-content/plugins/icegram/assets/js/main.min.js?ver=1.10.47' id='icegram_main_js-js'></script>
			
				<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																			ctccFirstPage();
											});
				</script>
			
			<div id="catapult-cookie-bar" class=" use_x_close"><div class="ctcc-inner "><span class="ctcc-left-side">This site uses cookies to store information on your computer.  By using the site, you consent to the placement of these cookies. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://linuxtechlab.com/privacy-policy/">Find out more.</a></span><span class="ctcc-right-side"></span><div class="x_close"><span></span><span></span></div></div><!-- custom wrapper class --></div><!-- #catapult-cookie-bar -->            <script type='text/javascript' style='display:none;' async>
__ez.queue.addFile('edmonton.php', '/detroitchicago/edmonton.webp?a=a&cb=2&shcb=34', true, ['/detroitchicago/minneapolis.js'], true, false, false, false);
__ez.queue.addFile('jellyfish.php', '/porpoiseant/jellyfish.webp?a=a&cb=2&shcb=34', false, [], true, false, false, false);
</script>

<script>var _audins_dom="linuxtechlab_com",_audins_did=123629;__ez.queue.addDelayFunc("audins.js","__ez.script.add", "//go.ezoic.net/detroitchicago/audins.js?cb=194-2");</script><noscript><div style="display:none;"><img src="//pixel.quantserve.com/pixel/p-31iz6hfFutd16.gif?labels=Domain.linuxtechlab_com,DomainId.123629" border="0" height="1" width="1" alt="Quantcast"/></div></noscript>
<script type="text/javascript" data-cfasync="false"></script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"r":1,"si":10,"rayId":"637413bb8b01c189","version":"2021.3.0"}'></script>
</body>
</html>
