<!DOCTYPE html><html
class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta
charset="UTF-8"><meta
name="viewport" content="width=device-width, initial-scale=1.0"><link
rel="profile" href="https://gmpg.org/xfn/11" /><link
rel="pingback" href="https://linuxtechlab.com/xmlrpc.php"><link
type="text/css" media="all" href="https://linuxtechlab.com/wp-content/cache/autoptimize/css/autoptimize_4bd8f76e52ee728f1801dae713dce213.css" rel="stylesheet" /><title>Simple guide to configure Nginx reverse proxy with SSL - LinuxTechLab</title> <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script> <meta
name="description" content="Learn how to configure Nginx reverse proxy with SSL. A reverse proxy is a server that takes the requests made through web i.e. http &amp; https, then sends them"/><link
rel="canonical" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/" /><link
rel="publisher" href="https://plus.google.com/+linuxtechlab"/><meta
property="og:locale" content="en_US" /><meta
property="og:type" content="article" /><meta
property="og:title" content="Simple guide to configure Nginx reverse proxy with SSL - LinuxTechLab" /><meta
property="og:description" content="Learn how to configure Nginx reverse proxy with SSL. A reverse proxy is a server that takes the requests made through web i.e. http &amp; https, then sends them" /><meta
property="og:url" content="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/" /><meta
property="og:site_name" content="LinuxTechLab" /><meta
property="article:publisher" content="https://www.facebook.com/linuxtechlab/" /><meta
property="article:author" content="https://www.facebook.com/shujat.hus" /><meta
property="article:tag" content="https" /><meta
property="article:tag" content="ssl" /><meta
property="article:section" content="How To&#039;s" /><meta
property="article:published_time" content="2019-01-17T05:24:31+00:00" /><meta
property="og:image" content="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?fit=720%2C340&#038;ssl=1" /><meta
property="og:image:secure_url" content="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?fit=720%2C340&#038;ssl=1" /><meta
property="og:image:width" content="720" /><meta
property="og:image:height" content="340" /><meta
property="og:image:alt" content="Nginx reverse proxy with SSL" /><meta
name="twitter:card" content="summary" /><meta
name="twitter:description" content="Learn how to configure Nginx reverse proxy with SSL. A reverse proxy is a server that takes the requests made through web i.e. http &amp; https, then sends them" /><meta
name="twitter:title" content="Simple guide to configure Nginx reverse proxy with SSL - LinuxTechLab" /><meta
name="twitter:site" content="@LinuxTechLab" /><meta
name="twitter:image" content="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?fit=720%2C340&#038;ssl=1" /><meta
name="twitter:creator" content="@linuxtechlab" /> <script type='application/ld+json'>{"@context":"https://schema.org","@type":"Person","url":"https://linuxtechlab.com/","sameAs":["https://www.facebook.com/linuxtechlab/","https://www.linkedin.com/in/linux-techlab-9963b9138/","https://plus.google.com/+linuxtechlab","https://in.pinterest.com/techlablinux/","https://twitter.com/LinuxTechLab"],"@id":"#person","name":"Shusain"}</script> <link
rel='dns-prefetch' href='//s0.wp.com' /><link
rel='dns-prefetch' href='//s.w.org' /><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Feed" href="https://linuxtechlab.com/feed/" /><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Comments Feed" href="https://linuxtechlab.com/comments/feed/" /><link
id="hu-user-gfont" href="//fonts.googleapis.com/css?family=Titillium+Web:400,400italic,300italic,300,600&subset=latin,latin-ext" rel="stylesheet" type="text/css"><link
rel="alternate" type="application/rss+xml" title="LinuxTechLab &raquo; Simple guide to configure Nginx reverse proxy with SSL Comments Feed" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/feed/" />
 <script type="text/javascript" data-cfasync="false">var mi_version         = '7.4.1';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-66906913-3';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-66906913-3', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('set', 'anonymizeIp', true);
		__gaTracker('require', 'linkid', 'linkid.js');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}</script>  <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxtechlab.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style id='hueman-main-style-inline-css' type='text/css'>body { font-family:'Titillium Web', Arial, sans-serif;font-size:1.00rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }.boxed #wrapper, .container-inner { max-width: 1120px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1120px;
                }
              }::selection { background-color: #5f4d7a; }
::-moz-selection { background-color: #5f4d7a; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #5f4d7a; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #5f4d7a; }.post-format .format-container { border-color: #5f4d7a; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #5f4d7a!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #578093; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #578093; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #578093; }
.post-comments span:before { border-right-color: #578093; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #553b7a}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #553b7a; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #553b7a; background-color: rgba(85,59,122,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #553b7a; background-color: rgba(85,59,122,0.95) }#header { background-color: #545655; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #545655; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: ; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: ; }
}
        #footer-bottom { background-color: #565656; }.site-title a img { max-height: 100px; }img { -webkit-border-radius: 10px; border-radius: 10px; }.sidebar.expanding, .sidebar.collapsing, .sidebar .sidebar-content, .sidebar .sidebar-toggle, .container-inner > .main::before,.container-inner > .main::after { background-color: #ededed; }@media only screen and (min-width: 480px) and (max-width: 1200px) { .s2.expanded { background-color: #ededed; } }@media only screen and (min-width: 480px) and (max-width: 960px) { .s1.expanded { background-color: #ededed; } }body { background-color: #2f495e; }</style> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://linuxtechlab.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript'>var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,exe,js,pdf,ppt,tgz,zip,xls","inbound_paths":"[]","home_url":"https:\/\/linuxtechlab.com","hash_tracking":"false"};</script> <link
rel='https://api.w.org/' href='https://linuxtechlab.com/wp-json/' /><link
rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxtechlab.com/xmlrpc.php?rsd" /><link
rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxtechlab.com/wp-includes/wlwmanifest.xml" /><link
rel='shortlink' href='https://wp.me/p8pupD-1gc' /><link
rel="alternate" type="application/json+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Fsimple-guide-to-configure-nginx-reverse-proxy-with-ssl%2F" /><link
rel="alternate" type="text/xml+oembed" href="https://linuxtechlab.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxtechlab.com%2Fsimple-guide-to-configure-nginx-reverse-proxy-with-ssl%2F&#038;format=xml" /><style id="ctcc-css" type="text/css" media="screen">#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #464646;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: ;
				}
				button#catapultCookie {
					background:;
					color: ;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style><script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linuxtechlab.com/?wordfence_lh=1&hid=AA31710EECA82854DE2C47E0BFD33BBA');</script> <link
rel='dns-prefetch' href='//v0.wordpress.com'/><link
rel='dns-prefetch' href='//i0.wp.com'/><link
rel='dns-prefetch' href='//i1.wp.com'/><link
rel='dns-prefetch' href='//i2.wp.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]> <script src="https://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script> <script src="https://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script> <![endif]--><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><meta
name="onesignal" content="wordpress-plugin"/><link
rel="manifest"
href="https://linuxtechlab.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/manifest.json.php?gcm_sender_id=264261321638"/> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://linuxtechlab.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '4aa7dae9-6300-464c-a817-ed5ca97dd617';
oneSignal_options['autoRegister'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "LinuxTechLab";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing !!!";
oneSignal_options['path'] = "https://linuxtechlab.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5ccade99-0f35-4775-9ae0-5e2c3bfd110b";
oneSignal_options['persistNotification'] = false;
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Click to subscribe notifications';
oneSignal_options['notifyButton']['text']['tip.state.unsubscribed'] = 'Subscribe to notification';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You have subscribed';
oneSignal_options['notifyButton']['text']['tip.state.blocked'] = 'You have blocked notifications';
oneSignal_options['notifyButton']['text']['message.action.subscribed'] = 'Thanks for subscribing !!!';
oneSignal_options['notifyButton']['text']['message.action.resubscribed'] = 'You are subscribed !!!';
oneSignal_options['notifyButton']['text']['message.action.unsubscribed'] = 'Did we do something wrong ???';
oneSignal_options['notifyButton']['text']['dialog.main.title'] = 'Manafe site notifications';
oneSignal_options['notifyButton']['text']['dialog.main.button.subscribe'] = 'SUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.main.button.unsubscribe'] = 'UNSUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.blocked.title'] = 'Unblock Notifications';
oneSignal_options['notifyButton']['text']['dialog.blocked.message'] = 'Follow instructions  to allow notifications';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <style type="text/css">html:not( .jetpack-lazy-images-js-enabled ) .jetpack-lazy-image {
					display: none;
				}</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <link
rel="icon" href="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link
rel="icon" href="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link
rel="apple-touch-icon-precomposed" href="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=180%2C180&#038;ssl=1" /><meta
name="msapplication-TileImage" content="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=270%2C270&#038;ssl=1" /><style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
.last-updated {
    font-size: small;
    text-transform: uppercase;
    background-color: #fffdd4;
} 

.single-post-meta{
display:none;
}

body, html {
color: #000000;
}

.entry {
    color: #000000 !important;
}</style></head><body
data-rsssl=1 class="post-template-default single single-post postid-4848 single-format-standard wp-custom-logo wp-embed-responsive ctcc-exclude-OC col-2cl boxed topbar-enabled mobile-sidebar-hide-s2 header-desktop-sticky header-mobile-sticky gecko"><div
id="wrapper">
<header
id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop header-ads-mobile topbar-transparent no-header-img">
<nav
class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1"><div
class="mobile-title-logo-in-header"><p
class="site-title"><a
class="custom-logo-link" href="https://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page">LinuxTechLab</a></p></div><div
class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false"><div
class="ham__navbar-span-wrapper">
<span
class="line line-1"></span>
<span
class="line line-2"></span>
<span
class="line line-3"></span></div></div><div
class="nav-text"></div><div
class="nav-wrap container"><ul
class="nav container-inner group mobile-search"><li><form
method="get" class="searchform themeform" action="https://linuxtechlab.com/"><div>
<input
type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></li></ul><ul
id="menu-top-navigation" class="nav container-inner group"><li
id="menu-item-65" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
id="menu-item-1994" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
id="menu-item-2289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
id="menu-item-269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav>
<nav
class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2"><div
class="nav-text"></div><div
class="topbar-toggle-down">
<i
class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
<i
class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i></div><div
class="nav-wrap container"><ul
id="menu-top-navigation-1" class="nav container-inner group"><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div><div
id="topbar-header-search" class="container"><div
class="container-inner"><div
class="toggle-search"><i
class="fas fa-search"></i></div><div
class="search-expand"><div
class="search-expand-inner"><form
method="get" class="searchform themeform" action="https://linuxtechlab.com/"><div>
<input
type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></div></div></div></div>
</nav><div
class="container group"><div
class="container-inner"><div
class="group pad central-header-zone"><div
class="logo-tagline-group"><p
class="site-title"><a
class="custom-logo-link" href="https://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page">LinuxTechLab</a></p></div><div
id="header-widgets"><div
id="text-24" class="widget widget_text"><div
class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br
/>
<br
/>
<ins
class="adsbygoogle" style="display: inline-block; width: 620px; height: 90px;" data-ad-client="ca-pub-9186837757068891" data-ad-slot="7709195798"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></div>
<nav
class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3"><div
class="nav-text"></div><div
class="nav-wrap container"><ul
id="menu-top-navigation-2" class="nav container-inner group"><li
class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a
href="https://linuxtechlab.com">Home</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-10"><a
href="https://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1994"><a
href="https://linuxtechlab.com/devops/">DevOps</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a
href="https://linuxtechlab.com/scripting/">Scripting</a></li><li
class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a
href="https://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav></div></div></header><div
class="container" id="page"><div
class="container-inner"><div
class="main"><div
class="main-inner group">
<section
class="content"><div
class="page-title pad group"><ul
class="meta-single group"><li
class="category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> <span>/</span> <a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></li></ul></div><div
class="pad group"><div
class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; display: block; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div>
<article
class="post-4848 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos tag-https tag-ssl"><div
class="post-inner group"><h1 class="post-title entry-title">Simple guide to configure Nginx reverse proxy with SSL</h1><p
class="post-byline">by   <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot;
<time
class="published" datetime="January 17, 2019">January 17, 2019</time></p><div
class="clear"></div><div
class="entry themeform"><div
class="entry-inner"><p>A reverse proxy is a server that takes the requests made through web i.e. http &amp; https, then sends them to backend server (or servers). A Backend server can be a single or group of application server like Tomcat, wildfly or Jenkins etc or it can even be another web server like Apache etc.</p><p>We have already discussed how we can configure a simple http reverse proxy with Nginx. In this tutorial, we will discuss how we can configure a Nginx reverse proxy with SSL. So let’s start with the procedure to configure Nginx reverse proxy with SSL,</p><p><strong>Recommended Read : <a
href="https://linuxtechlab.com/the-incomplete-guide-to-docker-for-linux/"><span
style="color: #993300;">The (in)complete Guide To DOCKER FOR LINUX</span></a></strong></p><p><strong>Also Read : <a
href="https://linuxtechlab.com/beginners-guide-to-selinux/"><span
style="color: #993300;">Beginner’s guide to SELinux</span></a></strong></p><h3>Pre-requisites</h3><p><strong>&#8211; A backend server:</strong> For purpose of this tutorial we are using an tomcat server running on localhost at port 8080. If want to learn how to setup a apache tomcat server, please <a
href="https://linuxtechlab.com/complete-guide-apache-tomcat-installation-linux/"><span
style="color: #993300;"><strong>read this tutorial</strong></span></a>.</p><p><strong>Note:-</strong> Make sure that application server is up when you start proxying the requests.</p><p><strong>&#8211; SSL cert :</strong> We would also need an SSL certificate to configure on the server. We can use let’s encrypt certificate, you can get one using the procedure <a
href="https://linuxtechlab.com/complete-guide-to-configure-ssl-on-nginx-with-lets-encrypt-ubuntu-centos-rhel/"><span
style="color: #993300;"><strong>mentioned HERE</strong></span></a>. But for this tutorial, we will using a self signed certificates, which can be created by running the following command from terminal,</p><p><span
style="color: #333399;"><strong>$ openssl req -x509 -nodes -days 365 -newkey rsa:2048 -keyout /etc/nginx/certs/cert.key -out /etc/nginx/certs/cert.crt</strong></span></p><div
class='code-block code-block-2' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins
class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="6722035572"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p>You can also read more about self signed certificates<a
href="https://linuxtechlab.com/create-ssl-certificate-apache-server/"><span
style="color: #993300;"><strong> HERE</strong></span></a>.</p><p>Next step on configuring nginx reverse proxy with ssl will be nginx installation,</p><hr
/><h3>Install Nginx</h3><hr
/><p><strong>Ubuntu</strong></p><p>Nginx is available with default Ubuntu Repositories. So simple install it using the following command,</p><p><span
style="color: #333399;"><strong>$ sudo apt-get update &amp;&amp; sudo apt-get install nginx</strong></span></p><p><strong>CentOS/RHEL</strong></p><p>We need to add some repos for installing nginx on CentOS &amp; we have created a detailed <a
href="https://linuxtechlab.com/installing-nginx-server-configuring-virtual-hosts/"><span
style="color: #993300;"><strong>ARTICLE HERE</strong></span></a> for nginx installation on CentOS/RHEL.</p><p>Now start the services &amp; enable it for boot,</p><p><span
style="color: #333399;"><strong># systemctl start nginx</strong></span></p><p><span
style="color: #333399;"><strong># systemctl enable nginx</strong></span></p><p>Now to check the nginx installation, we can open web browser &amp; enter the system ip as url to get a default nginx webpage, which confirms that nginx is working fine.</p><hr
/><h3>Configuring Nginx reverse proxy with SSL</h3><p>Now we have all the things we need to configure nginx reverse proxy with ssl. We need to make configurations in nginx now, we will using the default nginx configuration file i.e. ‘/etc/nginx/conf.d/default.conf’.</p><div
class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <ins
class="adsbygoogle"
style="display:block; text-align:center;"
data-ad-layout="in-article"
data-ad-format="fluid"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="6722035572"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p>Assuming this is the first time we are making any changes to configuration, open the file &amp; delete or comment all the old file content, then make the following entries into the file,</p><p><span
style="color: #333399;"><strong># vi /etc/nginx/conf.d/default.conf</strong></span></p><p><strong>server {</strong></p><p><strong>listen 80;</strong></p><p><strong>return 301 https://$host$request_uri;</strong></p><p><strong>}</strong></p><p><strong>server {</strong></p><p><strong>listen 443;</strong></p><p><strong>server_name linuxtechlab.com;</strong></p><p><strong>ssl_certificate /etc/nginx/ssl/cert.crt;</strong></p><p><strong>ssl_certificate_key /etc/nginx/ssl/cert.key;</strong></p><p><strong>ssl on;</strong></p><div
class='code-block code-block-4' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>ssl_session_cache builtin:1000 shared:SSL:10m;</strong></p><p><strong>ssl_protocols TLSv1 TLSv1.1 TLSv1.2;</strong></p><p><strong>ssl_ciphers HIGH:!aNULL:!eNULL:!EXPORT:!CAMELLIA:!DES:!MD5:!PSK:!RC4;</strong></p><p><strong>ssl_prefer_server_ciphers on;</strong></p><p><strong>access_log /var/log/nginx/access.log;</strong></p><p><strong>location / {</strong></p><p><strong>proxy_set_header Host $host;</strong></p><p><strong>proxy_set_header X-Real-IP $remote_addr;</strong></p><p><strong>proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;</strong></p><p><strong>proxy_set_header X-Forwarded-Proto $scheme;</strong></p><p><strong>proxy_pass http://localhost:8080;</strong></p><p><strong>proxy_read_timeout 90;</strong></p><p><strong>proxy_redirect http://localhost:8080 https://linuxtechlab.com;</strong></p><p><strong>}</strong></p><p><strong>}</strong></p><div
class='code-block code-block-5' style='margin: 8px auto; text-align: center; display: block; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> 
<ins
class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p>Once all the changes have been made, save the file &amp; exit. Now before we restart the nginx service to implement the changes made, we will discuss the configuration that we have made , section by section,</p><p><span
style="color: #800080;"><strong>Section 1</strong></span></p><p><strong>server {</strong></p><p><strong>listen 80;</strong></p><p><strong>return 301 https://$host$request_uri;</strong></p><p><strong>}</strong></p><p>here, we have told that we are to listen to any request made to port 80 &amp; then redirect it to https,</p><p><span
style="color: #800080;"><strong>Section 2</strong></span></p><p><strong>listen 443;</strong></p><p><strong>server_name linuxtechlab.com;</strong></p><p><strong>ssl_certificate /etc/nginx/ssl/cert.crt;</strong></p><p><strong>ssl_certificate_key /etc/nginx/ssl/cert.key;</strong></p><p><strong>ssl on;</strong></p><p><strong>ssl_session_cache builtin:1000 shared:SSL:10m;</strong></p><p><strong>ssl_protocols TLSv1 TLSv1.1 TLSv1.2;</strong></p><p><strong>ssl_ciphers HIGH:!aNULL:!eNULL:!EXPORT:!CAMELLIA:!DES:!MD5:!PSK:!RC4;</strong></p><p><strong>ssl_prefer_server_ciphers on;</strong></p><p>Now these are some of the default nginx ssl options that we are using, which tells what kind of protocol version, SSL ciphers to support by nginx web server,</p><p><span
style="color: #800080;"><strong>Section 3</strong></span></p><p><strong>location / {</strong></p><p><strong>proxy_set_header Host $host;</strong></p><p><strong>proxy_set_header X-Real-IP $remote_addr;</strong></p><p><strong>proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;</strong></p><p><strong>proxy_set_header X-Forwarded-Proto $scheme;</strong></p><p><strong>proxy_pass http://localhost:8080;</strong></p><p><strong>proxy_read_timeout 90;</strong></p><p><strong>proxy_redirect http://localhost:8080 https://linuxtechlab.com;</strong></p><p><strong>}</strong></p><p><strong>}</strong></p><p>Now this section tells about proxy &amp; where the incoming requests are sent once they come in. Now that we have discussed all the configurations, we will check &amp; then restart the nginx service,</p><p>To check the nginx , run the following command,</p><p><span
style="color: #333399;"><strong># nginx -t</strong></span></p><p>Once we have configuration file as OKAY, we will restart the nginx service,</p><p><span
style="color: #333399;"><strong># systemctl restart nginx</strong></span></p><p>That’s it, our nginx reverse proxy with ssl is now ready. Now to test the setup, all you have to do is to open web browser &amp; enter the URL. We should now be redirected to the apache tomcat webpage.</p><p>This completes our tutorial on how we can configure nginx reverse proxy with ssl, please do send in any questions or queries regarding this tutorial using the comment box below.</p><div
style="padding: 1.5em; background: #E1DDDD; border: 0.125em solid #c5dbe5; border-width: 0.125em 0;"><p
style="margin-bottom: 0.75em;">If you think we have helped you or just want to support us, please consider these :-</p><p
style="margin-bottom: 0.75em;">Connect to us: <a
href="https://www.facebook.com/linuxtechlab/"><span
style="color: #ff0000;">Facebook</span></a> | <a
href="https://twitter.com/LinuxTechLab"><span
style="color: #ff0000;">Twitter</span></a> | <a
href="https://plus.google.com/+linuxtechlab"><span
style="color: #ff0000;">Google Plus</span></a></p><p>Donate us some of your hard earned money:<form
action="https://www.paypal.com/cgi-bin/webscr" method="post" target="_blank"><div
class="paypal-donations">
<input
type="hidden" name="cmd" value="_donations" />
<input
type="hidden" name="bn" value="TipsandTricks_SP" />
<input
type="hidden" name="business" value="techlablinux@gmail.com" />
<input
type="hidden" name="return" value="https://linuxtechlab.com" />
<input
type="hidden" name="rm" value="0" />
<input
type="hidden" name="currency_code" value="USD" />
<input
type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
<img
alt src="https://i1.wp.com/www.paypal.com/en_US/i/scr/pixel.gif?resize=1%2C1&#038;ssl=1" width="1" height="1" data-recalc-dims="1" data-lazy-src="https://i1.wp.com/www.paypal.com/en_US/i/scr/pixel.gif?resize=1%2C1&amp;is-pending-load=1#038;ssl=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img
alt="" src="https://i1.wp.com/www.paypal.com/en_US/i/scr/pixel.gif?resize=1%2C1&#038;ssl=1" width="1" height="1" data-recalc-dims="1" /></noscript></div></form></p><p
style="margin-bottom: 0.75em;">Linux TechLab is thankful for your continued support.</p></div><div
class="sharedaddy sd-sharing-enabled"><div
class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this post:</h3><div
class="sd-content"><ul><li
class="share-email"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span
class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li
class="share-facebook"><a
rel="nofollow noopener noreferrer" data-shared="sharing-facebook-4848" class="share-facebook sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span
class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li
class="share-linkedin"><a
rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-4848" class="share-linkedin sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span
class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li
class="share-twitter"><a
rel="nofollow noopener noreferrer" data-shared="sharing-twitter-4848" class="share-twitter sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span
class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li
class="share-google-plus-1"><a
rel="nofollow noopener noreferrer" data-shared="sharing-google-4848" class="share-google-plus-1 sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span
class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li
class="share-jetpack-whatsapp"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://api.whatsapp.com/send?text=Simple%20guide%20to%20configure%20Nginx%20reverse%20proxy%20with%20SSL%20https%3A%2F%2Flinuxtechlab.com%2Fsimple-guide-to-configure-nginx-reverse-proxy-with-ssl%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span
class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li
class="share-tumblr"><a
rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span
class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li
class="share-end"></li></ul></div></div></div>          <nav
class="pagination group">
</nav></div><div
class="clear"></div></div></div>
</article><div
class="clear"></div><p
class="post-tags"><span>Tags:</span> <a
href="https://linuxtechlab.com/tag/https/" rel="tag">https</a><a
href="https://linuxtechlab.com/tag/ssl/" rel="tag">ssl</a></p><div
class="author-bio"><div
class="bio-avatar"><img
alt src="https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&#038;d=retro&#038;r=g" class="avatar avatar-128 photo jetpack-lazy-image" height="128" width="128" data-lazy-srcset="https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=256&#038;d=retro&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&amp;is-pending-load=1#038;d=retro&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img
alt='' src='https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&#038;d=retro&#038;r=g' srcset='https://secure.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=256&#038;d=retro&#038;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></noscript></div><p
class="bio-name">Shusain</p><p
class="bio-desc">Passionate about Linux &amp; open source.
Loves to learn, read &amp; write about Linux as well as new technologies.</p><div
class="clear"></div></div><h4 class="heading">
<i
class="far fa-hand-point-right"></i>You may also like...</h4><ul
class="related-posts group"><li
class="related post-hover">
<article
class="post-4594 post type-post status-publish format-standard has-post-thumbnail hentry category-devops category-how-tos tag-apache tag-modsecurity"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/easy-way-to-integrate-apache-with-modsecurity-on-ubuntu/" title="Permalink to Easy way to integrate Apache with modsecurity on Ubuntu">
<img
width="520" height="245" src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/08/Easy-way-to-integrate-Apache-with-modsecurity-on-Ubuntu.jpg?resize=520%2C245&amp;ssl=1" class="attachment-thumb-medium size-thumb-medium wp-post-image jetpack-lazy-image" alt="Apache with modsecurity" data-lazy-srcset="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/08/Easy-way-to-integrate-Apache-with-modsecurity-on-Ubuntu.jpg?w=720&amp;ssl=1 720w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/08/Easy-way-to-integrate-Apache-with-modsecurity-on-Ubuntu.jpg?resize=520%2C245&amp;ssl=1 520w" data-lazy-sizes="(max-width: 520px) 100vw, 520px" data-lazy-src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/08/Easy-way-to-integrate-Apache-with-modsecurity-on-Ubuntu.jpg?resize=520%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/easy-way-to-integrate-apache-with-modsecurity-on-ubuntu/" rel="bookmark" title="Permalink to Easy way to integrate Apache with modsecurity on Ubuntu">Easy way to integrate Apache with modsecurity on Ubuntu</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2018-08-24 10:38:51">August 24, 2018</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">August 24, 2018</span></p></div></div></article></li><li
class="related post-hover">
<article
class="post-1948 post type-post status-publish format-standard has-post-thumbnail hentry category-how-tos category-tips-tricks tag-apache tag-varnish tag-webserver"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/install-varnish-apache-web-server/" title="Permalink to Install Varnish Cache for Apache Web Server to Speed up Website">
<img
width="520" height="245" src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/install-varnish.jpg?resize=520%2C245&amp;ssl=1" class="attachment-thumb-medium size-thumb-medium wp-post-image jetpack-lazy-image" alt="install varnish" data-lazy-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/install-varnish.jpg?w=720&amp;ssl=1 720w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/install-varnish.jpg?resize=520%2C245&amp;ssl=1 520w" data-lazy-sizes="(max-width: 520px) 100vw, 520px" data-lazy-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/install-varnish.jpg?resize=520%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/install-varnish-apache-web-server/" rel="bookmark" title="Permalink to Install Varnish Cache for Apache Web Server to Speed up Website">Install Varnish Cache for Apache Web Server to Speed up Website</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2018-08-28 15:06:10">August 28, 2018</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">August 28, 2018</span></p></div></div></article></li><li
class="related post-hover">
<article
class="post-632 post type-post status-publish format-standard has-post-thumbnail hentry category-how-tos category-tips-tricks tag-centos tag-disk-partition tag-linux-commands tag-lvm"><div
class="post-thumbnail">
<a
href="https://linuxtechlab.com/beginners-guide-resizing-lvm/" title="Permalink to Resizing LVM made easy : A Beginner&#8217;s Guide">
<img
width="520" height="245" src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Resizing-LVM.jpg?resize=520%2C245&amp;ssl=1" class="attachment-thumb-medium size-thumb-medium wp-post-image jetpack-lazy-image" alt="resizing LVM" data-lazy-srcset="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Resizing-LVM.jpg?w=720&amp;ssl=1 720w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Resizing-LVM.jpg?resize=300%2C142&amp;ssl=1 300w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Resizing-LVM.jpg?resize=520%2C245&amp;ssl=1 520w" data-lazy-sizes="(max-width: 520px) 100vw, 520px" data-lazy-src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Resizing-LVM.jpg?resize=520%2C245&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																			</a></div><div
class="related-inner"><h4 class="post-title entry-title">
<a
href="https://linuxtechlab.com/beginners-guide-resizing-lvm/" rel="bookmark" title="Permalink to Resizing LVM made easy : A Beginner&#8217;s Guide">Resizing LVM made easy : A Beginner&#8217;s Guide</a></h4><div
class="post-meta group"><p
class="post-date">
<time
class="published updated" datetime="2017-02-27 18:53:04">February 27, 2017</time></p><p
class="post-byline" style="display:none">&nbsp;by    <span
class="vcard author">
<span
class="fn"><a
href="https://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span>
</span> &middot; Published <span
class="published">February 27, 2017</span>
&middot; Last modified <span
class="updated">June 5, 2018</span></p></div></div></article></li></ul><section
id="comments" class="themeform"><div
id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a
rel="nofollow" id="cancel-comment-reply-link" href="/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/#respond" style="display:none;">Cancel reply</a></small></h3><form
action="https://linuxtechlab.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p
class="comment-notes"><span
id="email-notes">Your email address will not be published.</span> Required fields are marked <span
class="required">*</span></p><p
class="comment-form-comment"><label
for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p
class="comment-form-author"><label
for="author">Name <span
class="required">*</span></label> <input
id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p><p
class="comment-form-email"><label
for="email">Email <span
class="required">*</span></label> <input
id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p><p
class="comment-form-url"><label
for="url">Website</label> <input
id="url" name="url" type="text" value="" size="30" maxlength="200" /></p><p
class="comment-subscription-form"><input
type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label
class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p
class="comment-subscription-form"><input
type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label
class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p
class="form-submit"><input
name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input
type='hidden' name='comment_post_ID' value='4848' id='comment_post_ID' />
<input
type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p
style="display: none;"><input
type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0ba5220f93" /></p><p
style="display: none;"><input
type="hidden" id="ak_js" name="ak_js" value="184"/></p></form></div>
</section></div>
</section><div
class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1"><a
class="sidebar-toggle" title="Expand Sidebar"><i
class="fas icon-sidebar-toggle"></i></a><div
class="sidebar-content"><div
class="sidebar-top group"><p>Follow:</p><ul
class="social-links"><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#0ea4d1;font-size:20px"><i
class="fab fa-facebook"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-twitter"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" aria-label="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-google-plus"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" aria-label="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-linkedin"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fas fa-rss"></i></a></li></ul></div><ul
class="post-nav group"><li
class="next"></li><li
class="previous"><a
href="https://linuxtechlab.com/nc-command-ncat-for-beginners/" rel="prev"><i
class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>NC command (NCAT) for beginners</span></a></li></ul><div
id="search-2" class="widget widget_search"><h3 class="widget-title">Search Bar</h3><form
method="get" class="searchform themeform" action="https://linuxtechlab.com/"><div>
<input
type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></div><div
id="text-20" class="widget widget_text"><h3 class="widget-title">Facebook Fan Page</h3><div
class="textwidget"><div
class="fb-page" data-href="https://www.facebook.com/linuxtechlab/" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote
cite="https://www.facebook.com/linuxtechlab/" class="fb-xfbml-parse-ignore"><p><a
href="https://www.facebook.com/linuxtechlab/">Linuxtechlab</a></p></blockquote></div></div></div><div
id="text-7" class="widget widget_text"><div
class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br
/>
<br
/>
<ins
class="adsbygoogle" style="display: inline-block; width: 300px; height: 1050px;" data-ad-client="ca-pub-9186837757068891" data-ad-slot="2501356018"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div
id="alxtabs-5" class="widget widget_hu_tabs"><h3 class="widget-title"></h3><ul
class="alx-tabs-nav group tab-count-3"><li
class="alx-tab tab-recent"><a
href="#tab-recent-5" title="Recent Posts"><i
class="far fa-clock"></i><span>Recent Posts</span></a></li><li
class="alx-tab tab-popular"><a
href="#tab-popular-5" title="Popular Posts"><i
class="fas fa-star"></i><span>Popular Posts</span></a></li><li
class="alx-tab tab-tags"><a
href="#tab-tags-5" title="Tags"><i
class="fas fa-tags"></i><span>Tags</span></a></li></ul><div
class="alx-tabs-container"><ul
id="tab-recent-5" class="alx-tab group thumbs-enabled"><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/" title="Permalink to Simple guide to configure Nginx reverse proxy with SSL">
<img
width="160" height="160" src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="Nginx reverse proxy with SSL" data-lazy-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?resize=160%2C160&amp;ssl=1 160w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?resize=320%2C320&amp;ssl=1 320w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/Simple-guide-to-configure-Nginx-reverse-proxy-with-SSL.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> / <a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/" rel="bookmark" title="Permalink to Simple guide to configure Nginx reverse proxy with SSL">Simple guide to configure Nginx reverse proxy with SSL</a></p><p
class="tab-item-date">17 Jan, 2019</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/nc-command-ncat-for-beginners/" title="Permalink to NC command (NCAT) for beginners">
<img
width="160" height="160" src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="nc command" data-lazy-srcset="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?resize=160%2C160&amp;ssl=1 160w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?resize=320%2C320&amp;ssl=1 320w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2019/01/NC-command-for-.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/nc-command-ncat-for-beginners/" rel="bookmark" title="Permalink to NC command (NCAT) for beginners">NC command (NCAT) for beginners</a></p><p
class="tab-item-date">15 Jan, 2019</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/executing-commands-scripts-at-reboot/" title="Permalink to Executing Commands and Scripts at Reboot &#038; Startup in Linux">
<img
width="160" height="160" src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="scripts at reboot" data-lazy-srcset="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?resize=160%2C160&amp;ssl=1 160w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?resize=320%2C320&amp;ssl=1 320w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Executing-Commands-and-Scripts-at-RebootStartup-in-Linux.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> / <a
href="https://linuxtechlab.com/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/executing-commands-scripts-at-reboot/" rel="bookmark" title="Permalink to Executing Commands and Scripts at Reboot &#038; Startup in Linux">Executing Commands and Scripts at Reboot &#038; Startup in Linux</a></p><p
class="tab-item-date">3 Jan, 2019</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/trying-to-beta-test-your-new-app-consider-these-helpful-tips-for-success/" title="Permalink to Trying to Beta Test Your New App? Consider These Helpful Tips For Success">
<img
width="160" height="160" src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="" data-lazy-srcset="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?resize=160%2C160&amp;ssl=1 160w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?resize=320%2C320&amp;ssl=1 320w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2018/12/Trying-to-Beta-Test-Your-New-App-Consider-These-Helpful-Tips-For-Success.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/trying-to-beta-test-your-new-app-consider-these-helpful-tips-for-success/" rel="bookmark" title="Permalink to Trying to Beta Test Your New App? Consider These Helpful Tips For Success">Trying to Beta Test Your New App? Consider These Helpful Tips For Success</a></p><p
class="tab-item-date">31 Dec, 2018</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/create-manage-docker-hosts-with-docker-machine/" title="Permalink to Create &#038; manage docker hosts with Docker Machine on VirtualBox">
<img
width="160" height="160" src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="manage docker hosts with Docker Machine" data-lazy-srcset="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?resize=160%2C160&amp;ssl=1 160w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?resize=320%2C320&amp;ssl=1 320w, https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/manage-docker-hosts-with-docker-machine.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> / <a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/create-manage-docker-hosts-with-docker-machine/" rel="bookmark" title="Permalink to Create &#038; manage docker hosts with Docker Machine on VirtualBox">Create &#038; manage docker hosts with Docker Machine on VirtualBox</a></p><p
class="tab-item-date">27 Dec, 2018</p></div></li></ul><ul
id="tab-popular-5" class="alx-tab group thumbs-enabled"><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/openldap-complete-guide-install-configure-ldap-centos-rhel/" title="Permalink to OpenLDAP: Complete guide to install &#038; configure LDAP on CentOS/RHEL">
<img
width="160" height="160" src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="configure ldap" data-lazy-srcset="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?resize=160%2C160&amp;ssl=1 160w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?resize=320%2C320&amp;ssl=1 320w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/openldap-instalaltion.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/openldap-complete-guide-install-configure-ldap-centos-rhel/" rel="bookmark" title="Permalink to OpenLDAP: Complete guide to install &#038; configure LDAP on CentOS/RHEL">OpenLDAP: Complete guide to install &#038; configure LDAP on CentOS/RHEL</a></p><p
class="tab-item-date">30 Nov, 2017</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/adding-windows-host-to-nagios/" title="Permalink to Nagios Server : Adding Windows host to Nagios server for monitoring">
<img
width="160" height="160" src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="Windows host to Nagios" data-lazy-srcset="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?resize=160%2C160&amp;ssl=1 160w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?resize=320%2C320&amp;ssl=1 320w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Nagios-Server-Adding-Windows-host-for-monitorig-in-Nagios-server.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/devops/" rel="category tag">DevOps</a> / <a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/adding-windows-host-to-nagios/" rel="bookmark" title="Permalink to Nagios Server : Adding Windows host to Nagios server for monitoring">Nagios Server : Adding Windows host to Nagios server for monitoring</a></p><p
class="tab-item-date">13 Feb, 2017</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/setting-mail-server-postfix-dovecot-squirrelmail/" title="Permalink to Complete guide for setting up a mail server using Postfix, Dovecot &#038; SquirrelMail">
<img
width="160" height="160" src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="postfix" data-lazy-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?resize=160%2C160&amp;ssl=1 160w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?resize=320%2C320&amp;ssl=1 320w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/Mail-server.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/setting-mail-server-postfix-dovecot-squirrelmail/" rel="bookmark" title="Permalink to Complete guide for setting up a mail server using Postfix, Dovecot &#038; SquirrelMail">Complete guide for setting up a mail server using Postfix, Dovecot &#038; SquirrelMail</a></p><p
class="tab-item-date">18 Mar, 2017</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/install-firefox-quantum-linux/" title="Permalink to How to install Firefox Quantum on Linux">
<img
width="160" height="160" src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="install firefox quantum" data-lazy-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?resize=160%2C160&amp;ssl=1 160w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?resize=320%2C320&amp;ssl=1 320w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/11/firefox-qunatum.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/how-tos/" rel="category tag">How To's</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/install-firefox-quantum-linux/" rel="bookmark" title="Permalink to How to install Firefox Quantum on Linux">How to install Firefox Quantum on Linux</a></p><p
class="tab-item-date">15 Nov, 2017</p></div></li><li><div
class="tab-item-thumbnail">
<a
href="https://linuxtechlab.com/playing-date-time-rhelcentos/" title="Permalink to Playing with Date &#038; Time in RHEL/CentOS">
<img
width="160" height="160" src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?resize=160%2C160&amp;ssl=1" class="attachment-thumb-small size-thumb-small wp-post-image jetpack-lazy-image" alt="date &amp; time" data-lazy-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?resize=300%2C300&amp;ssl=1 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?resize=160%2C160&amp;ssl=1 160w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?resize=320%2C320&amp;ssl=1 320w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?zoom=3&amp;resize=160%2C160&amp;ssl=1 480w" data-lazy-sizes="(max-width: 160px) 100vw, 160px" data-lazy-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?resize=160%2C160&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />																											</a></div><div
class="tab-item-inner group"><p
class="tab-item-category"><a
href="https://linuxtechlab.com/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></p><p
class="tab-item-title"><a
href="https://linuxtechlab.com/playing-date-time-rhelcentos/" rel="bookmark" title="Permalink to Playing with Date &#038; Time in RHEL/CentOS">Playing with Date &#038; Time in RHEL/CentOS</a></p><p
class="tab-item-date">7 Dec, 2017</p></div></li></ul><ul
id="tab-tags-5" class="alx-tab group"><li>
<a
href="https://linuxtechlab.com/tag/apache/" class="tag-cloud-link tag-link-48 tag-link-position-1" style="font-size: 16.11214953271pt;" aria-label="apache (20 items)">apache</a>
<a
href="https://linuxtechlab.com/tag/automation/" class="tag-cloud-link tag-link-100 tag-link-position-2" style="font-size: 9.9626168224299pt;" aria-label="automation (6 items)">automation</a>
<a
href="https://linuxtechlab.com/tag/bash/" class="tag-cloud-link tag-link-22 tag-link-position-3" style="font-size: 16.635514018692pt;" aria-label="bash (22 items)">bash</a>
<a
href="https://linuxtechlab.com/tag/bash-scripting/" class="tag-cloud-link tag-link-21 tag-link-position-4" style="font-size: 14.542056074766pt;" aria-label="bash scripting (15 items)">bash scripting</a>
<a
href="https://linuxtechlab.com/tag/centos/" class="tag-cloud-link tag-link-24 tag-link-position-5" style="font-size: 21.345794392523pt;" aria-label="centos (52 items)">centos</a>
<a
href="https://linuxtechlab.com/tag/commands/" class="tag-cloud-link tag-link-183 tag-link-position-6" style="font-size: 13.364485981308pt;" aria-label="commands (12 items)">commands</a>
<a
href="https://linuxtechlab.com/tag/database/" class="tag-cloud-link tag-link-72 tag-link-position-7" style="font-size: 12.971962616822pt;" aria-label="database (11 items)">database</a>
<a
href="https://linuxtechlab.com/tag/devops/" class="tag-cloud-link tag-link-101 tag-link-position-8" style="font-size: 14.542056074766pt;" aria-label="devops (15 items)">devops</a>
<a
href="https://linuxtechlab.com/tag/docker/" class="tag-cloud-link tag-link-96 tag-link-position-9" style="font-size: 10.616822429907pt;" aria-label="Docker (7 items)">Docker</a>
<a
href="https://linuxtechlab.com/tag/file-sharing/" class="tag-cloud-link tag-link-9 tag-link-position-10" style="font-size: 9.9626168224299pt;" aria-label="file sharing (6 items)">file sharing</a>
<a
href="https://linuxtechlab.com/tag/git/" class="tag-cloud-link tag-link-107 tag-link-position-11" style="font-size: 12.448598130841pt;" aria-label="git (10 items)">git</a>
<a
href="https://linuxtechlab.com/tag/http/" class="tag-cloud-link tag-link-47 tag-link-position-12" style="font-size: 11.271028037383pt;" aria-label="http (8 items)">http</a>
<a
href="https://linuxtechlab.com/tag/httpd/" class="tag-cloud-link tag-link-62 tag-link-position-13" style="font-size: 12.971962616822pt;" aria-label="httpd (11 items)">httpd</a>
<a
href="https://linuxtechlab.com/tag/https/" class="tag-cloud-link tag-link-63 tag-link-position-14" style="font-size: 9.9626168224299pt;" aria-label="https (6 items)">https</a>
<a
href="https://linuxtechlab.com/tag/java/" class="tag-cloud-link tag-link-90 tag-link-position-15" style="font-size: 9.0467289719626pt;" aria-label="java (5 items)">java</a>
<a
href="https://linuxtechlab.com/tag/jenkins/" class="tag-cloud-link tag-link-131 tag-link-position-16" style="font-size: 9.0467289719626pt;" aria-label="jenkins (5 items)">jenkins</a>
<a
href="https://linuxtechlab.com/tag/lamp/" class="tag-cloud-link tag-link-42 tag-link-position-17" style="font-size: 9.9626168224299pt;" aria-label="LAMP (6 items)">LAMP</a>
<a
href="https://linuxtechlab.com/tag/lamp-server/" class="tag-cloud-link tag-link-43 tag-link-position-18" style="font-size: 8pt;" aria-label="LAMP server (4 items)">LAMP server</a>
<a
href="https://linuxtechlab.com/tag/linux/" class="tag-cloud-link tag-link-35 tag-link-position-19" style="font-size: 11.271028037383pt;" aria-label="linux (8 items)">linux</a>
<a
href="https://linuxtechlab.com/tag/linux-commands/" class="tag-cloud-link tag-link-29 tag-link-position-20" style="font-size: 22pt;" aria-label="linux commands (58 items)">linux commands</a>
<a
href="https://linuxtechlab.com/tag/log-monitoring/" class="tag-cloud-link tag-link-98 tag-link-position-21" style="font-size: 12.448598130841pt;" aria-label="log monitoring (10 items)">log monitoring</a>
<a
href="https://linuxtechlab.com/tag/logs/" class="tag-cloud-link tag-link-97 tag-link-position-22" style="font-size: 9.9626168224299pt;" aria-label="logs (6 items)">logs</a>
<a
href="https://linuxtechlab.com/tag/mariadb/" class="tag-cloud-link tag-link-73 tag-link-position-23" style="font-size: 9.0467289719626pt;" aria-label="mariadb (5 items)">mariadb</a>
<a
href="https://linuxtechlab.com/tag/monitoring/" class="tag-cloud-link tag-link-36 tag-link-position-24" style="font-size: 14.280373831776pt;" aria-label="monitoring (14 items)">monitoring</a>
<a
href="https://linuxtechlab.com/tag/mysql/" class="tag-cloud-link tag-link-80 tag-link-position-25" style="font-size: 9.0467289719626pt;" aria-label="mysql (5 items)">mysql</a>
<a
href="https://linuxtechlab.com/tag/nagios/" class="tag-cloud-link tag-link-33 tag-link-position-26" style="font-size: 9.0467289719626pt;" aria-label="nagios (5 items)">nagios</a>
<a
href="https://linuxtechlab.com/tag/nagios-server/" class="tag-cloud-link tag-link-34 tag-link-position-27" style="font-size: 9.0467289719626pt;" aria-label="nagios server (5 items)">nagios server</a>
<a
href="https://linuxtechlab.com/tag/network/" class="tag-cloud-link tag-link-61 tag-link-position-28" style="font-size: 12.971962616822pt;" aria-label="network (11 items)">network</a>
<a
href="https://linuxtechlab.com/tag/nginx/" class="tag-cloud-link tag-link-87 tag-link-position-29" style="font-size: 8pt;" aria-label="nginx (4 items)">nginx</a>
<a
href="https://linuxtechlab.com/tag/php/" class="tag-cloud-link tag-link-89 tag-link-position-30" style="font-size: 8pt;" aria-label="php (4 items)">php</a>
<a
href="https://linuxtechlab.com/tag/proxy/" class="tag-cloud-link tag-link-15 tag-link-position-31" style="font-size: 9.0467289719626pt;" aria-label="proxy (5 items)">proxy</a>
<a
href="https://linuxtechlab.com/tag/proxy-server/" class="tag-cloud-link tag-link-14 tag-link-position-32" style="font-size: 9.0467289719626pt;" aria-label="proxy server (5 items)">proxy server</a>
<a
href="https://linuxtechlab.com/tag/redhat/" class="tag-cloud-link tag-link-25 tag-link-position-33" style="font-size: 19.644859813084pt;" aria-label="redhat (38 items)">redhat</a>
<a
href="https://linuxtechlab.com/tag/rhel/" class="tag-cloud-link tag-link-26 tag-link-position-34" style="font-size: 21.345794392523pt;" aria-label="RHEL (52 items)">RHEL</a>
<a
href="https://linuxtechlab.com/tag/root/" class="tag-cloud-link tag-link-27 tag-link-position-35" style="font-size: 8pt;" aria-label="root (4 items)">root</a>
<a
href="https://linuxtechlab.com/tag/scripting/" class="tag-cloud-link tag-link-20 tag-link-position-36" style="font-size: 13.88785046729pt;" aria-label="scripting (13 items)">scripting</a>
<a
href="https://linuxtechlab.com/tag/squid/" class="tag-cloud-link tag-link-11 tag-link-position-37" style="font-size: 11.271028037383pt;" aria-label="squid (8 items)">squid</a>
<a
href="https://linuxtechlab.com/tag/squid-proxy-server/" class="tag-cloud-link tag-link-13 tag-link-position-38" style="font-size: 10.616822429907pt;" aria-label="squid proxy server (7 items)">squid proxy server</a>
<a
href="https://linuxtechlab.com/tag/ssh/" class="tag-cloud-link tag-link-37 tag-link-position-39" style="font-size: 9.0467289719626pt;" aria-label="ssh (5 items)">ssh</a>
<a
href="https://linuxtechlab.com/tag/system-administrator/" class="tag-cloud-link tag-link-30 tag-link-position-40" style="font-size: 21.214953271028pt;" aria-label="system administrator (50 items)">system administrator</a>
<a
href="https://linuxtechlab.com/tag/ubuntu/" class="tag-cloud-link tag-link-94 tag-link-position-41" style="font-size: 14.934579439252pt;" aria-label="ubuntu (16 items)">ubuntu</a>
<a
href="https://linuxtechlab.com/tag/virtualization/" class="tag-cloud-link tag-link-67 tag-link-position-42" style="font-size: 10.616822429907pt;" aria-label="virtualization (7 items)">virtualization</a>
<a
href="https://linuxtechlab.com/tag/web-server/" class="tag-cloud-link tag-link-64 tag-link-position-43" style="font-size: 9.9626168224299pt;" aria-label="web server (6 items)">web server</a>
<a
href="https://linuxtechlab.com/tag/webserver/" class="tag-cloud-link tag-link-146 tag-link-position-44" style="font-size: 8pt;" aria-label="webserver (4 items)">webserver</a>
<a
href="https://linuxtechlab.com/tag/yum/" class="tag-cloud-link tag-link-44 tag-link-position-45" style="font-size: 9.9626168224299pt;" aria-label="yum (6 items)">yum</a></li></ul></div></div></div></div></div></div></div></div>
<footer
id="footer"><section
class="container" id="footer-full-width-widget"><div
class="container-inner"><div
id="text-19" class="widget widget_text"><div
class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br
/>
<br
/>
<ins
class="adsbygoogle" style="display: inline-block; width: 620px; height: 90px;" data-ad-client="ca-pub-9186837757068891" data-ad-slot="7709195798"></ins><br
/> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div>
</section>
<nav
class="nav-container group" id="nav-footer" data-menu-id="footer-4" data-menu-scrollable="false"><div
class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false"><div
class="ham__navbar-span-wrapper">
<span
class="line line-1"></span>
<span
class="line line-2"></span>
<span
class="line line-3"></span></div></div><div
class="nav-text"></div><div
class="nav-wrap"><ul
id="menu-footer-menu" class="nav container group"><li
id="menu-item-4389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4389"><a
href="https://linuxtechlab.com/privacy-policy/">Privacy Policy</a></li><li
id="menu-item-4390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4390"><a
href="https://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li
id="menu-item-4391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4391"><a
href="https://linuxtechlab.com/contact-us-2/">Contact us/ Donate us</a></li></ul></div>
</nav>
<section
class="container" id="footer-bottom"><div
class="container-inner"><a
id="back-to-top" href="#"><i
class="fas fa-angle-up"></i></a><div
class="pad group"><div
class="grid one-half"><div
id="copyright"><p>LinuxTechLab &copy; 2019. All Rights Reserved.</p></div></div><div
class="grid one-half last"><ul
class="social-links"><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#0ea4d1;font-size:20px"><i
class="fab fa-facebook"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-twitter"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" aria-label="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-google-plus"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" aria-label="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fab fa-linkedin"></i></a></li><li><a
rel="nofollow" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#10bfcf;font-size:20px"><i
class="fas fa-rss"></i></a></li></ul></div></div></div>
</section></footer></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"https:\/\/linuxtechlab.com\/simple-guide-to-configure-nginx-reverse-proxy-with-ssl\/":4848};</script> <div
id="sharing_email" style="display: none;"><form
action="/simple-guide-to-configure-nginx-reverse-proxy-with-ssl/" method="post">
<label
for="target_email">Send to Email Address</label>
<input
type="email" name="target_email" id="target_email" value="" />
<label
for="source_name">Your Name</label>
<input
type="text" name="source_name" id="source_name" value="" /><label
for="source_email">Your Email Address</label>
<input
type="email" name="source_email" id="source_email" value="" /><input
type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
<img
style="float: right; display: none" class="loading" src="https://linuxtechlab.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
<input
type="submit" value="Send Email" class="sharing_send" />
<a
rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a><div
class="errors errors-1" style="display: none;">
Post was not sent - check your email addresses!</div><div
class="errors errors-2" style="display: none;">
Email check failed, please try again</div><div
class="errors errors-3" style="display: none;">
Sorry, your blog cannot share posts by email.</div></form></div> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript'>var ctcc_vars = {"expiry":"30","method":"1","version":"1"};</script> <script type='text/javascript'>var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"1","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/linuxtechlab.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"3ea855213e"},"userStarted":{"with":"before|3.3.4","on":{"date":"2017-05-19 02:16:15.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"},"fitTextMap":{"single_post_title":{"selectors":".single h1.entry-title","minEm":1.375,"maxEm":2.62000000000000010658141036401502788066864013671875},"page_title":{"selectors":".page-title h1","minEm":1,"maxEm":1.3000000000000000444089209850062616169452667236328125},"home_page_title":{"selectors":".home .page-title","minEm":1,"maxEm":1.1999999999999999555910790149937383830547332763671875,"compression":2.5},"post_titles":{"selectors":".blog .post-title, .archive .post-title","minEm":1.375,"maxEm":1.475000000000000088817841970012523233890533447265625},"featured_post_titles":{"selectors":".featured .post-title","minEm":1.375,"maxEm":2.125},"comments":{"selectors":".commentlist li","minEm":0.8125,"maxEm":0.93000000000000004884981308350688777863979339599609375,"compression":2.5},"entry":{"selectors":".entry","minEm":0.9375,"maxEm":1.125,"compression":2.5},"content_h1":{"selectors":".entry h1, .woocommerce div.product h1.product_title","minEm":1.7578125,"maxEm":2.671875},"content_h2":{"selectors":".entry h2","minEm":1.5234375,"maxEm":2.390625},"content_h3":{"selectors":".entry h3","minEm":1.40625,"maxEm":1.96875},"content_h4":{"selectors":".entry h4","minEm":1.2890625,"maxEm":1.6875},"content_h5":{"selectors":".entry h5","minEm":1.0546875,"maxEm":1.40625},"content_h6":{"selectors":".entry h6","minEm":0.9375,"maxEm":1.265625,"compression":2.5}},"userFontSize":"16","fitTextCompression":"1.5"};</script> <script type='text/javascript'>var rm_pre_data = {"ajax_url":"https:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","rm_nonce_field":"21e62bac3f"};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <!--[if lt IE 9]> <script src="https://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script> <![endif]--> <script type='text/javascript' src='https://stats.wp.com/e-201903.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.9',blog:'124285797',post:'4848',tz:'5.5',srv:'linuxtechlab.com'} ]);
	_stq.push([ 'clickTrackerInit', '124285797', '4848' ]);</script> <script type="text/javascript">jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																			ctccFirstPage();
											});</script> <div
id="catapult-cookie-bar" class=" use_x_close"><div
class="ctcc-inner "><span
class="ctcc-left-side">This site uses cookies to store information on your computer.  By using the site, you consent to the placement of these cookies. <a
class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://linuxtechlab.com/privacy-policy/">Find out more.</a></span><span
class="ctcc-right-side"></span><div
class="x_close"><span></span><span></span></div></div></div><script type="text/javascript" defer src="https://linuxtechlab.com/wp-content/cache/autoptimize/js/autoptimize_f55078035588b2ee559724a82608049e.js"></script></body></html>