<!DOCTYPE html><html class="no-js" lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><script src="/cdn-cgi/apps/head/0IgBzvyLrhKdADprLcm3MAK_O7E.js"></script><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="http://linuxtechlab.com/xmlrpc.php"><link type="text/css" media="all" href="http://linuxtechlab.com/wp-content/cache/autoptimize/css/autoptimize_d873ed0f8d4a006faa24c0092893b59d.css" rel="stylesheet" /><title>Playing with Date &amp; Time in RHEL/CentOS - LinuxTechLab</title> <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script> <meta name="description" content="In this Beginner&#039;s friendly tutorial, we are going to discuss 3 commands using which we review/modify date &amp; time on our Linux system."/><link rel="canonical" href="http://linuxtechlab.com/playing-date-time-rhelcentos/" /><link rel="publisher" href="https://plus.google.com/+linuxtechlab"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Playing with Date &amp; Time in RHEL/CentOS - LinuxTechLab" /><meta property="og:description" content="In this Beginner&#039;s friendly tutorial, we are going to discuss 3 commands using which we review/modify date &amp; time on our Linux system." /><meta property="og:url" content="http://linuxtechlab.com/playing-date-time-rhelcentos/" /><meta property="og:site_name" content="LinuxTechLab" /><meta property="article:publisher" content="https://www.facebook.com/linuxtechlab/" /><meta property="article:author" content="https://www.facebook.com/shujat.hus" /><meta property="article:tag" content="centos" /><meta property="article:tag" content="date" /><meta property="article:tag" content="linux commands" /><meta property="article:tag" content="redhat" /><meta property="article:tag" content="RHEL" /><meta property="article:tag" content="system administrator" /><meta property="article:tag" content="time" /><meta property="article:section" content="Tips &amp; Tricks" /><meta property="article:published_time" content="2017-12-07T08:42:47+05:30" /><meta property="article:modified_time" content="2017-12-07T08:40:44+05:30" /><meta property="og:updated_time" content="2017-12-07T08:40:44+05:30" /><meta property="og:image" content="http://linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg" /><meta property="og:image:width" content="720" /><meta property="og:image:height" content="340" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="In this Beginner&#039;s friendly tutorial, we are going to discuss 3 commands using which we review/modify date &amp; time on our Linux system." /><meta name="twitter:title" content="Playing with Date &amp; Time in RHEL/CentOS - LinuxTechLab" /><meta name="twitter:site" content="@LinuxTechLab" /><meta name="twitter:image" content="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/03/date-time.jpg?fit=720%2C340" /><meta name="twitter:creator" content="@LinuxTechLab" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/linuxtechlab.com\/","name":"Linux Techlab","potentialAction":{"@type":"SearchAction","target":"http:\/\/linuxtechlab.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Person","url":"http:\/\/linuxtechlab.com\/playing-date-time-rhelcentos\/","sameAs":["https:\/\/www.facebook.com\/linuxtechlab\/","https:\/\/www.linkedin.com\/in\/linux-techlab-9963b9138\/","https:\/\/plus.google.com\/+linuxtechlab","https:\/\/in.pinterest.com\/techlablinux\/","https:\/\/twitter.com\/LinuxTechLab"],"@id":"#person","name":"dan"}</script> <link rel='dns-prefetch' href='//s0.wp.com' /><link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' /><link rel='dns-prefetch' href='//s.w.org' /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/linuxtechlab.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style id='hueman-main-style-inline-css' type='text/css'>body { font-size:1.00rem; }@media only screen and (min-width: 720px) {
        .nav > li { font-size:1.00rem; }
      }.boxed #wrapper, .container-inner { max-width: 1120px; }@media only screen and (min-width: 720px) {
                .boxed .desktop-sticky {
                  width: 1120px;
                }
              }::selection { background-color: #67597a; }
::-moz-selection { background-color: #67597a; }a,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #67597a; }.themeform input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #67597a; }.post-format .format-container { border-color: #67597a; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #67597a!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #6e8894; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #6e8894; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #6e8894; }
.post-comments span:before { border-right-color: #6e8894; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #67597a}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #67597a; }
              }.is-scrolled #header .nav-container.desktop-sticky,
              .is-scrolled #header .search-expand { background-color: #67597a; background-color: rgba(103,89,122,0.90) }.is-scrolled .topbar-transparent #nav-topbar.desktop-sticky .nav ul { background-color: #67597a; background-color: rgba(103,89,122,0.95) }#header { background-color: #7c8483; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #7c8483; }
}
        #header #nav-mobile { background-color: #33363b; }.is-scrolled #header #nav-mobile { background-color: #33363b; background-color: rgba(51,54,59,0.90) }#nav-header.nav-container, #main-header-search .search-expand { background-color: ; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: ; }
}
        #footer-bottom { background-color: #565656; }img { -webkit-border-radius: 10px; border-radius: 10px; }body { background-color: #34495e; }</style><style id='jetpack_facebook_likebox-inline-css' type='text/css'>.widget_facebook_likebox {
	overflow: hidden;
}</style><link rel='stylesheet' id='font-awesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css' type='text/css' media='all' /> <script type='text/javascript' src='http://linuxtechlab.com/wp-includes/js/jquery/jquery.js'></script> <link rel='https://api.w.org/' href='http://linuxtechlab.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://linuxtechlab.com/xmlrpc.php?rsd" /><link rel="alternate" type="application/json+oembed" href="http://linuxtechlab.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F" /><link rel="alternate" type="text/xml+oembed" href="http://linuxtechlab.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F&#038;format=xml" /> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//linuxtechlab.com/?wordfence_lh=1&hid=8C8AE40C78A836808CC94A944DCC06D3');</script> <link rel='dns-prefetch' href='//v0.wordpress.com'/><link rel='dns-prefetch' href='//jetpack.wordpress.com'/><link rel='dns-prefetch' href='//s0.wp.com'/><link rel='dns-prefetch' href='//s1.wp.com'/><link rel='dns-prefetch' href='//s2.wp.com'/><link rel='dns-prefetch' href='//public-api.wordpress.com'/><link rel='dns-prefetch' href='//0.gravatar.com'/><link rel='dns-prefetch' href='//1.gravatar.com'/><link rel='dns-prefetch' href='//2.gravatar.com'/><link rel='dns-prefetch' href='//widgets.wp.com'/><link rel='dns-prefetch' href='//i0.wp.com'/><link rel='dns-prefetch' href='//i1.wp.com'/><link rel='dns-prefetch' href='//i2.wp.com'/><style type='text/css'>img#wpstats{display:none}</style><!--[if lt IE 9]> <script src="http://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js"></script> <script src="http://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js"></script> <![endif]--><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style> <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async></script> <script>window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("http://linuxtechlab.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = '4aa7dae9-6300-464c-a817-ed5ca97dd617';
oneSignal_options['autoRegister'] = true;
oneSignal_options['httpPermissionRequest'] = { };
oneSignal_options['httpPermissionRequest']['enable'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "LiNUX TechL@b";
oneSignal_options['welcomeNotification']['message'] = "Thank you for subscribing !!!";
oneSignal_options['subdomainName'] = "https://linuxtechlab.onesignal.com";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5ccade99-0f35-4775-9ae0-5e2c3bfd110b";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-right';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'large';
oneSignal_options['notifyButton']['prenotify'] = true;
oneSignal_options['notifyButton']['displayPredicate'] = function() {
              return OneSignal.isPushNotificationsEnabled()
                      .then(function(isPushEnabled) {
                          return !isPushEnabled;
                      });
            };
oneSignal_options['notifyButton']['showCredit'] = true;
oneSignal_options['notifyButton']['text'] = {};
oneSignal_options['notifyButton']['text']['message.prenotify'] = 'Click to subscribe notifications ';
oneSignal_options['notifyButton']['text']['tip.state.unsubscribed'] = 'Subscribe to notification';
oneSignal_options['notifyButton']['text']['tip.state.subscribed'] = 'You have subscribed ';
oneSignal_options['notifyButton']['text']['tip.state.blocked'] = 'You have blocked notifications';
oneSignal_options['notifyButton']['text']['message.action.subscribed'] = 'Thanks for subscribing !!!';
oneSignal_options['notifyButton']['text']['message.action.resubscribed'] = 'You are subscribed !!!';
oneSignal_options['notifyButton']['text']['message.action.unsubscribed'] = 'Notifications ?? No more';
oneSignal_options['notifyButton']['text']['dialog.main.title'] = 'Manafe site notifications';
oneSignal_options['notifyButton']['text']['dialog.main.button.subscribe'] = 'SUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.main.button.unsubscribe'] = 'UNSUBSCRIBE';
oneSignal_options['notifyButton']['text']['dialog.blocked.title'] = 'Unblock Notifications';
oneSignal_options['notifyButton']['text']['dialog.blocked.message'] = 'Follow instructions  to allow notifications';
              OneSignal.init(window._oneSignalInitOptions);
                    });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }</script> <link rel="icon" href="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=32%2C32" sizes="32x32" /><link rel="icon" href="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=192%2C192" sizes="192x192" /><link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=180%2C180" /><meta name="msapplication-TileImage" content="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Logomakr_95pQXj-1.png?fit=270%2C270" /><style type="text/css" id="wp-custom-css">/*
You can add your own CSS here.

Click the help icon above to learn more.

Use this field to test small chunks of CSS code. For important CSS customizations, it is recommended to modify the style.css file of a child theme.
http//codex.wordpress.org/Child_Themes
*/
.single-post-meta{
display:none;
}

body, html {
color: #000000;
}

.entry {
    color: #000000 !important;
}</style></head><body class="post-template-default single single-post postid-1010 single-format-standard wp-custom-logo col-2cl boxed topbar-enabled mobile-sidebar-hide-s2 header-desktop-sticky header-mobile-sticky unknown"><div id="wrapper"><header id="header" class="main-menu-mobile-on one-mobile-menu main_menu header-ads-desktop  topbar-transparent no-header-img"><nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1"><div class="mobile-title-logo-in-header"><p class="site-title"><a class="custom-logo-link" href="http://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page"><img src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Blend.png?fit=968%2C130" alt="LinuxTechLab"></a></p></div><div class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false"><div class="ham__navbar-span-wrapper"> <span class="line line-1"></span> <span class="line line-2"></span> <span class="line line-3"></span></div></div><div class="nav-text"></div><div class="nav-wrap container"><ul class="nav container-inner group mobile-search"><li><form method="get" class="searchform themeform" action="http://linuxtechlab.com/"><div> <input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></li></ul><ul id="menu-top-navigation" class="nav container-inner group"><li id="menu-item-65" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a href="http://linuxtechlab.com">Home</a></li><li id="menu-item-10" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="http://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li id="menu-item-1994" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1994"><a href="http://linuxtechlab.com/devops/">DevOps</a></li><li id="menu-item-11" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="http://linuxtechlab.com/scripting/">Scripting</a></li><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a href="http://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li id="menu-item-2289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a href="http://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li id="menu-item-269" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a href="http://linuxtechlab.com/contact-us-2/">Contact us</a></li></ul></div></nav><nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2"><div class="nav-text"></div><div class="topbar-toggle-down"> <i class="fa fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i> <i class="fa fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i></div><div class="nav-wrap container"><ul id="menu-top-navigation-1" class="nav container-inner group"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a href="http://linuxtechlab.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="http://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1994"><a href="http://linuxtechlab.com/devops/">DevOps</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="http://linuxtechlab.com/scripting/">Scripting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a href="http://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a href="http://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a href="http://linuxtechlab.com/contact-us-2/">Contact us</a></li></ul></div><div id="topbar-header-search" class="container"><div class="container-inner"><div class="toggle-search"><i class="fa fa-search"></i></div><div class="search-expand"><div class="search-expand-inner"><form method="get" class="searchform themeform" action="http://linuxtechlab.com/"><div> <input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></div></div></div></div></nav><div class="container group"><div class="container-inner"><div class="group pad central-header-zone"><div class="logo-tagline-group"><p class="site-title"><a class="custom-logo-link" href="http://linuxtechlab.com/" rel="home" title="LinuxTechLab | Home page"><img src="https://i2.wp.com/linuxtechlab.com/wp-content/uploads/2017/01/cropped-Blend.png?fit=968%2C130" alt="LinuxTechLab"></a></p><p class="site-description">Linux Devops Tutorial, Scripting tutorials, how to&#039;s , Tips &amp; Tricks</p></div></div><nav class="nav-container group desktop-menu " id="nav-header" data-menu-id="header-3"><div class="nav-text"></div><div class="nav-wrap container"><ul id="menu-top-navigation-2" class="nav container-inner group"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-65"><a href="http://linuxtechlab.com">Home</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10"><a href="http://linuxtechlab.com/how-tos/">How To&#8217;s</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1994"><a href="http://linuxtechlab.com/devops/">DevOps</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11"><a href="http://linuxtechlab.com/scripting/">Scripting</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-12"><a href="http://linuxtechlab.com/tips-tricks/">Tips &#038; Tricks</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2289"><a href="http://linuxtechlab.com/free-linux-books/">Free E-Books</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-269"><a href="http://linuxtechlab.com/contact-us-2/">Contact us</a></li></ul></div></nav></div></div></header><div class="container" id="page"><div class="container-inner"><div class="main"><div class="main-inner group"><section class="content"><div class="page-title pad group"><ul class="meta-single group"><li class="category"><a href="http://linuxtechlab.com/tips-tricks/" rel="category tag">Tips &amp; Tricks</a></li></ul></div><div class="pad group"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><article class="post-1010 post type-post status-publish format-standard has-post-thumbnail hentry category-tips-tricks tag-centos tag-date tag-linux-commands tag-redhat tag-rhel tag-system-administrator tag-time"><div class="post-inner group"><h1 class="post-title entry-title">Playing with Date &#038; Time in RHEL/CentOS</h1><p class="post-byline">by <span class="vcard author"> <span class="fn"><a href="http://linuxtechlab.com/author/shsuain/" title="Posts by Shusain" rel="author">Shusain</a></span> </span> &middot; <span class="published">December 7, 2017</span></p><div class="clear"></div><div class="entry themeform"><div class="entry-inner"><p>In this tutorial, we are going to discuss how we can view or modify date &amp; time values in our RHEL/CentOS 7 servers. We are going to discuss 3 commands which we can use to view/modify date &amp; time for our systems. Before we discuss the commands, let’s learn in brief about two different types of clocks available i.e. system clocks &amp; Hardware clocks,</p><div class='code-block code-block-2' style='margin: 8px 0; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><p><strong>System clock</strong> or <strong>software clock</strong> is maintained by OS, kernel in particular &amp; is initialized when your system boots up while the <strong>Hardware clock</strong> or <strong>Real time clock (RTC)</strong> is independent of the OS &amp; works even when the system is closed. It draws power from BIOS battery to continue working. Now let’s move onto the commands which we will use to work with these clocks.</p><ul><li><strong>Timedatectl command</strong> – was introduced as a part of systemd in version 7 of RHEL/CentOS. It allows us to change/view the system clock.</li><li><strong>Date command</strong>&#8211; is available for all the Linux distributions &amp; is used to review/modify system clock.</li><li><strong>Hwclock command</strong> – is used for accessing hardware clock of the system&amp; is used for displaying time from the hardware clock</li></ul><h2><strong>TIMEDATECTL command </strong></h2><p>&nbsp;</p><h4><strong>Display Date &amp; Time</strong></h4><p>To view current date &amp; time of your system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ timedatectl<br /> </strong></p></div><p>&nbsp;</p><h4><strong>Changing Time</strong></h4><p>To change the time of the system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ timedatectl set-time HH:MM:SS<br /> </strong></p></div><p>Where, <strong>HH</strong> means hour,<strong> MM</strong> means minutes &amp; <strong>SS</strong> means seconds.</p><p>&nbsp;</p><h4><strong>Changing Date</strong></h4><p>To change the date of the system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ timedatectl set-time ‘YYYY-MM-DD  HH:MM:SS’<br /> </strong></p></div><p>Where, <strong>YYYY</strong> is the year, <strong>MM</strong> is the month &amp; <strong>DD</strong> is the day of the month. We also need to specify the time otherwise it will be set as 00:00:00.</p><p>&nbsp;</p><h4><strong>Changing time-zones</strong></h4><p>Firstly to change the time-zone of a system clock, we need to find the time-zone that we need to set. To find the time zone, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ timedatectl list-timezones<br /> </strong></p></div><p>It will display the list of available time-zones. Select the zone &amp; run the following command to set it,</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ timedatectl set-timezonetime_zone (Asia/dhaka).<br /> </strong></p></div><p>&nbsp;</p><h2><strong>DATE command</strong></h2><p>&nbsp;</p><h4><strong>Display Date &amp; Time</strong></h4><p>To view current date &amp; time of your system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date<br /> </strong></p></div><p>We can also customize the display date format using,</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date +”MM:HH:SS”<br /> </strong></p></div><p>&nbsp;</p><h4><strong>Changing Time</strong></h4><p>To change the time of the system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date +%T –s “HH:MM:SS”<br /> </strong></p></div><p>It will set the time in 24-hour format. To use time in AM/PM format, use</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date +%T%P –s “HH:MM:SSAM”<br /> </strong></p></div><p>&nbsp;</p><h4><strong>Changing Date</strong></h4><p>To change the date of the system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date –s ‘DD MM YYYY  HH:MM:SS’<br /> </strong></p></div><p>To set the date in customized format, use</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ date %y%m%d –s “YYYYMMDD”<br /> </strong></p></div><p><strong> </strong></p><h2><strong>HWCLOCK command</strong></h2><p>&nbsp;</p><h4><strong>Display Date &amp; Time</strong></h4><p>To view current date &amp; time of your Hardware clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ hwclock<br /> </strong></p></div><p>&nbsp;</p><h4><strong>Changing Date &amp;Time</strong></h4><p>To change the time of the Hardware clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ hwclock &#8211; &#8211; set &#8211; &#8211; date “DD MM YYYY HH:MM”<br /> </strong></p></div><p>&nbsp;</p><h4>Synchronizing Date &amp; Time</h4><p>To synchronize Hardware clock to system clock, run</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ hwclock &#8211; &#8211; systohc<br /> </strong></p></div><p>Or to synchronize system clock to hardware clock ,</p><div style="background-color: #33363b; width: 700px; border: 2px solid black;"><p style="margin: 0; padding: 5px;"><strong style="color: #fbfafa;">$ hwclock &#8211; &#8211; hctosys<br /> </strong></p></div><p>These were some commands to review/modify the date &amp; time of your machine. If you have some queries/issues regarding the above , please leave them in the comment box below.</p><p>&nbsp;</p><div style="padding: 1.5em; background: #E1DDDD; border: 0.125em solid #c5dbe5; border-width: 0.125em 0;"><p style="margin-bottom: 0.75em;">If you think we have helped you or just want to support us, please consider these :-</p><p style="margin-bottom: 0.75em;">Connect to us: <a href="https://www.facebook.com/techlablinux/"><span style="color: #ff0000;">Facebook</span></a> | <a href="https://twitter.com/LinuxTechLab"><span style="color: #ff0000;">Twitter</span></a> | <a href="https://plus.google.com/+linuxtechlab"><span style="color: #ff0000;">Google Plus</span></a></p><p style="margin-bottom: 0.75em;"><p style="margin-bottom: 0.75em;">Linux TechLab is thankful for your continued support.</p></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this post:</h3><div class="sd-content"><ul><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-1010" class="share-facebook sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-1010" class="share-linkedin sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-1010" class="share-twitter sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-1010" class="share-google-plus-1 sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="whatsapp://send?text=Playing%20with%20Date%20%26%20Time%20in%20RHEL%2FCentOS http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-1010" class="share-pinterest sd-button share-icon no-text" href="http://linuxtechlab.com/playing-date-time-rhelcentos/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='code-block code-block-1' style='margin: 8px 0; text-align: left; clear: both;'> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>  <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></div><nav class="pagination group"></nav></div><div class="clear"></div></div></div></article><div class="clear"></div><p class="post-tags"><span>Tags:</span> <a href="http://linuxtechlab.com/tag/centos/" rel="tag">centos</a><a href="http://linuxtechlab.com/tag/date/" rel="tag">date</a><a href="http://linuxtechlab.com/tag/linux-commands/" rel="tag">linux commands</a><a href="http://linuxtechlab.com/tag/redhat/" rel="tag">redhat</a><a href="http://linuxtechlab.com/tag/rhel/" rel="tag">RHEL</a><a href="http://linuxtechlab.com/tag/system-administrator/" rel="tag">system administrator</a><a href="http://linuxtechlab.com/tag/time/" rel="tag">time</a></p><div class="author-bio"><div class="bio-avatar"><img alt='' src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&#038;r=g' srcset="" data-srcset='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=256&#038;r=g 2x' class='lazy lazy-hidden avatar avatar-128 photo' height='128' width='128' /><noscript><img alt='' src='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=128&#038;r=g' srcset='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=256&#038;r=g 2x' class='avatar avatar-128 photo' height='128' width='128' /></noscript></div><p class="bio-name">Shusain</p><p class="bio-desc"><p>Passionate about Linux .<br /> Loves to learn, read &amp; write about new technologies.</p></p><div class="clear"></div></div><h4 class="heading"> <i class="fa fa-hand-o-right"></i>You may also like...</h4><ul class="related-posts group"><li class="related post-hover"><article class="post-1320 post type-post status-publish format-standard has-post-thumbnail hentry category-tips-tricks tag-text-editor tag-vi"><div class="post-thumbnail"> <a href="http://linuxtechlab.com/working-vi-editor-basics/" title="Working with VI editor : The Basics"> <img width="520" height="245" src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" class="lazy-hidden attachment-thumb-medium size-thumb-medium wp-post-image" alt="vi editor" sizes="(max-width: 520px) 100vw, 520px" data-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/05/VI-editor-the-basics.jpg?resize=520%2C245" data-lazy-type="image" data-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/05/VI-editor-the-basics.jpg?w=720 720w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/05/VI-editor-the-basics.jpg?resize=300%2C142 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/05/VI-editor-the-basics.jpg?resize=520%2C245 520w" /> </a></div><div class="related-inner"><h4 class="post-title entry-title"> <a href="http://linuxtechlab.com/working-vi-editor-basics/" rel="bookmark" title="Working with VI editor : The Basics">Working with VI editor : The Basics</a></h4><div class="post-meta group"><p class="post-date"> <time class="published updated" datetime="2017-05-11 20:19:50">May 11, 2017</time></p></div></div></article></li><li class="related post-hover"><article class="post-1839 post type-post status-publish format-standard has-post-thumbnail hentry category-tips-tricks tag-disk-cloning tag-linux-commands tag-monitoring"><div class="post-thumbnail"> <a href="http://linuxtechlab.com/useful-linux-commands-you-should-know/" title="Useful Linux Commands that you should know"> <img width="520" height="245" src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" class="lazy-hidden attachment-thumb-medium size-thumb-medium wp-post-image" alt="useful linux commands" sizes="(max-width: 520px) 100vw, 520px" data-src="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Useful-Linux-Commands-that-you-should-know.jpg?resize=520%2C245" data-lazy-type="image" data-srcset="https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Useful-Linux-Commands-that-you-should-know.jpg?w=720 720w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Useful-Linux-Commands-that-you-should-know.jpg?resize=300%2C142 300w, https://i1.wp.com/linuxtechlab.com/wp-content/uploads/2017/09/Useful-Linux-Commands-that-you-should-know.jpg?resize=520%2C245 520w" /> </a></div><div class="related-inner"><h4 class="post-title entry-title"> <a href="http://linuxtechlab.com/useful-linux-commands-you-should-know/" rel="bookmark" title="Useful Linux Commands that you should know">Useful Linux Commands that you should know</a></h4><div class="post-meta group"><p class="post-date"> <time class="published updated" datetime="2017-09-10 11:34:54">September 10, 2017</time></p></div></div></article></li><li class="related post-hover"><article class="post-425 post type-post status-publish format-standard has-post-thumbnail hentry category-tips-tricks tag-grub tag-linux-commands tag-redhat tag-rhel tag-system-administrator"><div class="post-thumbnail"> <a href="http://linuxtechlab.com/secure-grub-centos-rhel/" title="How to secure Grub in Centos/RHEL 5/6/7 &#038; 7.2"> <img width="520" height="245" src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" class="lazy-hidden attachment-thumb-medium size-thumb-medium wp-post-image" alt="secure grub" sizes="(max-width: 520px) 100vw, 520px" data-src="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Beginners-guide-to-Securing-GRUB-1.jpg?resize=520%2C245" data-lazy-type="image" data-srcset="https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Beginners-guide-to-Securing-GRUB-1.jpg?w=720 720w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Beginners-guide-to-Securing-GRUB-1.jpg?resize=300%2C142 300w, https://i0.wp.com/linuxtechlab.com/wp-content/uploads/2017/02/Beginners-guide-to-Securing-GRUB-1.jpg?resize=520%2C245 520w" /> </a></div><div class="related-inner"><h4 class="post-title entry-title"> <a href="http://linuxtechlab.com/secure-grub-centos-rhel/" rel="bookmark" title="How to secure Grub in Centos/RHEL 5/6/7 &#038; 7.2">How to secure Grub in Centos/RHEL 5/6/7 &#038; 7.2</a></h4><div class="post-meta group"><p class="post-date"> <time class="published updated" datetime="2017-11-24 05:12:55">November 24, 2017</time></p></div></div></article></li></ul><section id="comments" class="themeform"><h3 class="heading">2 Responses</h3><ul class="comment-tabs group"><li class="active"><a href="#commentlist-container"><i class="fa fa-comments-o"></i>Comments<span>2</span></a></li><li><a href="#pinglist-container"><i class="fa fa-share"></i>Pingbacks<span>0</span></a></li></ul><div id="commentlist-container" class="comment-tab"><ol class="commentlist"><li class="comment even thread-even depth-1 parent" id="comment-47"><div id="div-comment-47" class="comment-body"><div class="comment-author vcard"> <img alt='' src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='http://2.gravatar.com/avatar/23dc0eab4945b73530379ae159f52007?s=48&#038;r=g' srcset="" data-srcset='http://2.gravatar.com/avatar/23dc0eab4945b73530379ae159f52007?s=96&#038;r=g 2x' class='lazy lazy-hidden avatar avatar-48 photo' height='48' width='48' /><noscript><img alt='' src='http://2.gravatar.com/avatar/23dc0eab4945b73530379ae159f52007?s=48&#038;r=g' srcset='http://2.gravatar.com/avatar/23dc0eab4945b73530379ae159f52007?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript> <cite class="fn">fans</cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"><a href="http://linuxtechlab.com/playing-date-time-rhelcentos/#comment-47"> May 29, 2017 at 12:26 pm</a></div><p>Dear Sir<br /> I want to know how i can change date and time permanently means If i will restart my server it should not be change it should remains same as befor.</p><div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://linuxtechlab.com/playing-date-time-rhelcentos/?replytocom=47#respond' onclick='return addComment.moveForm( "div-comment-47", "47", "respond", "1010" )' aria-label='Reply to fans'>Reply</a></div></div><ul class="children"><li class="comment byuser comment-author-shsuain bypostauthor odd alt depth-2" id="comment-49"><div id="div-comment-49" class="comment-body"><div class="comment-author vcard"> <img alt='' src="//linuxtechlab.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=48&#038;r=g' srcset="" data-srcset='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=96&#038;r=g 2x' class='lazy lazy-hidden avatar avatar-48 photo' height='48' width='48' /><noscript><img alt='' src='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=48&#038;r=g' srcset='http://1.gravatar.com/avatar/4200ffb9e23e656b6eae0ef398e2fe5a?s=96&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /></noscript> <cite class="fn"><a href='http://linuxtechlab.com' rel='external nofollow' class='url'>Shusain</a></cite> <span class="says">says:</span></div><div class="comment-meta commentmetadata"><a href="http://linuxtechlab.com/playing-date-time-rhelcentos/#comment-49"> May 30, 2017 at 7:39 pm</a></div><p>All these commands are used to send date permanently only. If your server is getting reset to an old date and time, then its probably because of an old CMOS battery.</p><div class="reply"><a rel='nofollow' class='comment-reply-link' href='http://linuxtechlab.com/playing-date-time-rhelcentos/?replytocom=49#respond' onclick='return addComment.moveForm( "div-comment-49", "49", "respond", "1010" )' aria-label='Reply to Shusain'>Reply</a></div></div></li></ul></li></ol></div><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/playing-date-time-rhelcentos/#respond" style="display:none;">Cancel reply</a></small></h3><form id="commentform" class="comment-form"> <iframe src="http://jetpack.wordpress.com/jetpack-comment/?blogid=124285797&#038;postid=1010&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=5.6&#038;sig=8971f53c550d275cfedf13cc41ceaefde4764188#parent=http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment"></iframe> <!--[if !IE]><!--> <script>document.addEventListener('DOMContentLoaded', function () {
						var commentForms = document.getElementsByClassName('jetpack_remote_comment');
						for (var i = 0; i < commentForms.length; i++) {
							commentForms[i].allowTransparency = false;
							commentForms[i].scrolling = 'no';
						}
					});</script> <!--<![endif]--></form></div> <input type="hidden" name="comment_parent" id="comment_parent" value="" /></section></div></section><div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1"><a class="sidebar-toggle" title="Expand Sidebar"><i class="fa icon-sidebar-toggle"></i></a><div class="sidebar-content"><div class="sidebar-top group"><p>Follow:</p><ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#00b3c4"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#00b3c4"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#00b3c4"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#00b3c4"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#00b3c4"><i class="fa fa-rss"></i></a></li></ul></div><ul class="post-nav group"><li class="next"><a href="http://linuxtechlab.com/complete-guide-apache-tomcat-installation-linux/" rel="next"><i class="fa fa-chevron-right"></i><strong>Next story</strong> <span>Complete guide for Apache TOMCAT installation on Linux</span></a></li><li class="previous"><a href="http://linuxtechlab.com/linux-server-glances-monitoring-tool/" rel="prev"><i class="fa fa-chevron-left"></i><strong>Previous story</strong> <span>Real Time Linux server monitoring with GLANCES monitoring tool</span></a></li></ul><div id="search-2" class="widget widget_search"><form method="get" class="searchform themeform" action="http://linuxtechlab.com/"><div> <input type="text" class="search" name="s" onblur="if(this.value=='')this.value='To search type and hit enter';" onfocus="if(this.value=='To search type and hit enter')this.value='';" value="To search type and hit enter" /></div></form></div><div id="facebook-likebox-2" class="widget widget_facebook_likebox"><h3 class="widget-title"><a href="https://www.facebook.com/linuxtechlab/">Facebook Fan Page</a></h3><div id="fb-root"></div><div class="fb-page" data-href="https://www.facebook.com/linuxtechlab/" data-width="450"  data-height="432" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/linuxtechlab/"><a href="https://www.facebook.com/linuxtechlab/">Facebook Fan Page</a></blockquote></div></div></div><div id="text-7" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="3826838966"
data-ad-format="auto"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div><div id="recent-posts-2" class="widget widget_recent_entries"><h3 class="widget-title">Recent Posts</h3><ul><li> <a href="http://linuxtechlab.com/complete-guide-apache-tomcat-installation-linux/">Complete guide for Apache TOMCAT installation on Linux</a></li><li> <a href="http://linuxtechlab.com/playing-date-time-rhelcentos/">Playing with Date &#038; Time in RHEL/CentOS</a></li><li> <a href="http://linuxtechlab.com/linux-server-glances-monitoring-tool/">Real Time Linux server monitoring with GLANCES monitoring tool</a></li></ul></div><div id="text-10" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle"
style="display:block"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="3826838966"
data-ad-format="auto"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></div></div></div></div></div><footer id="footer"><section class="container" id="footer-full-width-widget"><div class="container-inner"><div id="text-13" class="widget widget_text"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <br /> <ins class="adsbygoogle"
style="display:inline-block;width:728px;height:90px"
data-ad-client="ca-pub-9186837757068891"
data-ad-slot="9733771768"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p></div></div></div></section><section class="container" id="footer-bottom"><div class="container-inner"><a id="back-to-top" href="#"><i class="fa fa-angle-up"></i></a><div class="pad group"><div class="grid one-half"><div id="copyright"><p>LinuxTechLab &copy; 2017. All Rights Reserved.</p></div></div><div class="grid one-half last"><ul class="social-links"><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Facebook" href="https://www.facebook.com/linuxtechlab/" target="_blank"  style="color:#00b3c4"><i class="fa fa-facebook"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Twitter" href="https://twitter.com/LinuxTechLab" target="_blank"  style="color:#00b3c4"><i class="fa fa-twitter"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Google-plus" href="https://plus.google.com/+linuxtechlab" target="_blank"  style="color:#00b3c4"><i class="fa fa-google-plus"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Linkedin" href="https://www.linkedin.com/in/linux-techlab-9963b9138/" target="_blank"  style="color:#00b3c4"><i class="fa fa-linkedin"></i></a></li><li><a rel="nofollow" class="social-tooltip"  title="Follow us on Rss" href="http://feeds.feedburner.com/LnuxTech-lb" target="_blank"  style="color:#00b3c4"><i class="fa fa-rss"></i></a></li></ul></div></div></div></section></footer></div> <script type="text/javascript">window.WPCOM_sharing_counts = {"http:\/\/linuxtechlab.com\/playing-date-time-rhelcentos\/":1010};</script> <div id="sharing_email" style="display: none;"><form action="/playing-date-time-rhelcentos/" method="post"> <label for="target_email">Send to Email Address</label> <input type="email" name="target_email" id="target_email" value="" /> <label for="source_name">Your Name</label> <input type="text" name="source_name" id="source_name" value="" /><label for="source_email">Your Email Address</label> <input type="email" name="source_email" id="source_email" value="" /><input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" /> <img style="float: right; display: none" class="loading" src="http://linuxtechlab.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" /> <input type="submit" value="Send Email" class="sharing_send" /> <a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a><div class="errors errors-1" style="display: none;"> Post was not sent - check your email addresses!</div><div class="errors errors-2" style="display: none;"> Email check failed, please try again</div><div class="errors errors-3" style="display: none;"> Sorry, your blog cannot share posts by email.</div></form></div> <script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js'></script> <script type='text/javascript'>var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"1","extLinksTargetExt":"1","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":true,"mobile":true},"isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_up","mobile":"stick_up"},"isDevMode":"","ajaxUrl":"http:\/\/linuxtechlab.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"da3398985f"},"userStarted":{"with":"before|3.3.4","on":{"date":"2017-05-19 02:16:15.000000","timezone_type":3,"timezone":"UTC"}},"isWelcomeNoteOn":"","welcomeContent":""};</script> <script type='text/javascript'>var jpfbembed = {"appid":"249643311490","locale":"en_US"};</script> <script type='text/javascript'>var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};</script> <script type='text/javascript'>var a3_lazyload_extend_params = {"edgeY":"0"};
var a3_lazyload_extend_params = {"edgeY":"0"};</script> <script type='text/javascript'>var rm_pre_data = {"ajax_url":"http:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","rm_nonce_field":"dd95006b02"};</script> <script type='text/javascript'>var icegram_pre_data = {"ajax_url":"http:\/\/linuxtechlab.com\/wp-admin\/admin-ajax.php","post_obj":{"is_home":false,"page_id":1010,"action":"display_messages","shortcodes":[],"cache_compatibility":"yes","device":"laptop"}};</script> <script type='text/javascript'>var sharing_js_options = {"lang":"en","counts":"1"};</script> <script type='text/javascript'>var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});</script> <!--[if lt IE 9]> <script src="http://linuxtechlab.com/wp-content/themes/hueman/assets/front/js/ie/respond.js"></script> <![endif]--><!--[if IE]> <script type="text/javascript">if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}</script> <![endif]--> <script type="text/javascript">(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=124285797&postid=1010&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.6&sig=8971f53c550d275cfedf13cc41ceaefde4764188#parent=http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "http://jetpack.wordpress.com/jetpack-comment/?blogid=124285797&postid=1010&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=5.6&sig=8971f53c550d275cfedf13cc41ceaefde4764188#parent=http%3A%2F%2Flinuxtechlab.com%2Fplaying-date-time-rhelcentos%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "http:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();</script> <script type='text/javascript' src='https://stats.wp.com/e-201749.js' async defer></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.6',blog:'124285797',post:'1010',tz:'5.5',srv:'linuxtechlab.com'} ]);
	_stq.push([ 'clickTrackerInit', '124285797', '1010' ]);</script>  <script type="text/javascript" defer src="http://linuxtechlab.com/wp-content/cache/autoptimize/js/autoptimize_784a5a68d24770b69dafbc08d20b4e3a.js"></script></body></html>
<!-- Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced

 Served from: linuxtechlab.com @ 2017-12-08 14:30:43 by W3 Total Cache -->